realvnc problems with linux

By dani190 ยท 11 replies
Mar 24, 2007
  1. hey guys, i installed realvnc on fedora core 6. But whenever i try to start it, it says its started but when i check it isn't, and when i go to kill the process i cant because it doesn't exist (meaning it hasn't started) anyone have any ideas how to fix this. I have been working on getting this to work all day and i am stuck on this last problem. Just not to long ago i was able to connect from my linux server to my windows laptop fine, but from the windows laptop to the linux server it wont work and i think its because realvnc server isn't even started.

    Any ideas? as you might guess i am quite anxious to get this working.
  2. McBob

    McBob TS Rookie

    vnc server

    First off, which distributors linux are you running?
    (i recommend DEBIAN-its free and im my experiance just flat out better)
    (also comes with 2 preset GUIs these may be helpfull for noobs)
    Just a peice of avice try using an edited Telnet server, for more security.
    who knos it might better than what you had in mind to begin with.
    (its what i did,) :)

    Questions and mored Email to
  3. dani190

    dani190 TS Rookie Topic Starter

    telnet are you kidding me thats such a un secure thing. Im running fedora core 6 if you read what i wrote.
  4. McBob

    McBob TS Rookie

    lol, your right(sorta)

    its only unsecure if u dont know how to use linux to edit the servers
    functionality(reprogram the Parameters-AKA:rewrite a nock-off version, just remember to install to the nock-off version to the other comp or the server will crash= or be hakd)
    if you chose not to do this your not alone, but im too lazy and preoccupied to do anything else , if you rather use vnc try another distributor like tihgt, or ultra, if still having problems vist
    for a walk through

    Questions and more Email to
  5. dani190

    dani190 TS Rookie Topic Starter

    telnet is unsecure period no matter what you do
  6. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    use SSH; it replaces BOTH Telnet & FTP with encrypted data flows
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Uhm.. The point of VNC is to control the graphical desktop on another machine. Telnet or SSH are not going to help anything except that one could tunnel VNC through SSH for added security.

    dani: there is no VNC process, because the VNC server you activated is a module of the X server and runs as a part of that.
  8. dani190

    dani190 TS Rookie Topic Starter

    i still don't get how to make this work here is a post i made on another board which is insisting on not helping so lets see if someone here knows whats going on.

    Anyone have an idea what i can do?

    maybe it could be my linux firewall the iptables or w.e

    any ideas?

    or maybe the service ain't started how would i check
  9. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    that looks like you tried to connect using some name instead of an IP address.

    you must remember that your client systems do not(normally) have a public name/address pair
    and you must connect using IP addresses.

    The first to for client/server access is ALWAYS
    system-a: ping system-b
    system-b: ping system-a​
    first use only IP addresses for ping and then try names. you will likely see
    that only address will work.
  10. dani190

    dani190 TS Rookie Topic Starter

    nope i used the ip address statically set
  11. dani190

    dani190 TS Rookie Topic Starter

    some more details....
    When i enter the command vncserver :1

    i get this message New "IP" (root)' desktop is IP

    starting applications specified in /root/.vnc/xstartup
    log file is /root/.vnc/IP.log

    then i use the command ps -ax to check if the process is running and i do not find the process vncserver which should be there if it was running.

    Any ideas?
  12. dani190

    dani190 TS Rookie Topic Starter

    i just found more info out,

    when i ran rpm -e vnc it gets rid of it i think but then i type vncserver and i still get stuff, how do i cleanly uninstall this?

    i also started x0vncserver and its listening now i try to connect but asks for a password, i enter the 1 i set it doesnt work says no password configured for vnc auth.

    When i go and set it again using vncpasswd it doesnt come up with any error messages but then i try again and it still gives the same message.

    Can someone please please please help me i really want to get this working, this is the last problem i have and i am done
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...