Referenced Memory Error

By Biznich ยท 271 replies
Nov 15, 2003
  1. Spyder07

    Spyder07 TS Rookie

    Referenced Memory

    Hello i try to start to start a certain game that I play and this is the error I recieve.

    The instruction at 0x10c9765 refereneced memory at 0x00c3f000
    The memory could not be read

    Press ok to terminate program.

    I read trought the past treads but i cant figured out anything that could fix it. Someone please help

  2. herrfrog

    herrfrog TS Rookie

    Alyx, it could be any number of things. I tried a number of the things recommmended here at this forum and one finally worked. And I started with restoring from a backup, which didn't work, and tried the registry hack that de redder recommended, which worked for about 3 days, then cleaning and defragging the hard drive, cleaning the hardware, testing the RAM, updating my Java package, replacing that installshield engine, updated Flash, removed an unused printer from the My Printers folder. I am not sure whether any one of these things did the trick for me, or if it was a combination of more than one. But I am no longer having this error, "knock on wood." I think this error is caused by a number of possible causes and is different from one person to another, at least some of the time. During this troublesome quest though, I did find that one version of Flash is not compatible with several things, including the installer for my Creative keyboard, that there were some problems with an older version of Java that might have contributed, and other stuff. But to just blame your antivirus software is not a good idea, to say the least.
  3. Tortel

    Tortel TS Rookie

    I have recently gotten this error too, but it happens with random apps, even my screen saver.

    This is really annoying me, I read the first page and I think ill check if the memory connections are clean. I have a P4 3ghz OC'ed to 3.15, 1 gig o RAM, gforce fx5200.

    If not the connections or windows fault, it could be the old FX5200 or my overclocking that causes this.
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Since your getting this in both your game and screen saver you need to start testing the RAM for memory problems. If the RAM tested okay then the OS is corrupt. If it only happen in a software program most likey it's the software causing the problem.

    MEMTEST86 can tell you if the RAM is good or not. AGain all RAM can go bad. You should make sure your system is getting enough air-intake and air-outtake.

    Overclocking if done right you should be okay. I got all my systems CPU and GPU overclocked, but have the right amount of air coming in and out.. But first test your RAM to see if it's running okay. There are lots of free memory testers online you can use.
  5. herrfrog

    herrfrog TS Rookie

    BTW, if you get an error message in Windows XP or 2K, you can just hit Ctrl-C when the error message has the focus and it will copy the text of it so you can paste it here, and not have to take screenshots. :)

    And I wouldn't say it was necessarily a corrupt OS. But if it is, I may have gotten this from this thread, I can't remember, but it is an especially good tip:
    And it works for W2K as well. (You have to have your install disk in the drive to do it.) So this may be the first thing to try. Easy and doesn't take too long. So I suggest doing that as well as testing your ram. And then take a good look at all the posts on this thread. I also found relevant threads about the installshield engine getting corrupted, and an older version of java engine causing problems like this. Both are solved by replacing the older one.
  6. Cobbicus

    Cobbicus TS Rookie

    Similar Problem

    Essentially, my problem is the same, but more specific in what is affected by it.

    I've had it for around six or eight weeks, I think.

    The exact message is:

    explorer.exe - Application Error
    The instruction at "0x022e2f8a" referenced memory at "0x022e2f8a". The memory could not be "read".

    Click on OK to terminate the program
    Click on CANCEL to debug the program
    OK Cancel

    Sometimes, rarely, it says "The memory could not be written." instead.

    The numbers aren't a typo, they are almost always the same as each other. Another instruction number that's come up is 0x03692f8a. The interesting thing is the memory that couldn't be read is still the same as the instruction address.

    I just tested it again, only a few minutes after, and the addresses changed. I tried Ctrl-C and pasting somewhere to no avail. However, I got four error messages. The first had an instruction address similar to the first in this post, with the read being the same. The second was the same instruction number with a writing address of 0x0000001. The third changed the instruction address slightly, with the read matching it again. The fourth matched the most recent instruction address with a write address of 0x0000001 again.

    The problem only occurs when I view the contents of a folder that holds avi files from a specific source. I download anime, but not much. During the period this problem has been happening, I have downloaded a complete series from another source, and it works just fine.
    Further, when I delete the file that came from the first source (dattebayo) the problem no longer persists. Note that it is not restricted to one file of theirs, but so far, I think around seven files dating back at least a month and a half. Getting those particular episodes from alternate sources doesn't work. Downloading the files to alternate locations on either of my HDs doesn't work either.

    In all cases of the error, the desktop has to restart and some of the normal processes and apps that start on boot don't restart.

    I have attempted to use the Debug option that comes up. It opens an editor, don't remember which, and displays a window with lots of addresses in a column. Unfortunately, it's beyond my limited expertise at that point.
    When I close the debugger, there's an error message saying:
    "Unhandled exception in explorer.exe 0xC0000005: Access violation".

    Sorry if the answer is somewhere in the thread...but I didn't really want to sift through 12 pages and two years of back posts.
  7. surrealdesi

    surrealdesi TS Rookie

    I get the following error message, PLEASE HELP

    I get the following error message whenever I try to save a file

    - Application Error
    The instruction at "0x7c910e03" referenced memory at "0x49a22e79" The memory could not be "written".
    Click on OK to terminate the program


    my e-mail address is
  8. doohuh

    doohuh TS Rookie

    Several of these memory problems.

    I've had a bunch of these memory error messages, and I'm not sure what to do. I have a recent alienware built system so I don't think it's anything I have personally done.

    Anyway, here are just two of the sets of numbers that always come up with these errors. I read very early in this forum about how people would need to see these codes to determine what the problem is, so here they are:

    "0x7c901095" at "0x7699208b"

    "0x00ca5f6c" at "0x00ca5f6c"

    Any help is greatly appreciated.
  9. superthin

    superthin TS Rookie

    What should we do?

    I find the The instruction at "0x7c910e03" referenced memory at "0x49a22e79" The memory could not be "written". Click on OK to terminate the program can be occured any times and anywhere if PC have Windows 2K or XP (all Service Pack).

    When I use IE, Firefox, and Opera (sometims) even, the error above will be happened. I think: bad RAM (with some error chips) is first factor, virus is second, Java Virtual Machine is third, some of Windows file corrupted is fourth, and conflict of hardwares / softwares (very hard to identify which is main element).

    I think, the solution is we do not use Windows OS , we should use Linux, in Linux I have never deal with this problem.
  10. doohuh

    doohuh TS Rookie

    I say we just sit it out until Vista comes out. ;)
  11. drjay

    drjay TS Rookie

    Sorry to dig up a few week old topic but maybe my problem with it can clear up a few suspicions. Not that it will apply to everyone, but we can maybe rule out "it's ALWAYS X problem" type statements.

    It's not from running out of ram: I have 4 gig
    It's not specific to IE: I get the error in Firefox
    It's not due to overheating: Every component (video included) is well within spec
    It's not due to overclocking: I run the stock settings on a 955 EE
    It's not due to memory errors: Memtest passes *and* for safe measure I just did a warranty return and got fresh ram.
    It's not due to "cheap" ram: I'm using OCZ's latest PC-5400 Gold Edition. Not the most expensive, but certainly not "cheap."
    It *may* not have to do with BIOS or chipset drivers: I'm using all the latest. Doesn't say much, but only that the authors have not found it related to their drivers or bios.

    Oddly enough I've been able to replicate the problem. For some odd reason this video will do it every time:
    (I hear he's neat)

    I can view every other video on that site I try and so far only that one causes problems. On that one I never get past the "Loading..." part. If it locks up for you we're in the same boat.

    I also get frequent lockups when running extremely memory intensive applications. A few games too but mostly things like Premier and such.

    Sorry to have no good news, I have no idea why it happens but maybe this can provide some direction.
  12. Cobbicus

    Cobbicus TS Rookie

    One Solution

    Perhaps I can shed a little light. I posted earlier having a similar problem, but I couldn't open any folder containing avi files from a specific source. The folder would open and I'd get the problem.

    I reformatted my hard drive and reinstalled everything and the problem no longer exists.

    A geekier computer geek than I told me that it sounded like something was allocated wrong when it was written.

    It occurs to me that this can occur with the use of bittorrent clients because they stake claim on storage space for every file they download when the download is initiated. Once the problem is created, it can be a pain in the neck to get rid of, especially since once one file is screwed up like that, others seem to follow suit. The common denominator seems to be the files being downloaded.

    It may also be caused by using more than one file sharing/swarming program at the same time. Example: Bearshare and Azureus. I don't know exactly how Azureus allocates the space for the files, but it's possible Bearshare doesn't recognize this and simply writes wherever it sees unused space, even though the OS knows that Azureus has already claimed the space.

    Further, I did discover that the problem would not go away simply by deleting the file(s) that seem associated with it (good ol' safe mode Dos Prompt).

    Incidentally, since I redid my HD, I've been able to redownload all those files and the problem has not resurfaced.

    Hope this helps.
  13. Stephen123

    Stephen123 TS Rookie

    The instruction at "0x004afa89" referenced memory at "0x00000000". The memory could n

    error message.
    The instruction at "0x004afa89" referenced menory at "0x00000000". The memory could not be "read".

    I get this message consistently on trying to view a form in VB6. I have VBNET 2003 and at first both coexisted fine. But after doing upgrading of VB6 code to VBNet the problem appears. I did memtest. No problem. I just tried uninstalling ISII. no help. Reinstalling VB6 no help. Only thing that works is restoring to a norton ghost 5 month old image in which I had just installed VB.NET 2003. The error goes away until I tried to update VB6 code in Net.
    "0x004afa89" is only mentioned once on a german site. Running Win2K SP4. Pentium 4

    I have no problem with IE (I think). I am guessing this problem might have the same cause as the rest in this thread. Hope someone comes up with an answer.
  14. anguis

    anguis TS Enthusiast Posts: 85   +12

    So Ive been getting these messages on my brand new laptop while playing FEAR and HL2...Im going to try a couple things and wll let you guys know the outcome
  15. anguis

    anguis TS Enthusiast Posts: 85   +12

    Well nope, I tried geting rid of McAfee and it didnt help..have all new hardware and such. HP Compaq nc6320..
    Error on F.E.A.R. is "The instruction at "0x583a95bb" referenced memory at "0x0345fe60". The memory could not be "read". Click on OK to terminate the program.
  16. srikanth.k

    srikanth.k TS Rookie

    Sol: "The instruction at "0x000000000" referenced memory at "0x00000000". The memory

    Hi guys,,

    This Error occurs due to registry in consistency and StartUP Objects..

    so plz clean your Registry for malicious programs which runs hundreds of Threads.

    Clean Registry and Check it out....

  17. Vrall

    Vrall TS Rookie

    I am so glad i found this forum. I've been having the same kind of problem but only on Flyff,(an online game) but nothing else. I have put a forum on there site about this but all of the suggestions didn't work. I get the "The instruction at "0x000000000" referenced memory at "0x00000000". The memory could not be "read" thing and next time i get the game to start up I'll get the numbers/ letters and post them. any help would be really nice
  18. srikanth.k

    srikanth.k TS Rookie

    Reply : to online game

    IE browser has so many Patches to be installed Check the Microsoft for Updations in Internet Explorer it has been Reported that it gives the memory Reference Error./

    Check the OS Patches and IE Patches. your problem Will be Solved
  19. Skullet

    Skullet TS Rookie

    I've had this problem in the past, its generally caused by a faulty video codec, uninstall any video codecs you have and see if the problem persists, if the problem is solved then reinstall your codecs one by one to see if the problem returns, thus you should be able to elliminate the rogue codec.
  20. justcin0803

    justcin0803 TS Rookie

    Reference memory issue

    My issue seems to be a bit different from everyone else. I only get this issue when shutting down my system. I get: The instruction at 0x02a8f207 referenced memory at 0x02a8f207. The memory could not be read.

    I have done the sfc /scannow and that took care of the same issue I had but different string of numbers/letters.

    Anything else I could try?
  21. mavrik72

    mavrik72 TS Rookie

    Possible Solution

    I have not read all of the posts before, but I would like to offer my solution.

    Try recreating the virtual memory.

    For XP system...
    1. Right-click on My Computer and select Properties.
    2. Click the Advanced Tab and select Settings under the Perfomance Options.
    3. Click on the Advanced Tab and select Change under Virtual Memory.
    4. Click No Paging File and clisk Set.
    5. Click OK, OK, OK and tell the system to restart.
    6. Let the system reboot...It will be slower than usual.
    7. Right-click on My Computer and select Properties.
    8. Click the Advanced Tab and select Settings under the Perfomance Options.
    9. Click on the Advanced Tab and select Change under Virtual Memory.
    10. Click Custom Size and set the Initial Size to (1.5 times your Physical Memory.)
    11. Set Maximum to (2 times your Physical Memory.)
    12. Click OK, OK, OK. No reboot required.

    This problem stems from system images. When a manufacturer creates an image and then changes the memory but does not update the image, memory errors can occur. This can even happen when you upgrade your own system memory. Always recreate the Virtual memory after modifying physical memory. It should prevent these types of errors.
  22. justcin0803

    justcin0803 TS Rookie

    Now what?

    I wasn't getting the error when I was on the internet only when shutting down my computer. I made the initial changes to my virtual memory as you I don't get the errors when I shut down I get them when I'm browsing the internet AND I get the error that I'm out of virtual memory...I wasn't getting this before! HELP!
  23. mavrik72

    mavrik72 TS Rookie

    You have to follow ALL of the steps.
  24. justcin0803

    justcin0803 TS Rookie

    I did follow ALL of the steps. I'm a novice, not an *****.

    The problem seems to have been resolved with the sfc /scannow solution (I did this a couple of times)...I haven't been getting any of the reference memory errors for the last few days.
  25. Jerrylouis

    Jerrylouis TS Rookie

    Hello all- I have also been getting these error's for some time now, but have had no time to address them. I read the posts here today and then did some checking. I have the problem anytime I bring up a page from my website that is only displaying an image, when I close this page bam the error. I made an observation that may be of interest. If I bring up an ie page and just leave it minimized and then bring up another page with an image, then close the image page-no error. If I bring up the image page with no other ie page running and close it, I get an error every time. For now I will leave an ie page minimized setting on my home page (google) and see what happens. I also tried changing home pages, but it had no effect, still get error if I close an ie page with an image on it and no other ie page active, yours Jerry
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...