Referenced Memory Error

By Biznich · 271 replies
Nov 15, 2003
  1. hmorwin

    hmorwin TS Rookie


    I am using a computer with the following configuration:

    AMD Athlon XP 3000+, 939 pin processor
    MOBO: MSI RS482M2-IL with bois version: v3.80, release date: 2005-7-29
    RAM: Trancend 512 MB DDR400 RAM-single stick
    Power Supply: Frontech JL2410 (400W SMPS with 24 pin power connector)
    Windows XP/2000 prof

    I bought my computer in the month of November, 2005. Since then, I have been experiencing some problem with access voilation errors and programs getting terminated. I have updated my motherboard with the latest available drivers from MSI website.

    I am got the folliwng error messages when I was using the programs like Internet Explorer or Getright 5.2d(a download manager) and the program is getting terminated This is the case in both Windows XP pro and 2000 Pro:

    1. Error For IE:
    The instruction at "0x0153ca87" referenced memory at "0x0153ca87", The memory could not be "read".
    Click on OK to terminate the program

    2. Error for Getright:
    Access violation at 0x02F6FC6E (tried to write to 0x05EDE6D0), program terminated.

    I am really disappointed with this kind of behaviour of my computer with AMD processor. Eventhough my friends adviced me not to go with AMD, I preferred it. Previously I was using Intel based computer and I never had such problems. Did I make a mistake by buying an AMD based computer. Please help me out to resolve this problem.

    Harry Morwin.
  2. hmorwin

    hmorwin TS Rookie

    I forgot to tell you something. I did formated and reinstalled the OS WinXP SP2, updated my system with all the MS updates and Norton AV updates( I have NIS 2005 installed on my PC). Today again I got the following error with heading iexplorer.exe Applicaiton error, when I was trying to close IE:

    The instruction at "0x1001ca87" referenced memory at "0x1001ca87", The memory could not be "read". Click Ok to termincate.

    Please help me in finding the exact root cause. Many of then are suggesting that the fault could be of the Motherboard or the RAM. Is it true. I have even run Memtest86 - Memory Diagnostic for 4 passes, but I didn't get any problem. Also I did run sfc /scannow, it too didn't show up with any error message.

    When I went through may forums and websites, I noticed that the similar kind of problem is there with many AMD based PC owners. Even in one forum it was mentioned that it the memory leak bug is due to AMD Processor.

    Please help me out.
  3. kamote

    kamote TS Rookie

    The solution I got...

    MY case is this...
    Same errors with different numbers

    This happens when i am opening excel files. But not all excel files. Sometimes, when i open a file and the error did not appear all the other excel files i can open. But when i closed the application (excel) and reopen the files the error comes out again.
    This error happens also when i run or play .wmv files and some .avi files but not all. Some .avi will play.
    This error also happens when the internet page i want to visit has a movie file playing wherein it has to run a media player i.e wmp, qt, real...

    I am not having any crash with my windows xp sp2, so far. Above is what i have observed that is happening.
    I have googled it and i found many people have this problem in a lot of other applications have this error... and not only with windows xp but also win2k... it is not a hardware problem as most have initially suspected...

    it is not about memory chips... have tried it... even checked my mems with different test progs...

    i have already removed any of my recent installations, still i have the problem...
    ran registry cleaners...
    no virus detected or any trojans or security threats... i ran an online scan and have the avg antivirus.... no luck

    a friend suggested to reinstall the sp2. i downloaded the file (273Mb) from microsoft update site.

    i also downloaded the latest directX (dec2005)

    i installed the sp2 and now i can open the excel files and media files without the errors.

    i also installed the new directX just for good measure for IE...

    I hope this can help some of you guys!
  4. pracheck

    pracheck TS Rookie

    Same problem here although I only got this when I use Nero Vision express 6 and in the middle of making/editing a movie. First time I got this was after I upgraded (fresh install) to XP SP2. When I was using XP SP1, no such problem. I re-installed my SP2 but this did not solve the problem. The problem is not hardware related because I have reformatted, defragmented, replaced old HDs and other peripherals and have even experimented by transferring my HD in another PC and the problem persisted. The problem I think is in the new SP2 modifications and MS updates. I hope somebody finds out how to solve this problem since I really miss using Nero and have not burned any personal DVD complilations lately. Cheers!

    My PC specs:

    Asus Motherboard - P4U800-X Series
    P4 2.26Ghz
    HD 1 Seagate Baraccuda 7200 200GB
    HD 2 Seagate Baraccuda 7200 120GB
    NVdia GeForce FX 5200 128MB
    RAM 1GB
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Your Winodws may be infected by virus or faulty ram. Attach the following files here. I will study your log and dumps.
    C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\drwtsn32.log
    C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\user.dmp

    If turns on DEP (Data Execution Protectiob), disable DEP may resolve the problem.
    Hijackthis log is also very useful to diagnostic your problem
  6. kainers

    kainers TS Rookie

    I'm getting the same error playing video games(half-life 2 and FEAR). I want to attach my DrWatson files as requested but the forum isn't letting me. Is there an email or other place I can post this information for review?
    I was only able to attach the last bit of the whole report.


    Attached Files:

  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    This forum accepts zip file and the maximum size limit of each attachment is 100K. However you can attach more than 1 attachment. Split the Drwatson log into several attachments
  8. ajm786

    ajm786 TS Rookie

    I'm getting the same random errors, on a brand new install of WinXP. I've got all the latest updates, latest drivers, and haven't changed any hardware for a while.

    I thought I was only having these errors with Objectdock, but now it's random, and happens to any program.

    cpc2004, you look like the guru here. What should I do at this point?
  9. randbaek

    randbaek TS Rookie

    yep, i did what someone else here suggested - changed my home page - and it solved the problem

    then again, i was only getting the error message when closing IE

    i only registered to say this and to thank the site, you're good guys
  10. fcampbell

    fcampbell TS Rookie

    For the sake of completeness, I have the same problem using Imaging for Windows. I get the error every time I print something and then exit out of the program. I am now going to attempt some of the suggested solutions in this thread.
  11. sliderIP

    sliderIP TS Rookie

    Hello,, want to join the party here with similar problem.

    Running Windows 2003 server, have been running fine on the same machine for more than a year. Error started 2 days ago after i installed few programs which MAY had some virus. Error is

    The instruciton at "0x001405f3" referenced memory at "0x020a0000", The memory could not be "read"

    I booted up to memtest86 and checked memory, no errors.
    Logged on as a different user, same error.
    Applied SP1, no luck.
    Uninstalled Java Runtime, reinstaleld it, same error.
    Reinstalled Windows using Repair option, same error.
    Ran virus,spayware, trojan scans, no luck. though viruses were found.
    by the way, booting in safe mode does not hlep either.

    One thing i noted that error occurs mainly in browser based apps or net related apps only e.g. IE, Firefox, MSN i.e. no error if i run Word, Notepad etc -- but i think Windows Eplorer may have given the same error too i think

    Also if i dont click "OK to terminate...." on the error message box, i can use it just fine , like now i have this error popped but i can use IE just fine.

    My next test would be to fresh install XP on the same machine and c if that works ok, if it works then at least its not hardware issue

    I did not find anything on google on this error message.

    Anyone have had any valuable input?

    Thanks for any help.
  12. Daywalker

    Daywalker TS Rookie

    Hi there,

    sliderIP, I've got EXACTLY the same problem as you. Every detail you described matches mine. Except I'm running Winxp pro sp2 +updates.

    What is more, I want to add that I started to see this error after Maple10 software installation. During the installation I saw that some stuff of java is being installed so I thought maybe this has the influence on these errors. But Maplesoft support denied that in reply of my e-mail.

    I've tested my memory with memtest86 but after 1 pass there were no errors so I stopped memtest (maybe I should have ran it longer?).

    I noticed these apps throwing this error: IE6, Mozilla Firefox, ldc++, eMule, skype. Others seems to work fine.

    sliderIP, please tell me if clean reinstall of operating system helps. I will try further methods of solving this problem but if everything fails, I will have to make clean reinstall.

    And one more thing, I can use every app named above if I move the error window away without pushing OK or Cancel.
  13. sliderIP

    sliderIP TS Rookie

    I did couple of things since then and have 'cured' myself from this crapy error.

    If i have to guess, it has something to do with mismatched/corrupted system/DLL file due to VIRUS/WORM/TROJAN , or some installation that screwed it up.

    Here's what i did ,,

    Uninstall anything u can install later ,, make it as clean as possible.

    Run virus scan (s) , not just one but as many as u can , my pick is AVG Professional , download their trial copy and scan the whole machine

    I found 23 viruses with AVG that were not found by Bitdefender, Trend etc..

    But i say for sure that its not hardware issue, so u dont have to worry about that part at least.

    Let me know if this works for u.
  14. Daywalker

    Daywalker TS Rookie

    I took your advice and installed AVG Pro. Did a scan on C: drive and the scanner found C:\WINDOWS\system32\ldr64.dll infected which is I-Worm/Bagle. It was the only virus. I removed it manually by deleting registry key to force it not to startup at the next boot. Well... Now I think it's fixed and thank God I don't see the "Referenced Memory Error" after all (Hope to not see it in the future).
    It's kinda strange coz my PC is usually virus free although I never use any anti-viral software :)

    Thank you for your help, sliderIP.
    Good luck.
  15. sliderIP

    sliderIP TS Rookie

    U r welcome, i am glad your are 'clean' , i never had any anti-virus software before but now i think its not such a bad idea,, AVG Pro has my vote as it cleaned what others did not.

    Happy Surfing.
  16. gilbertc

    gilbertc TS Rookie

    Application Error

    The application error to a game I want to play says 0*0.004912a6 referenced memory at 0*0.00000000. click ok to terminate process or cancel to debug.

    What should I do to get the game to play?
  17. de redder

    de redder TS Rookie

    Hi all,

    I am so glad that i have found this thread. With the a/n problem
    i am strugling for a long time.

    In the past i wanted to find something about these errors but it
    was a no go.

    I do get the memory error when i

    - want to generate an offline campaign mission in Il2fb/pf
    - want to play silent hunter 3 online
    - sometimes when i log off my pc
    - sometimes after ending a program.

    Very strange with other programs, internet, email etc i have no problems at all.

    I will try a virusscan and will respond onto this forum again.
  18. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    run memtest86+ from a floppy to check memory.
    any errors are bad.
  19. EricLangston

    EricLangston TS Rookie

    The memory could not be "read" ....

    I decided to sign up to put my 2 cents in as well.

    I get ... "The instruction at 0x00dc1539 at referenced memory at 0x00dc1539 could not be "read".

    I get it *every* time I start my computer and it affects Netscape, which loads on startup for me. But the subsequent times that I start Netscape, it isn't affected.

    I get it *every* time I shut down my computer and it affect explorer.exe. But I never care because my computer's about to kills all the processes anyway.

    When and if it comes up apart from those times is seemingly random but I think that it happens when I'm either starting or closing a program.

    I've tried cleaning my memory, I'm going to reformat in 2 days (because of a different problem), and I'm going to perform the memory test tomorrow.

    Hope to hear back from someone.

  20. de redder

    de redder TS Rookie

    I have norman virukiller and i have just ran stinger.

    Couldn`t find any worm/trojan/virus.

    How works that memtest??
  21. de redder

    de redder TS Rookie

    Ran memtest, no problems found
    Ran stinger, no problems found

    Tried many things but its a no go.
  22. de redder

    de redder TS Rookie

    Vambry how did you do it???? Everybody has to learn from each other.
  23. de redder

    de redder TS Rookie

    Installed the last nvidia drivers but its also a no go!!
  24. de redder

    de redder TS Rookie

    Also that java tweak.

    When i want to play sh3 online and i am the server and
    that people that come to play with me are all gone when i am in the sub.
    Joining a server is impossible for me.

    Offline i have no problems at all with sh3.

    Very strange.

    I really don`t know what causes this.
  25. de redder

    de redder TS Rookie

    Found something,


    Error on Exit of application: The instruction at "0x01ccedbc" referenced memory at "0x0d05690". The memory could not be "read".


    When user exits Framework, CaliberRM, or Document Factory they receive an error “The instruction at "0x01ccedbc" referenced memory at "0x0d05690". The memory could not be "read".” This is almost always a client specific issue.


    Search add\remove programs for any shareware applications. If they exist, remove them, and this should alleviate the error.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...