Referenced Memory Error

Not open for further replies.


TS Rookie

Hello again, to let you know, I just tried the above procedure to recreate the virtual memory, it didnt work for me either. I am the IT person at an airport where I keep a windows 2003 sbs running, so I know "how to follow all the steps" haha. I am getting the same results as before, if I keep an IE window running mimimized to the tray and bring up a different one to view images, no error when I kill it, but if the IE window is the only one running and I view an image and then kill that window, I get an error. Have a good day, yours Jerry


TS Rookie

Hey all, I am a On Site tech at a High School, and some of the compters in one of the labs is getting the same error. Mine looks like-

The instruction at “0x7741cfaf” referenced memory at “0x05c5fde4”. The Memory could not be “read”.

It pops up ALOT and is very annoying. Most of the time it crashes the computers, making students loose all their information. From what ive read it looks like its somthing with IE? Would i have the same problems if I ran FireFox instead?


TS Rookie
The real cause?

First post.
I had just done a voluntary IE7 upgrade when this memory issue started.

I gave up trying to solve the problem by following the advise found here and instead did a restore.

Now we're back to IE6 and what so far seems normal.

I wonder if it was the IE7 upgrade or another update that "tagged along" with it that caused the problem.

I only wonder because of what I saw for restore options that occured while I upgraded to IE7:
Installed Windows Internet Explorer 7.
Installed Windows IDNMitigationAPIs.
Installed Windows NLSDownlevelmapping.
Installed Windows XP KB915865.
Software Distributin Service 2.0

These all occured within seconds of one another.

So, for now I've installed the IE7 blocking tool till I learn more about how this is all related.


-Bill Yanneck


TS Rookie
i figured it out.

This is what you need to do to fix the errors. i had the same problems as you guys. Everytime i closed a program i got that memory can not be "read" error. it also made a ding. to fix it you need to first run a virus/spyware removal program such as windows defender. Run a FULL SCAN. after you do that delete whatever bad programs are there and restart your computer. Then open the internet and type "winsockxpfix.exe" into the google search bar. there will be a bunch of hits. pick one and download the program. i downloaded it from "". If you download it from the same place i know it gives step by step instructions on running the program. Good Luck.

Joe :grinthumb


TS Rookie
Easy Fix Found: F-Secure Anti-virus, Disable "Scan Web Traffic"

Like everyone else here, I was pulling out my friggin hair to fix this problem. Thanks to previous posters who suggested looking at the anti-virus software.

I use F-Secure which I consider to be the best anti-virus software money can buy. I recently upgraded to their Internet Security 2007 product. Also decided to play with some of the settings. Under "Virus and Spy Protection" -> "Real-time Scanning" ->"Anti-Virus" tab -> I clicked the check box fo "Scan Web Traffic (HTTP)".

Didn't notice at that time, but that was the beginning of my troubles.

After 8-10 hours of f*cking around to fix the gawddam memory error (which had NEVER occured before) I finally decided to un-check the box I checked earlier.


Problem instantly resolved - no re-boot necessary.


Good luck to everyone.


TS Rookie
I too have been having the same problem. I first noticed it when I purchased and installed Quicktime Pro. I get it every time I run Quicktime. I now get it almost every day when my AVG antivirus does its system scan.
Ok I'm having the same issue only my system moves SUPER slow when starting up, and when I open ANY program, after a few seconds I get this message and the entire system locks up. The only way to even start my computer is in safe mode, and even safe mode is a little off.


TS Rookie

-the problem ocurred when i turn off ( restart ) computer, on the screen apears the same message every time,
can not rad referenced memory, error at 0x0074006
click CANCEL ( debug ) or ENTER (terminate ) the program.


TS Rookie
fix for cannot read referenced memory

I only get the cannot read referenced memory error when I am using ie7, therefore I don't know if this will help those who get the error using other programs. I don't use much video or other programs so I don't know how this will affect them. My exact problem was when I visited some sites using ie7, my browser would just close and then I would get the message about the referenced memory could not be read. I opened ie7 without add-ons and my problem ended. (start button/programs/accesories/system tools/ie without add-ons) Since I didn't have the problem without the add-ons, I opened ie7 the normal way and went to the tools tab at the top and then the manage add-ons in the drop down menu. I disabled a bunch of them that I didn't think I really needed and now I don't have the problem any more. I am sorry I didn't record the ones I disabled to narrow it down to the exact add-on that was causing the error, but this should get you going in the right direction. Good luck everyone!!!! I would be interested to know if this helps anyone, so please post here and let me know, thanks


TS Rookie
Similar problem

ya im getting a similar error but mine only happens when im playing a game called Shadowbane

i get this

sb.exe - Application error

The instruction at "0x027849b6" referenced memory at "0x022a4e44". The memory could not be read.

click on ok to terminate the program
click on cancel to debug the program

but either choice results in a crash


TS Rookie

I have not every post on here but I would like to explain my problem. I get the memory error on shutdown only. I think it has something to do with anti-virus software. After installing the free trial of Norton on my sisters computer, she got the shutdown error too. It was freakin crazy. And she has never had it before. I have tried the free mcaffee trial as well and got the error still. It has an issue with my wireless internet. And on my sisters computer, it had to do with her service host. It was way too weird to see this happen to two computers not on the same network. After reading through a lot of posts, it seems like virus software is coming up quite a bit...any opinions on what to do? VERY FRUSTRATING.


One more thing to add to my post above.

My sister used to have an older version of Norton that never gave her problems.

I reinstalled Windows on my computer last week and know that I have no viruses on my machine. I have run over 5 different scans and my computer is clean.

Would buying the real version of Norton make a difference than having the free trial version?

It is weird that I also got the error after getting the free version of mcaffe antivirus. Does it have to do with downloading this software and not getting it on a cd? Help!


TS Rookie

I am still getting this error as well. I unistalled and reinstalled Norton Anitvirus, ran sfc /scannow, ran registry fix software, changed my virtual memory and I am still getting the following two errors:

The instruction at "0x02c61611" referenced memory at "0x02c61611". The memory could not be read.


The instruction at "0x02c9f207" referenced memory at "0x02c9f207". The memory could not be read.

I only get these errors when shutting down. And I run Firefox, not IE, although I do have that installed.

Any other thoughts?



TS Rookie
Memory could not be read

Hi everyone,

With VB application, once I got the following error but when i cleared the temp files it started working. After I added few more controls again i got the same error. Now the error is coming everytime when i execute the application. But application without the latest update is working fine. Can you guys please help me to rectify it.

The error is :

The instruction at "0x212fa7e2" referrenced at memory "0x00000008". The memory could not be read.

When you guys reply please send me a mail to with the subject as "Application Error".

Kindly reply as quickly as possible.



TS Rookie
I am having the same problem, but in a different context. I recently updated my version of Office (using the automatic update) and now my PC is cycling, kind of.
After I updated my OS, the PC recomends that you restart right away. On the shut down button, it says "must click here to install..." Windows starts to shut down, then an error msg pops up saying The instruction at "0x745f2870" referenced memory at "0x00000000" The memory could not be "read". Click OK to terminate, or Cancel to debug.
No matter which one I select, my PC freezes, it just says "downloading update 1 0f 9...PC will turn off on its own" FOREVER! nothing happens! I have to do a hard restart.
When my PC restarts, windows pops up w/ a Generic Host Process for Win32 error message, and asks if I want to send an error report to MS... when I send the error report, it brings up a MS page, and they say "the problem occurs after you start/restart PC.... appears in PCs w/ Win XP SP2 & Security Update 873333 (MS05-012)... click here to download patch"
I have downloaded this "patch" 3 times, and my laptop keeps doing this same cycle!

I searched add remove programs for the Security Update that windows blames, and I found "Windows XP HotFix KB873333" Not the EXACT same, but close enough.
But when I tried to uninstall it, it gave me a warning that I may not be able to use a long list of applications.
I dont have Norton anthing (I hate norton w/ a passion), I do have a trial version of McAfee Internet Security (which I dont really love, but am using cause its free)
I reformated my HD less then a week ago, so I KNOW it has to do w/ Windows, (especially sense they tell me they know its their falt "security update 873333")
I have 1.5gb of DDR2 Ram, so it couldnt be that Im running out of virtual memory.
The only other thing it could be (other then XP) is Office 07. I recently installed Office 07, a legall version, but I didnt have any problems w/ it untill I updated my OS.
Any advice would be greatly appreciated!


TS Rookie
Hi - this is my very first post on this site. I got registered today only.

I am tired with this "Memory read/write error" with IE. Microsoft is not providing much help. Can anyone please dig deep into the issue and help me (rather all of us) to get rid of this issue?


Ajay Patel.

Desperate Dan

TS Rookie
As this thread has been in existance since 2004, it would seem to be baffling more gurus than you can shake a stick at, judging by this and the innumerable other forums.
My problem just surfaced last night when I downloaded Microsoft updates. Never had the problem before!
I was using IE7.0
When I went to shut down I got a message saying the downloads would be installed and the machine would shut down automatically. When I went to the machine this morning it was still running with an error message on it and only some of the downloads installed.
Which seems to point squarely at Microsoft!
I wouldn't say my machine was running perfectly before but it was as acceptable as you could expect from a MS Operating System


TS Rookie
please help :(

i come with no solutions only problems...0x03564156 referenced memory at 0x00000000 i click ok because if i try to debug it freezes. i have been aving this prblem with my SD card that i put into my toshiba laptop. it read the images from my camera fine but when i try to use it with my camcorder it doesnt work. it lets me get into the SD folders and i am able to click in the folder containing my videos but before i can get to them this error shows. if anyone has any solutions i will be greatful. thanks.


TS Rookie
Referenced memory error in windows explorer

Hi all,

I am new to this forum and I have a really annoying problem with my laptop.

It is not as serious as some posts on this thread but it is beginning to do my head in.

The problem first started occuring when I set up file sharing across a wireless network.

I keep getting the following error when either trying to rename or delete a folder in my documents or My computer programs directory and it is completely repeatable.

Explorer.exe - App error
The instruction at 0x0xxxxxxx referenced memory at 0x00000000
The memory could not be written.
Click Ok to terminate the program
Click cancel to debug this program

The 0x0xxxxxxx differs on each error.

At first windows explorer just used to hang and and dr watson would come up with the usual send/dont send a report to microsoft, not exactly very helpful.

So to get more info I used regedit to set AeDebug auto value to 0,
and now I get the above error.

I have found a workaround by creating a folder named My docs2 on the desktop I am able to copy the contents of My documents to it and I am then able to rename/delete files in this new folder without causing any errors.

But I still can't rename or delete folders in my documents without causing windows explorer to stop responding.

Creating folders in My documents does not cause this error just trying to rename or delete them hence I now have several empty folders called new folder, new folder(2), new folder (3) etc etc in my documents.

The Important stuff
OS Windows XP Home Edition Sp2
Celeron M 1.70ghz
60 Gb hdd
512 mb ram

I have now stopped sharing all my folders on my laptop but the problem still exists.

I've also run memtest with no errors.

Any ideas anyone on how to resolve this??


TS Rookie

The instruction at 0x00000000 refrenced memory at 0x00000000. The memory could not be "read".

Any1 help?

starts when starting up windows user accounts.

cheers 4 helping- James
Members should start a new thread for their problems, in our Windows OS forum, rather than posting in someone elses thread. Otherwise it gets really confusing.

Thread closed.

Regards Howard :)
Not open for further replies.