Audio Removing "line in" echo from Realtek HD Audio output (if it is not a sound effect)

Swing Daddy

TS Rookie
I just solved my own problem and thought others might benefit, since I could not find the solution using internet search.

My Realtek HD Audio manager seemed to be creating an echo on my "Line In" audio signal. I had already set the 'environment' and 'equalizer' sound effects options to <None>, but the echo persisted. I found the problem seems that I was essentially duplicating the Line In audio stream.

The first "source" I found was the HD Audio manager. You can open the manager and view the 'Line In' tab - mine had a non-zero playback volume (the slider was NOT all the way to the left for zero playback). If you want output from the HD Manager, that makes sense.

I also found out a second Line In "source". It was in the 'Line In' properties settings where I had checked off the option to "Listen to this device." When I disabled that, the echo disappeared.

To view this 'Line In' properties tab, right-click on the speaker icon in the notification area, then select Recording Devices (yes, "Recording"). Then, the tab will display in a window with the title 'Sound'. You should see the Line In device in the list. Right-click on this item and select Properties. The 'Line In' properties window pops up. Then select the 'Listen' tab. UNselect 'Listen to this device'. The echo should disappear if you're experiencing my problem.

I hope this helps someone. I'm just trying to help the community from which I've received so much help. :grinthumb
 
  • Like
Reactions: Mentor Milla

Jason25

TS Rookie
Hello

I have the same problem and I just came across this thread. Yes, unselecting 'Listen to this device' does get rid of the echo. However the sound isn't great compared to leaving it ticked (bar the echo). In sound properties, under the playback tab, if you disable all playback devices, sound is still coming from somewhere, what is it? Some default inner speaker? I take it that is what is causing the echo. Is there anyway to disable this?
 

blahiblipblah

TS Rookie
I also just fixed this by opening volume mixer, then clicking on the device icon, next the enhancements tab and selecting "none" under setting... Somehow it was set to sewer pipe even though I have never changed any settings.
 

Pauly

TS Rookie
You may have a sample rate problem. I had the same echoey issue and mine was resolved with making sure the windows sample rate was the same as the Realtek HD sample rate. Both should be set to 16bit 48000Hz. Go to Control Panel > Sound > Speakers (Realtek Audio Device) > Properties > Advanced then select the above sample rate from the drop-down menu and apply. In the Realtek Menu (click on speaker icon in bottom right of Windows) Select the Default Format tab then make sure the same sample rate is listed in that drop-down menu.

Hope this helps.
 
G

Guest

MY SAVIOR !! I've been fighting this for hours. Was getting ready to do the dreaded rollback drivers until I came across this.

THANK YOU SO MUCH !

--dw817--
 

joffrey

TS Rookie
For my two cents...downloading skype created my realtek echo and disabled the balance as well. Skype also created errors in my register which I had to use emerg disc to correct. Once Skype was removed and my reg errors corrected, the realtek sound and balance worked just fine :)
 
G

Guest

Your article helped me find a solution I have been looking all day for. God bless you for posting this!!
 

LCDRTaylor

TS Rookie
I realize your post is three years old, but wanted to thank you. I've been vexed with just "crazy" feedback (Realtek on board laptop, primary speaker device on secondary display) and haven't been able to defeat it without completely disabling the mic. With your workaround, I now have mic function and no feedback.
 

bigpapanoodle

TS Rookie
Having just managed to install a video capture device to my desktop PC (planning to transfer VHS tapes to digital recordings) I came across this echo effect. I wanted to listen to the audio output as the recording was taking place so it appeared to make sense that the box "listen to this device" remained checked. Googled the net and the first result was your post! Many thanks for saving me a shedload of time.
 

afcruise

TS Rookie
I just solved my own problem and thought others might benefit, since I could not find the solution using internet search.

My Realtek HD Audio manager seemed to be creating an echo on my "Line In" audio signal. I had already set the 'environment' and 'equalizer' sound effects options to <None>, but the echo persisted. I found the problem seems that I was essentially duplicating the Line In audio stream.

The first "source" I found was the HD Audio manager. You can open the manager and view the 'Line In' tab - mine had a non-zero playback volume (the slider was NOT all the way to the left for zero playback). If you want output from the HD Manager, that makes sense.

I also found out a second Line In "source". It was in the 'Line In' properties settings where I had checked off the option to "Listen to this device." When I disabled that, the echo disappeared.

To view this 'Line In' properties tab, right-click on the speaker icon in the notification area, then select Recording Devices (yes, "Recording"). Then, the tab will display in a window with the title 'Sound'. You should see the Line In device in the list. Right-click on this item and select Properties. The 'Line In' properties window pops up. Then select the 'Listen' tab. UNselect 'Listen to this device'. The echo should disappear if you're experiencing my problem.

I hope this helps someone. I'm just trying to help the community from which I've received so much help. :grinthumb
I spent quite a bit of time attempting all the "fixes" listed without success. I discovered a simple fox that worked with my system. First go to Control Panel. Go to Realtek HD Audio Manager. Under "sound effects" Mine was set on "auditorium." I set it on NONE. This fixed my echo and may work with yours.
 
Last edited by a moderator:

warewgojin

TS Rookie
I just solved my own problem and thought others might benefit, since I could not find the solution using internet search.

My Realtek HD Audio manager seemed to be creating an echo on my "Line In" audio signal. I had already set the 'environment' and 'equalizer' sound effects options to <None>, but the echo persisted. I found the problem seems that I was essentially duplicating the Line In audio stream.

The first "source" I found was the HD Audio manager. You can open the manager and view the 'Line In' tab - mine had a non-zero playback volume (the slider was NOT all the way to the left for zero playback). If you want output from the HD Manager, that makes sense.

I also found out a second Line In "source". It was in the 'Line In' properties settings where I had checked off the option to "Listen to this device." When I disabled that, the echo disappeared.

To view this 'Line In' properties tab, right-click on the speaker icon in the notification area, then select Recording Devices (yes, "Recording"). Then, the tab will display in a window with the title 'Sound'. You should see the Line In device in the list. Right-click on this item and select Properties. The 'Line In' properties window pops up. Then select the 'Listen' tab. UNselect 'Listen to this device'. The echo should disappear if you're experiencing my problem.

I hope this helps someone. I'm just trying to help the community from which I've received so much help. :grinthumb
How does this work in windows 10 with realtek HD audio config
 

yesug

TS Rookie
I know this is old but it helped me partially figure out the echo issue. Here is what I was doing first.

Using CD player connected to rear Line In and listening via front headphone jack.

First problem was I could not raise the volume-it was at a constant lower level. Going to Windows Sound Settings/Sound Control Panel/Recording/Line In/Properties/Listen and checking 'Listen to Device' solved that. But I had the echo issue. I also made sure in Sound Settings/Sound Control Panel/Playback/Advanced that the format-mine was 2 ch-24 bit-48000hz was the same as in the Realtek Sound Manager settings.

I went back to Realtek Sound Manager/Line In. I had Recording volume and Playback volume set to 50%. What I found fix this echo is lowering playback to 0 and raising recording to 90%.

Echo gone and I can adjust volume perfectly via Win volume slider.

Hope this helps.
 

jpme19

TS Rookie
This is a super old thread but maybe this will help some other hapless googlers. Go into your sound control panel double click on the realtek device giving issues click advanced tab, uncheck enable audio enhancements which is under signal enhancments.