1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Replaced RAM, now blank screen

By sicvic99
Jan 8, 2011
Post New Reply
  1. Hello

    short background: I just got my computer back from RMA (the water cooler it came with leaked, ugh). They informed me of a few pieces of hardware they were replacing and sent it back. When I received it yesterday, I somewhat successfully booted it; after installing Win 7, I soon had some driver problems . While I was troubleshooting this, I noticed on the invoice that the company also given me two new sticks of RAM (which they had not informed me of when they called me with an update on their progress). Simply out of curiosity, I opened up my case (unplugged the power cord etc etc) and looked at the RAM (two 2GB DDR3 PC3 PC1333) by taking it out of their slots. They were the same generic brand (no-name apparently) that I had prior to RMA
    After this, I put it back in, closed the case, etc., and turned on the computer; I was greeted by a blank screen. I opened up my case again and reset the RAM to make sure it was set in place, and tried again, which lead to more of the same. Ditto when I switched around the slots used (also tried to use each stick individually).

    Does anyone know what could have caused this, and if it's easily fixable?

    Motherboard: GIGABYTE GA-870A-UD3 (the memory should be compatible)

    I find it unlikely that I did anything to fry the memory (i'm grounded, etc) or that I would easily fry both of the sticks, but at this point I can't think of what else it might be. Googling around, in somewhat similar situations, people suggest to reset the BIOS, which I have not done yet. Should I try that?

    Thanks in advance,

    edit: I re-set my video card in place just in case and tried multiple monitors as well, no luck (but I wouldn't figure that it would be the problem anyway, since I didn't touch it prior)
  2. Cota

    Cota TS Enthusiast Posts: 513   +8

    Do the bios thingy, and if it doesn't work try unplugging all the cords except the power cable from the case, but do turn off the switch on the PSU. Had worked for me to get ride of the gremlin on some PC's. Also if the problems seems to stay you can use the magic words to get your PC replaced "Federal Trade Commission" :p
  3. sicvic99

    sicvic99 TS Rookie Topic Starter

    hmm, reset the bios and it's working. O.o I'm confused as to why that works... gremlins, as you said, I guess.

    Thank you :)

    Hooray, now to fix the original driver problems that I originally had...

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...