Router not registering an IP address

By giyad ยท 5 replies
Aug 30, 2008
  1. Ok, so I woke up today and my internet was just not working. My modem is connected directly to my computer right now, and obviously everything is fine. So heres the problem. When I connect the modem to my Linksys WRT150N router, the router does not register an IP. I've tried release and then renewing it, but it keeps saying in the status I can log onto my router fine, I think its just not registering with my provider for some reason... The weird thing is, it was working fine until I woke up today, I hate problems like that... Any suggestions???

    Oh, and I'm on Mac OSX 10.5.4 incase that helps...
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Trouble shooting is long and slow.
    First, have your provider check that the connection is otherwise good by getting them on the phone. Some will not work on weekends. Others only work from 9 to 5, so it can be frustrating..
    Then reinstall the LinkSys software.
    Next, see if you can, borrow someones wireless unit to be sure the problem is not elsewhere in the system.
    In our experience, the WRT150N is a reliable unit, but you can always have a cable modem burn out for no good reason.
  3. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    I spoke with my ISP and they said they can't help me because its the router and not from them.
    They are right in that respect, because I can connect to the internet by plugging my modem directly into the computer, but once I connect it to the router, nothing... When I log into the router, it doesn't show that it is registering an IP. I don't have another unit to test, but I don't see how it could be anything else...
  4. jobeard

    jobeard TS Ambassador Posts: 11,131   +982

    Have you tried power-off the router, wait 30 sec's and then repower the device?
    If that fails, use the RESET pin-hole on the back to reset to factory settings.
  5. giyad

    giyad TS Enthusiast Topic Starter Posts: 59

    yup tried that, and i've already done the reset thing too... :(

    Seems like my router just busted itself overnight or something. Really makes no sense to me
  6. jobeard

    jobeard TS Ambassador Posts: 11,131   +982

    agree. The modem is ok and so is your system so it's Q.E.D. the router.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...