Rundll32 issue?

By vale46 ยท 5 replies
Jun 28, 2009
  1. Hi all, thank you for reading this post.

    I have read many issues regarding this but none fit my situation so hope you can help.

    4 days ago i turned on my pc and this message greated me,

    "windows host process rundll32 has stopped working"

    My options were , close program or let windows search online for a solution. Neither option sorts it but the dialogue box does dissapear untill i next turn on my pc.
    Now, once the dialogue box has gone my pc runs absolutely normal. No problems or issues at all, so i guess its not a major thing its just anoying that it pops up at start up.

    I do the same thing on my pc day in day out, updates are are up to date, virus scans are clean, defrag is regular. I pride myself on how well my pc runs. It has been about 11 months since i last had to format due to a program installation issue that windows help and supprt site couldnt help with so i formatted and that sorted it, like i said, no other problems for 11months, but my concern is....

    Why all of a sudden is this message popping up? and how do i stop it ?

    Thanks for any ideas,

    Kindest regards,


    P.S. I am running Vista 32bit home premium, i dont use nero, i have norton 360 v2 and i only have 3D sofware programs in use.
  2. ender

    ender TS Rookie Posts: 94

    Any new programs installed/uninstalled recently? It seems like your computer is trying to start an app that is either gone or incompatible somehow. Try booting in safe mode (this will not load any of the usual startup apps) and see if the message pops up there as well.
  3. vale46

    vale46 TS Rookie Topic Starter Posts: 160

    ok, i ran pc in safe mode and the dialogue box didnt come up, i rebooted and now my pc wont get past the bios choose the "F" number screen !!!!!

    I am now writing this from a laptop as my pc is now in permanent bios screen freeze mode!!!

    From a working pc to a redundant lump in less then an hour !! What do i do now ?
  4. vale46

    vale46 TS Rookie Topic Starter Posts: 160

    Right.... turned it off kicked it, punched it, called it a few harsh words then turned it back on !!!!

    Still in bios screen freeze.........

    Left it, left it some more......then the bios page actually loaded and waited for me to do something, so i exited....

    It then took 8 mins to load windows, i am now writing this from the pc in question, i darent turn it off incase it doesnt work again at all.

    My cd drive isnt working and it said a usb device was malfunctioning but i couldnt tell what it was so printer, scanner and readyboost stick is now unpluged.

    Dont know if it matters but when i was trying to exit the bios all button pressing was delayed about 3seconds before any on screen results !?

    Any suggestions peeps.

    Thanks again,

  5. vale46

    vale46 TS Rookie Topic Starter Posts: 160

    Wait !!! i just tried to eject the cd from "my computer" icon and it worked, its the button on the actual tower that has packed in.. !!! how odd ? this has just happened while starting this thread. Is it coinsidence or part of the rundll32 issue ?

    Thanks again.

    P.S. I still darent turn off !
  6. ender

    ender TS Rookie Posts: 94

    I don't think the initial rundll issue and the restarting issue are related and I'm not entirely sure what the second issue is in the first place. As far as I could understand you rebooted your PC while a CD/DVD was in the drive and it was trying to boot from the CD/DVD but failed; managed to convince it to boot from the HDD and load Windows and then ejected the CD/DVD.

    Having a scratched or otherwise damaged and non-readable CD/DVD in the drive would sort of explain all your reboot issues and the fact that the drive appeared to not work after Windows started. If this was the case, just remove the CD/DVD and feel safe. Your computer is acting as it should and you can go back to solving your initial issue.

    As for the initial issue, I'd like you to go through the following steps:
    - go to Start -> Run
    - type msconfig.exe in the Run box and press enter
    - a new window will appear - go to the tab called 'Startup'
    - notice that it contain a list of programs and on each line you have a checkbox, program name, manufacturer, location on your HDD and corresponding registry entriey
    - uncheck all the boxes except for your antivirus and firewall
    - restart your computer

    The annoying message should be gone but you'll get another one about having used the msconfig utility. Don't worry though, just tick the 'leave me be' box under the message before clicking on 'OK' and it won't appear until the next time you use the msconfig utilty.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...