SATA drive stuck in PIO mode

By Corwin613 ยท 7 replies
Mar 25, 2010
  1. Ok not sure how or why this happened but I have tried removing the controller from the device manager and rebooting but it still shows up in PIO mode.

    Transfers etc are slow obviously so I would like to fix this

    I have also tried a program that resets ATA devices to DMA mode

    I had this HDD in another computer without a problem so I am not sure why I am having this problem at all..

    Its is a 1.5 TB Seagate HDD if that matters at all

    MB is a P4M800 and I am running Windows XP Pro 32bit SP3
  2. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Repair XP, but if you don't have the XP SP3 CD then you would need to blow out the OS and re-install the OS. Once corrupt no turning back. You could try to re-install SP3 but I think you would be better off re-installing the OS to get it where it should be.
  3. Corwin613

    Corwin613 TS Enthusiast Topic Starter Posts: 93

    Is that the only possibility? I have run a program called HD Tune and it showed that the harddrive was not bootable.... could that be part of the problem too? Plus it didn't show any errors on the drive tho it was running at 39C

    This isn't my main drive I just have a lot of files on it.
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Not your main drive. So remove the cables and power after you power down of course. Reboot into Windows. Run a registry cleaner program like CCleaner or IOBIT Advance System Care free. Then shutdown the system. Connect the cables and such. Try it again. Also what error message do you get? Like a hive error?
  5. Corwin613

    Corwin613 TS Enthusiast Topic Starter Posts: 93

    I don't get an error message at all. Just transfers to and from the drive are really slow (1.9mb/s) on a 1.5gb/s SATA drive

    I had been using this drive as a download drive for my torrents but because of this problem its been stuttering while I download

    I will try what you suggest as soon as I get a chance I have a busy weekend
  6. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Those Seagate 1.5 TB drives on 1.5 speed were nearly always trouble sooner or later... I would try the new Seagate 1.5TB with 3.0... or the Western Digital, and use that drive only as a storage drive.
  7. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    I had just build a new BT box myself the old one was quick but now PCI-E Dual Direction is super fast on quad-core. I didn't bother to get SATA II TB because of all these issues going Seagate HDDs . So I had stuck in a couple of WD Blue GB in there 3.0Gbps.
  8. Corwin613

    Corwin613 TS Enthusiast Topic Starter Posts: 93

    Don't have money to build a new one yet
    SATA on the board doesn't support the 3.0mb/sec speed the hdd is capable of 3.0 but i have it set to 1.5

    Don't think its the drive that it the problem honestly tho will have to see
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...