SATA Drives and K8NE-Deluxe & XP; My problem solved.... for now

By mharris240
Jan 15, 2005
  1. Been following the posts concerning the Asus K8NE-Deluxe mb and disappearing SATA drives.

    In Oct, I purchased from Newegg, my Asus K8NE-Deluxe motherboard with the Nvidia GForce 3 chipset. One morning, not more than a month after purchasing the board, I turned on the computer and it failed to find any of my SATA drives in the box. During POST, it appeared as if the onboard SATA controller had died, as POST simply sat at the point where it was trying to identify the two SATA drives in my system. After about a minute, it simply moved on during POST and tried to bring up the system, which obviously, it failed to do because the SATA boot drive was no where to be seen.

    Thinking that there had been a SATA controller failure, I RMAed the board back to newegg, which they promptly replaced. After installing the replacement board, everything worked fine... until this morning, when I discovered during POST, that the exact same problem had occured again.

    Instead of tearing down the system and RMAing the board again, I unhooked the SATA cables from the onboard SATA connections and then tried configuring a standard EIDE hard drive to the Primary IDE controller on the board. Well, that worked, as the board POSTED just fine (except for the SATA drives) so I knew that the board was at least salvageble with EIDE drives.

    I thought about purchasing another mb from another vendor such as MSI, but I noticed after searching the SATA issue on google, that other folks with boards from other vendors using the Nvidia GForce 3 chipset were having the same problem with SATA drives, including a board from MSI. Hmmmm....

    So I figured that perhaps something was going on with SATA deep in the BIOS. So before going and reinstalling XP and my complete system to the working EIDE drive on the primary controller, I thought I monkey around in the BIOS of this Asus board.

    I discovered in this AMI Bios (Asus revision 1007) under Advanced|Chipset, a selection called Onboard Device. This selection contains two options for SATA. One is called Silicon Image Mode; the other option is called Internal SATA IDE Interface.

    The Asus mb book defines the selection Silicon Image Mode this way: "Allows you to disable or set the onboard Silicon Image RAID controller mode." Since I am not running a RAID, I decided to disable this setting.

    The other setting I left enabled: Internal SATA IDE Interface.

    After saving the settings and restarting the computer, I was amazed when the damned SATA drives were identified during POST and the system started normally.

    It appears there is a problem with SATA and the Nvidia chipset when running a RAID, and there very well may be a problem when implementing the Silicon Image driver with the chipset and XP. Don't know. But I hope my very simple solution can help others with this frustrating problem that I had.
  2. janraseng

    janraseng TS Rookie

    Perfect, thanx I'm gonna give this a try. I've got a Gigabyte 7N400 pro mb but it's got Nvida onboard and the problem looks very familiar. Keep you posted!
  3. dennmarck2004

    dennmarck2004 TS Rookie

    SATA drive not recognized

    I'm using P4P800-X with Seagate 80Gb SATA 7200 for my Video editing, I had the same prob before but now its OK, no probs encountered I just tried the following:
    1. Connected my old HD (Ultra ATA)
    2. formatted my new SATA to NTFS
    3. removed my old HD (Ultra ATA) and reboot.
    4. my new HD now detected, configured my BIOS (AMIBIOS) to SATA configuration, boot priority etc.
    5. reinstalled XP with NTFS format.
    6. installed the ASUS utilities CD for Intel i865PE

    so far i have successfully reformatted my SATA HD once since and I encountered no problems at all. :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...