Tech Stocking Stuffers: 18 awesome gifts under $50

Second hard drive in PIO mode only

By x9wu1
Jul 19, 2005
  1. I just put in a second hard drive (Maxtor, 250GB, ultra ata/133) into my dell dimension 4550 as primary slave. The drive only operates in PIO mode, which is extremely slow. I have been trying to enable DMA mode without success. The following is what I've tried:

    1. Checked the jumper settings; both hard drives are cable select.
    2. Verified that the new drive is fine using Maxtor's testing utility.
    3. Changed dell cable to the cable that came with the new drive.
    4. Uninstalled primary IDE channel driver and let XP detect the drives and reinstall the drivers.

    None of these works. Related to this is an odd thing that the BIOS doees not recognize the devices on either primary or secondary slave (I have CD-RW drive on secondary slave), but I can use the slave drives in XP. I have XP Professional SP2 on my system.

    By this time, I am pretty much desperate! Any help is appreciated!!!

  2. x9wu1

    x9wu1 TS Rookie Topic Starter

    More testing

    I did some more tweaking:

    1. Put the new drive on secondary master (just for testing). The drive work great in Ultra DMA 5 mode. BIOS recognize the drive fine.

    2. Instead of cable select, manually set master and slave on the two drives. The BIOS still does not recognize the slave and XP puts it in PIO mode.

    It seems the problem is either the IDE controller or the BIOS have problem dealing with 2 drives on the same cable.

    Any ideas? Please!
  3. Triton

    Triton TS Enthusiast Posts: 82

    Check your BIOS version and date.

    For a hard drive that size (over 137GB) to be recognized by the system board its BIOS has to support 48-bit LBA
    Latest BIOS listed: Dimension 4550, A08 FlashBIOS 10/07/2003

    I have seen posts in other forums indicating the latest BIOS for this system supports 48-bit LBA

    From DELL support;
    "Step 7: ATA/IDE Capacities
    ATA/IDE capacities range as high as 300GB as of late 2004. However, capacities above 137GB require that the system BIOS be designed to handle 48-bit LBA (logical block access) operation to enable the full capacity of the drive to be used. Systems more than two years old might require a BIOS and/or driver upgrade to use drives with capacities over 137GB. If a BIOS upgrade is not available, a PCI-based ATA/IDE host adapter equipped with its own 48-bit LBA BIOS can be used."
  4. x9wu1

    x9wu1 TS Rookie Topic Starter

    Problem solved

    Thanks. I happened to have updated the BIOS to A08 when I upgraded to SP2. However, from Dell Community Forum I got to know how clear the NVRAM and it worked. Now both slave drives are recognized by the BIOS and they are set to DMA mode.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...