Silicon Image SATA/150-RAID-Controller + 2x Hitachi 7K250 250GB = Data Corruption?

Not open for further replies.
Cheers Folks

I suffered heavy lost of data creating a mirroring (!) RAID-1 on two different Silicon Image SiI3112-SATA/150-RAID-PCI-Controllers using a pair of Hitachis 7K250 harddrives (250GB, SATA/150, 7200rpm, 8MB Cache).

The BIOS detects both HDDs without problems, Windows XP Pro can be installed completely without problems but if i copy bigger files (>xxMB) from other drives or via LAN, the files are sometimes damaged.

-> 4 seperately copied WinXP SP2-Files from CD or vianetwork to any partition within the RAID-1 using the cmd "xcopy /v".

-> 2 damaged files while trying to extract the files anywhere i could.

I can run Prime95 24h+ without problems.
Both harddrives are "OK, return code 0x00", tested with the latest version of Hitachis Drive Fitness Test.

Here is the complete config:

AMD Athlon XP 2000+ with Swiftech MCX-462-V
EPoX EP-8KHA+ (VIA KT266A-Chipset)
3x 512MB Kingston HyperX, DDR3200
two different SATA/150-Controllers with different BIOS-Rev's (but even the latest one from Silicon Image won't work)

I recognized a tiny difference on the HDD firmware-revisions ... could it be that simple and that strange :confused:

Oh please, make it ending ... I spent maybe 50 hours or so on copying files, rebuilding RAIDs and installing Windows XP...

Bye bye and nice to read you, with nice greets to the www,
Kai Schwab aka "WaxMo"


Posts: 4,190   +11
Which Via Hyperion drivers are you using ? Do you have a creative soundcard installed ?
Yeehah! Thanks for your question!
No, there's no SoundBlaster in there, I'm using the onboard Realtec AC'97-sound.

I tried different setups, but if i used oem-drivers, i used the latest drivers for all components:

VIA Hyperion 4in1 driver pack v4.53
Broadcom BC57xx driver pack v7.80
Silicon Image 3x12/a RAID driver "" (2004-09-22)
nVidia Forceware 61.77
Microsoft Windows XP Professional Service Pack 2 (officially bought, just by the way...)
Microsoft-built-in-drivers for the firewire-PCI-card

But check this out:
I recognized a * V E R Y * interesting thing...
Last night, i created just-for-fun a RAID-0 (stripeset) setup and please don't hurt me - ALL PROBLEMS DISAPPEARED with that moment!
This setup had not a single problem with any of my cruel torture test (watch "b.bat" below).

But now I'm using a RAID-1 again (this is the setup I preferred...), the troubles appeared again. :-(

Even changing the complete hardware working around that RAID (mobo, ram, cpu, psu, nic, raid-controller) does not affect the situation: Any raid-1-setup suffers from heavy data corruption.

wooooaaah... I better get some sleep now.

Cheers! And thanks a lot!
Kai Schwab

PS: Here's the torture-test "b.bat":

@echo off
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 1.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 2.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 3.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 4.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 5.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 6.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 7.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 8.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 9.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 10.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 11.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 12.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 13.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 14.exe
xcopy d:\xpsp2.exe c:\
ren xpsp2.exe 15.exe
start 1 /x:c:\1
start 2 /x:c:\2
start 3 /x:c:\3
start 4 /x:c:\4
start 5 /x:c:\5
start 6 /x:c:\6
start 7 /x:c:\7
start 8 /x:c:\8
start 9 /x:c:\9
start 10 /x:c:\10
start 11 /x:c:\11
start 12 /x:c:\12
start 13 /x:c:\13
start 14 /x:c:\14
start 15 /x:c:\15


Info: The batch-file copies 15 times the SP2-package from CD to HDD, renames it for batch-processing and later, extracts ALL self-extracting cabinets to separate files simultaneously (!).
The process takes its time and costs around 9 gigabytes but here are the facts:

RAID-0-setup (stripeset, 32kb blocksize): 0% failures, 100% OK.
RAID-1-setup (mirroring config): ~40-50% failures ("file is damaged")

This is really stunning...

Maybe a driver-problem?
I'm testing again...
Hopefully, see'ya soon. :-]
8-| *lookin'fullyconfusedaround*

Woohoo ... Thanks a lot! I never thought of that.
I'll check this out. The "PCI Latency" currently has the value "32" ... that is too strength for a RAID-setup?

Just in _this_ moment, I try another version of the SiI3112A-driver ("3x12_x86_win_rdvr-10032").
I took it from the EPoX-website, they use the same chip on an 8RDA3+ mobo.

Thanks for your patience! :)
Cheers ... and stay tuned,

I've got it...
The puzzle's done.

It has been the problem I suggested yet with the slightly different firmwares of the two hitachis in use with the Silicon Image SiI3112A Raid controller (with todays' latest available BIOS!) , I can't explain it otherwise.

The firmware-revisions are 3 counters different.

Now I'm using the VIA KT600-/ VT8327-chipset-integrated RAID-functionality on another mainboard with the latest driver available and my torture-test performed very nice. 0% data corruption, 100% integrity on 12 simultanously extracted windows-xp-service-pack-2-files.

I dared to test the rebuild-capability of that setup... :D
The rebuild's working in background now; the tools says it takes only 70 mins for rebuilding at least 250 gigs ... THAT ROCKS!!!

Dear Didou: Thank you very very much for your tweaks but I'm sad to say: nothing worked... I decreased and increased the PCI-latency (normal: "32", faster setup: "8", slower setup: "64"), but it never got better.

But now I know what to do: Buy another controller, maybe a Highpoint Rocket RAID or something similar.


Stay tuned.

[Thread possibly able to be closed]
Not open for further replies.

Latest posts