Steam language help?

By herbalfire
Oct 3, 2012
Post New Reply
  1. I turned my laptop on today and all my games are loading in random languages fallout nv is in spannish and tf2 and dead island load in russian ?? I havnt tried my desktop yet so I dont know if the settings have changed on there, any ideas??
  2. Relic

    Relic TechSpot Chancellor Posts: 1,379   +16

    Hey Herbal, bit late but you should be able to change the language under your launcher settings. So go to your Game Library, right click Fallout or TF2, select properties, then the language tab and change it back to whatever you had it at. Why it changed I couldn't tell ya, but I've seen it happening before. Do you travel to different regions by any chance?
  3. herbalfire

    herbalfire TS Enthusiast Topic Starter Posts: 46

    Thanks I figured that out in the end and no its so strange I justed loaded up steam and it decided to change all my languages, bad times :(

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...