Switch/Hub behind router

By detrunks ยท 12 replies
May 7, 2008
  1. Hi,
    I'm having endless problems with connecting both my PC and 360 to the net. I have what I think is a hub behind the router (the router only has one ethernet connection - its one from Vonage)
    Firstly, how do I know if I have a switch or a hub?
    Secondly, does DHCP on the router need to be turned off or on?
    Are there any other setting on the router that need to be changed so that the hub/switch works?
    When the hub is connected, I can get either the PC or the 360 to connect, but not both. The hub has 4 connection points (excluding the uplink connection).
    Both the PC and 360 are on dynamic IP.
    I've 'power cycled' a number of times but nothing got resolved.

    thx in advance
  2. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    If you have the choice, ENABLE DHCP. This assigns a unqiue IP address to every
    device on the LAN side -- without which you can only have ONE device attached.

    A hub or switch may then be attached thus:
    modem --- hub/switch --- multiple devices
    Both hub/switches have zero configuration options and DEPEND upon the upstream
    router (or modem) to have NAT+DHCP.
  3. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Do you have an actual router, or just a cable modem from Vonage?
    It sounds like to me, that you probably only have a MODEM that allows one phone and one computer to be connected to it at a time.

    Switches, at least the ones used in most areas, or even sold in most areas, have NO configuration options really, other than the "uplink" switch/port.
    So the problem is not with either of these devices.

    What you need to do most likely, is get say, a Linksys router, and then plug the cable from the Vonage box into the WAN port on the router, and then plug the Xbox 360 and the computer(s) into the router's built in switch ports.

    If you desire to do so, you may also attach your switch to one of the router's switch ports and attach other devices to that, however unless you run out of ports, that's kind of redundant and not recommended because it just introduces another thing that can go wrong into the network setup.

    Keep in mind, in networking, simple is USUALLY best.

    If you are unsure if it is actually a router or a modem you have from Vonage, post a picture/model number (preferably model number) of the device and I'll see if I can confirm which it is.
  4. detrunks

    detrunks TS Enthusiast Topic Starter Posts: 153

    I have a Vonage router (it's a VT2142 by Motorola). If the problem is not the hub (and I have DHCP enabled on the router), then why does only 1 device on the hub work at a time?
  5. pyromaster114

    pyromaster114 TS Guru Posts: 246

    I believe what you have this setup, correct?

    What you want, I believe, is this:

    I don't believe that the device (Motorola VT2142) was designed to be used with a switch/hub and multiple computers...

    As far as I can tell from my research, you need a router or other device either in front of, or behind, the Vonage device, and connect your Xbox and computer(s) to the router.

    The one thing you could try, before buying a router, is connecting the Ethernet cable from the Vonage (Motorola VT2142) device, to the UPLINK port of the switch/hub. This might enable the devices to work properly, but I doubt it.
  6. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    with this setup, you enable DHCP in the VT2142
    modem--digital phone adapter--- HUB--- other systems
    the hub always uses passthru so IF there's DHCP, it will work. pg 33 of the U.G.
    shows DHCP is available. see U.G.

    this would work just as well
    modem --- --- router---digital phone adapter---  other systems+phones
                       + --- more systems
    in which case DHCP in the router is ENABLED and the digital phone adapter dhcp is DISABLED (only use one dhcp and always as close to the modem as possible).
  7. detrunks

    detrunks TS Enthusiast Topic Starter Posts: 153

    Jo - the 1st set-up is what I currently have. Maybe I just have a dodgey hub...
  8. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    My gut reaction is the DHCP is not activated ....
  9. pyromaster114

    pyromaster114 TS Guru Posts: 246

    I'm almost certain that the problem lies in that the phone adapter thingy from motorola does not allow you to have the hub attached to it like that...
    However, I would take these steps:

    1) Ensure DHCP is enabled on the phone adapter.
    If it still doesn't work:
    2) Try assigning static IPs to devices, see if they work then.
    If it STILL doesn't work:
    3) Go get a linksys router, and create the OTHER setup that Joe proposed. (This one, I'm SURE that it will work, cause I've done it before....

    You might try buying a SWITCH (not hub, cause apparently that isn't working...) and seeing if that works in place of the current hub...
    Don't know what that would do though, but DHCP works through switches too... so it should work if it's going to work in this way.
  10. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    All routers have problems with a hub or a switch UNLESS you manually
    configure each system attached, as somewhere on the network there MUST be a
    DHCP service to avoid IP ADDRESS Conflicts.

    As most users have difficulty attempting a manual configuration, it is easiest to install
    a ROUTER immediately next to the modem and then attach all devices to the router :)
  11. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Well, yes Jo is right... all routers would have some issue having multiple computers or other devices attached with a hub like that if there was no DHCP server. (Unless IPs were manually configured)

    I was referring to that my experience has been that the Motorola digital phone adapters were not cooperative when I tried to use a switch connected to them.
    I'm not sure why, and I'm almost certain that it has something to do with the DHCP, as Jo stated before.
  12. detrunks

    detrunks TS Enthusiast Topic Starter Posts: 153

    ok - I gave it another go (DHCP was always enabled) and for some reason it worked. It appears that at least one of the hub points is not actually working which is why I could not connect both devices.

    thanks for all the help
  13. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    I've seen that before too -- really disturbing. Glad you've got is sorted out :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...