Task Manager problem

By Ro' ยท 6 replies
Apr 19, 2008
  1. Task Manager..Idk If this should be here.

    Hello how's everyone doing? Im hoping everyones perfect.

    So heres the deal, Im using computer like nothings happened, and I press on Ctrl+alt+supr just to check what tasks are running and Bam! Task manager has been disabled by the administrator.
    Surprise surprise Im the administrator.
    So I was wondering what could have happened and how could I solve it.
    Any Ideas/suggestions are well appreciated :) thankz for your time!
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. Ro'

    Ro' TS Rookie Topic Starter Posts: 20

    [/i]Check user and system policies[/i]
    Note that if you have a policy problem, you will usually get an error when you try to open it, such as "The system administrator has disabled Task Manager" or something similar.
    1) Make sure you are logged in as a user with administrative privileges. You can see which users are admins by going in Control Panel and clicking the Users icon.
    2) Start -> Run regedit
    3) Browse to:
    4) Click on each subfolder under Policies (it is usually System that has the entry).
    5) You will see in the right-hand side, and entry called DisableTaskMgr.
    If you see this key (right side), just highlight it and delete the key. Note that if the key's value was "1", that is why you can't open Task Manager.
    6) Also check this key:
    Repeat from above and delete the key DisableTaskMgr.

    If for some reason that doesn't work, I found one case where just typing this into the Run box does the trick, here is the command:
    REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableTaskMgr /t REG_DWORD /d 0 /f
    It basically does the same thing of changing it manually in the registry. But just in case...

    You'll have to log off and on for these changes to take effect.
    If Task Manager still doesn't work, check the same registry keys you changed above, if they are back to the way they were before, then you have malware setting it this way. And so...
    I applied the REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableTaskMgr /t REG_DWORD /d 0 /f on run
    and my task manager works now but I cant execute regedit!
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Download RatsCheddar.zip http://www.castlecops.com/zx/sjpritch25/RatsCheddar.zip

    It contains a program written by Rathat, and it is a Policy Controller.
    Save and extract this program to the desktop.
    Once extracted, click on the RatsCheddar.exe file.
    Enable everything, then click Exit
    Reboot your Computer.
  5. wsnett

    wsnett TS Rookie

    nice information
  6. Ro'

    Ro' TS Rookie Topic Starter Posts: 20

    by the way Idk if it has to do with anything but I just checked my task after doing the run thing and a program is running called "Romeo" but it didnt appear in processes but in Apps....tried to see what was it but there was nothing...and my DVD+-RW/CD-Rw kept opening and closing...anything wierd here?
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Romeo might be a bluetooth remote program (but really I don't know without more info)

    The CD opening and shutting (program wise?) is a bit vague in your description. ie: what program; when? and all the other common questions you might shed some light on
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...