Trouble retrieving DLC Key on Steam

By cliffordcooley ยท 9 replies
Nov 19, 2013
Post New Reply
  1. I purchased a Humble Bundle that came with "LOTRO: Steely Dawn Starter Pack". At first the DLC was not part of the bundle and was added later (2 weeks later). At first the Keys were not available. It was two days later when I was able to add the DLC to my Steam account. After two days waiting for the DLC to activate in-game, I came to the conclusion it would not automatically. I started a Steam Support ticket last Friday which I have yet to receive a reply. Two days after starting the ticket, I did a search and found this page.

    How do I make a purchase through Steam?

    The page mentions a "View CD Keys" option which I do not have. The only evidence I have is a listing for the DLC under account details. I have never been prompted with a key that can be used in-game to activate the DLC.

    Is this a common issue with Steam? Trouble with DLC keys and then no support trying to get the key.
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    I've never had a problem getting a Steam key if available from HumbleBundle. Once you have the key you just enter the key in Steam and it should add the DLC - never had it not do so. I don't recall anything ever not showing up after I entered a key. One easy way to determine if Steam knows you should own it is to pull up the store page for that DLC. It will either give you the option to purchase it or say you already own it.
    cliffordcooley likes this.
  3. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    The Humble Bundle page was a single click of a button that automatically added the Games/DLC to my linked Steam account. If I visit the DLC page on Steam it does say I own the DLC, I don't have a clue nor can I retrieve the key. And I need the key to activate the DLC within my LOTRO account. I can see how I am supposed to retrieve the keys from the link above. I just don't have that option, as the "View CD Key's" option is not available for LOTRO.

    I do have "View CD Key's" option available for other games that were added from the same Humble Bundle purchase. I'm not sure why it doesn't show for LOTRO.
  4. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    I finally received a reply late last night.
    I followed the instructions and found 23 files failed verification. Steam initiated a download to correct the failed verification, a download of 12GB. After download, I followed the steps again and everything verified 100%. But I am still not able to see the key for my DLC. And loading the game starts an update to undo what Steam did during the verification.

    WTFH, all I want is a key to activate my DLC in-game. But yet here I am caught between three systems that are out of sink with each other and failed to notify me of my key. And during the attempt to gain a 25 character text string, I end up downloading 25GB of game files. What a frigging joke!
  5. lchu12

    lchu12 TS Booster Posts: 195   +9

    Have you tried going into your Steam Library, finding the game and right click on it. From there a option should say downloadable content. Click that and you should find the DLC's you have for the game. I'll take a look into my own games to see if I can find a key from a DLC and update you with instructions if I have any.

    Sorry if the instructions above is all screwed up, trying to work and remember how to do it, while typing.
    cliffordcooley likes this.
  6. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    Yeah I discovered that somewhere around my last post. There is a list that shows the DLC labeling and the purchase method. I'm surprised the keys don't show in this list. Even with the few games I do have that show a "CD Key" option, there is no key listed in the game properties DLC tab. I personally think that is a great place to list all the keys linked to the installed game.

    Steam did finally give me a key that was supposedly the one linked to my account. However I have no idea what the key was for, as it did not unlock the features listed for the DLC. When I mentioned the given key didn't unlocked the desired items, Steam support passed the ball to Turbine. Steam passed the ball 4 days ago. I was anticipating this and started a ticket with Turbine 5 days ago. I've not heard anything yet from Turbine, though they said it may take 4 to 5 days before a response is made.

    I'm not as furious over the issue as I was at the start. At this point I know there is nothing I can do, and trying so hard to figure out what I was doing wrong is what had me agitated I'm more patient and determined to get what was given to me. I don't care how long it takes or how many ticket's I have to start, I will get the DLC activated on my LOTRO account.
    lchu12 likes this.
  7. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    Maybe I should change the title and bash Turbine. It has been 8 days since posting a support ticket with Turbine and I've not heard anything from them at all.

    I can't believe the trouble I'm having in getting this DLC activated. It is almost as if they never intended to honor the deal made with Humble Bundle.
  8. lchu12

    lchu12 TS Booster Posts: 195   +9

    cliffordcooley likes this.
  9. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    Believe it or not I have the CK Key option now, available in both places. In Links and under the right click menu. It was not in either place yesterday (or was it the day before I checked last).

    Sad news though, the key is the one that Steam Support give me a week ago. So it seems Steam is now out of the picture. I'm definitely needing to talk to Turbine, if they will just pickup the phone on my support ticket.
  10. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,735   +3,706

    Finally received a response from Turbine. Their response was of no help, but I'm certain if I hadn't noticed the issue on my own, they would have been helpful.

    The DLC key has been activated. Turbine was allowing me to sign in to "" using my game login. If the login had been rejected, I would have gathered it was the wrong login ID. My game login ID is not the same as my account ID. I was trying to activate the DLC key on my Game login ID not my account ID. Afterward it was not giving me options to continue with the activation. There was confusion as to why the activation appeared to be working but at the same time failing to appear in-game. Especially after what I went through, to get the key initially.

    All is good. No time lost. Only several hours of disappointment, not being able to use the DLC.

    Although Turbine should reconsider their login methods. It might save them a few support tickets in the future.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...