Trying to fix 2 USB Flash Drives with 2 different problems

By xpuser101
Aug 11, 2009
  1. 1 is a RAW USB Flash Drive - sandisk cruizer - 4gig

    the other is

    2 E: is not accessible. Access denied - Corsair Voyager 16gig

    I tried the following on the first - sandisk cruizer - 4gig
    GetDataBack version 4 - free , says its possible to get back all the data , all files are there, but have to upgrade to paid.

    I tried the following on the second - Corsair Voyager 16gig
    GetDataBack version 4 - free - stopped at 50% and came up with errors

    also tried Killdisk for windows version 5.1.24 - free - just hangs and freezes at pass1 writing block 0 - see attached screenshot - However I know the files are there and intact.
    Also when I go into my computer it says E: is not accessible. Access denied

    So if anyone have any idea what else to try please let me know.

    Attached Files:

  2. strategic

    strategic TechSpot Paladin Posts: 1,020

    Could you be a little more specific for what you are trying to accomplish?
    Are you doing this under an 'administrator' account?
    Which O/S are you using?
  3. xpuser101

    xpuser101 TS Rookie Topic Starter

    Yes, I am the administrator using XP Pro
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You might try booting into Linux from a G-parted Live CD. Then run TestDisk utility to see if it might be able to read/recover the data on the flash drives. See [post=720766]How to boot from a G-Parted-Live-CD[/post]
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...