Unable to install new pci wireless card

By netweb ยท 7 replies
Jan 7, 2007
  1. I successfully installed a belkin wireless netwrok card on my laptop. Unfortunatly this was damaged so I ordered a replacement card. The new card was the same part number but a different version. PNP sees it as a different hardware ID so instade of seeing the card as "belkin wireless network adaptor" as the original card did, it sees it as "belkin wireless network adaptor #2". As a result the drivers will not install.
    Any ideas how to resolve this issue?
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    It's caused by XP already thinking you have a BWNA installed , you need to remove any references to either card first, go into ADD REMOVE programs and find the listing for it, now uninstall it, reboot with the card out and the go into device manager (right click my computer, properties, hardware,device manager) click View and choose show hidden devices, check under network adaptors and make sure its not shown.

    Now run the install routine for the new card and see if it works.

    I had a similar issue with a Belkin PCI card not being recognised by XP once, 3hours later it went in the Bin, and I bought a 3Com card, a lot less hassle to install.

  3. netweb

    netweb TS Rookie Topic Starter

    Thanks for your reply.
    I have been thinking the same thing that the system thinks it is installing a second BWNA card.
    I have done as you suggested. There is no reference to a belkin card in the Add/Rem programs.
    When I view the hidden devices in the device manager the only reference I get is the "Belkin 802.11g wireless card - Packet scheduler Miniport" I tried to uninstall this but get the message "Failed to uninstall - device might be required to boot up the computer.
    So I still have the problem.
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi again

    what happens when you try to install the card by running the driver install CD?

  5. netweb

    netweb TS Rookie Topic Starter

    I get the following error message during the install.

    Component XP
    File group UI
    Error Access is denied.


  6. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Disable or uninstall the old "install" by going to Settings ->Control Panel -> System -> Hardware -> Device Manager, then click on the network adapter, then action.
  7. netweb

    netweb TS Rookie Topic Starter

    Thanks for the suggestion, but I have already tried that and it did not help.
    The system still has a reference to the old card ID and as soon as I plug in the new card again it comes up as "belkin wireless network adaptor #2.


  8. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Then your problem is with Windows, or bad hardware... or registry.
    Get your self a copy of a good and simple registry editor such as RegClean from www.majorgeeks.com.
    Then once again remove the network device in your Device Manager.
    Then remove all references to it in the registry... checking very carefully to assure they are ALL gone... not just the obvious ones.
    The problem you have is unusual. I would be concerned because of other problems in your hardware or setup. I would reformat and reinstall everything. Once a system becomes flakey, that is the smartest move.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...