Unexpected system crash with motufwa.sys

By MaxSample ยท 14 replies
Nov 26, 2007
  1. Hi there,

    I wonder if any of you guys could possibly help me with this issue as it's absolutely doing my nut! It is attributed to my new MOTU 828mkii USB which I bought and installed a few weeks back...

    The driver file motufwa.sys is causing a violent system crash requiring a full reboot. This occurs unexpectedly when opening a program (e.g cubase), or starting media (e.g video file on YouTube) which requires, and possibly initiates the 828 as an audio output. The system crash does not occur when the program or media is in operation however. When in operation the unit performs flawlessly. The crash can also occur whenever the unit is switched either on or off, even when the PC is idle. The rate of error is about 1 in 10 times. The details of an example crash are:


    STOP: 0x000000D1 (0xF8FAF003, 0x00000002, 0x00000000, 0xF68038D5)

    motufwa.sys - Address F68038D5 base at F67E2000
    Datestamp 44ecb7dc

    The steps I have taken to troubleshoot so far are:

    -Several full and clean installations of various driver versions for the 828suitable for XP (crash has been occuring on all driver versions)

    -Rerouting IRQ (currently no conflicts or sharing at all)

    -Disabling unnecessary components

    -Switching USB power scheme to "always on" (the 828 hardware itself works better this way, but makes no difference to the system crash)

    -Changing USB hub port

    -Updating USB hub and USB2 controller drivers

    -Changing between ACPI and PC mode

    -Changing motufwa.sys, and other MOTU drivers' startup procedure (demand, boot, automatic etc.)

    -Replacing USB cable

    -Restoring 828 factory defaults

    -Hard-drive defragmentation

    -Used MEMcheck x86 to identify any RAM errors (non found)

    Other comments:

    The error occurs when the onboard soundcard is disabled.

    The only PCI device installed is the nVidia Quadro NVS 280 graphics card. The error still occurs when this PCI device is disabled/removed. There are no IRQ conflicts with this device at all.

    No other devices use a USB2 connection, except for a 7-port generic hub (Belkin). The problem still occurs when no other USB connections are made except for the 828 and a USB mouse for convenience.

    The only recent change I've made to the computer is the addition of an Optiarc DVD-RW drive, though the crash was occurring well before this change was made.

    ...Sorry for being extremely long-winded about this but I'm finding this issue absolutely frustrating. I've been relaying Q&A's with MOTU Tech Support over the past few weeks and it seems that they have got sick of my constant pestering about this! Any help would be very greatly appreciated.

  2. KrisBenoit

    KrisBenoit TS Rookie

    Same problem.

    I am having this exact problem.
    Your post is the only thing so far I have found on the net (in English) regarding the motufwa.sys error.
  3. MaxSample

    MaxSample TS Rookie Topic Starter

    Hi Kris,

    Thanks for your reply. I have managed to solve this issue now (about a month ago) and everything seems to be running perfectly, touch wood. The problem that I found was that the incorrect driver versions were being installed for the 828 each time I tried to reinstall/update them. Even though I kept doing clean reinstalls of the latest driver versions from the MOTU site, the system seemed to roll back to an older driver, without telling me so and for no justifiable reason. I'm surprised this problem isn't as common as I think it should be - even MOTU tech support totally gave up.

    Here's the steps I took to solve the problem:

    - Install the latest version of the driver you can find (I think it's, and I'm assuming you are using XP or Vista). Follow all installation instructions where possible.

    -After the installation, go to the Control Panel, then open the System dialog box. Click on the Hardware tab and go to Device Manager.

    -Expand the 'Sound, video and game controllers' tab to expand to the list of all the MOTU devices.

    -Right-click the top-most MOTU driver (should be MOTU Audio) and click Update Driver...

    -Click on 'No, no this time' for the Windows Update search wizard. On the next page select 'install from a list or specific location'. Following that on the page after, select 'don't search. I will choose the driver to install'.

    -On the next page you will find all the drivers for MOTU Audio available on the system. Select the latest version (highest number following the 3.6.7.x format), and upgrade to that one. Make sure the 'show compatible hardware' option is checked.

    -Repeat for all of the MOTU drivers listed in the device column.

    -There is also a driver named 'MOTU Audio MIDI Extension' under the 'system devices' tree too. You can try upgrading that as well.

    -Reboot the system after all the drivers have been updated.

    This may or may not work on your system, but it has solved any apparent problems I was having on mine. The 828 now works like a dream. Let me know how you get on.


  4. stefcaron

    stefcaron TS Rookie


    ...unfortunately I am here because I am frustrated.
  5. stefcaron

    stefcaron TS Rookie


    ...sorry, that should have been a full letter.

    Maxsample, I have done exactly what you suggested, but upon trying to find an anterior driver for the MOTU, it crashed, and now doesn't work at all anymore. Sonar just doesn't see the unit in anyway whatsoever.

    By trying to fix one problem, I have created a dozen more.
  6. MaxSample

    MaxSample TS Rookie Topic Starter

    Hi stefcaron,

    Sorry to hear about your problems. MOTU really do need to get their act together on the driver issue. Unfortunately after all this has taken place, I have had to reinstall everything on my entire system (as a result of a non-MOTU related incident) and now the same problem has come back. I've reapproached this problem using the same method as I mentioned in my last post but this time I can't seem to get rid of it.

    Now that I'm back to square one I am unsure as to what solved the problem in the first instance. I am currently experimenting with several reinstallations of the and driver versions from the MOTU site (earlier versions do not work at all on my system). However, there has been a significant decrease in the error rate - now being about 1 in 30 times I use the 828 to access audio, as opposed to 1/10 times as I stated in my first post. I will post back here immediately if I find a new solution to the problem.

  7. stefcaron

    stefcaron TS Rookie

    So... where do we go from here?

    That sucks.

    I re-installed everything - Sonar, ACID and the MOTU. Everything short of reformatting my laptop.
    I've been in a conversation with a guy at MOTU. We're slowly whittling down what might be the problem. For me, it's not Sonar, as I've experienced a few crashes with ACID Pro 4.0. I am eagerly expecting Reason 4.0 in the mail any day now. If anything is going to stress my system out, it will be that.

    Interestingly, when I am using Sonar, I see both processors on the Pentium Dual-Core working in the 30-40% range before a BSOD rudely interrupts my work. Matt, The MOTU Guy, had me test Sonar with the Realtek soundcard that is on the laptop... 50-60% CPU and no crash, no BSOD. No stuttering. No hiccups.
    I also pointed out to him that I use the 828 mkII with a desktop computer that has Windows XP Pro as an operating system, and I have yet to experience a crash on that system. My laptop has Vista.

    I am seriously thinking of downgrading my laptop to Windows XP if MOTU can't get a driver working properly for Vista. And that would greatly affect my trust in the company's products. Here I am convincing my bassist to plunk down $899 (Canadian - we're in Toronto) to purchase an 828mkII for his own projects, and I am thinking of purchasing a second 828mkII (or the mkIII, whatever is available) so that I don't have to carry it back and forth between working at home and for rehearsals and for recordings.

    So I provided Matt The MOTU Guy with the link to the Techspot page... hopefully he'll see that more than one person is having this problem and he'll be able to help you and Kris out also.
  8. MaxSample

    MaxSample TS Rookie Topic Starter

    Solved! ...I think.


    Sorry for the delay in replying since my last post, however I think I have managed to get down to the bottom of the motufwa.sys driver problem. My XP has been permanently running for the past six days without a flaw; I've also been stress-testing the hell out of it in that time too, and it seems I have finally got rid of the error.

    It just so happens that this isn't directly a MOTU driver issue, but more attributed to a resident Windows update/driver - namely for the USB2 controller. The original USB2 driver was not configured to be used under stressful circumstances, such as being used with data-hungry and power-hungry sound interfaces, and so when pushed to its limits the USB2 driver would simply just "give in" (hence the motufwa.sys blue screen).

    The way to solve this problem in XP is to install the USB2 driver update KB898108, which can be requested from Microsoft support for free, or it can even be found in the MOTU installation directory on your hard-drive. But there just happens to be a big problem with this that maybe even the guys at MOTU don't even know about...

    Apparently there is a huge bug that has been discovered with Windows Update. I'm not exactly sure of what it is, but in a nutshell it prevents any Windows updates (automatic or manual) from being installed on the system. And the stupid thing is is that it doesn't even let you know about this; it actually gives you a misleading message that the installation was successful when it wasn't. I found this out through examining the update logs in the Windows directory.

    Now, the KB898108 update actually comes packaged with all of the MOTU USB2 driver installations, so it should have been automatically installing when you install the MOTU software, but this bug has been preventing it from doing so. Instead, only "residues" (can't think of a better word) of the update are installed, making any future updates for the same file a bigger pain.

    The only way I forced it to install was to uninstall ALL the drivers for any USB devices for the PC, especially the MOTU; going in to Add/Remove Progams (clicking the "show updates" checkbox) and uninstalling the KB898108 update; going into the device manager and uninstalling any Enhanced (not Universal) USB drivers present; and finally doing a search for and deleting any file which has KB898108 in its name. Any pop-ups telling me "a new hardware device has been found etc." were ignored as it would have meant that XP was trying to reinstall the old USB controller driver(s) that you just removed.

    The KB898108 update was installed after all this (from an executable file), and the relevent USB2 controllers were installed into the driver cache (the update installation is still not 100% successful according to the logs but manages to install enough to make everything work). From then on it's a fairly simple process, waiting for Windows to find and install the USB2 controllers and then reinstalling all of the USB devices and the MOTU again.

    I should mention that this may only work on Windows XP and not Vista. Microsoft have stated a while back that the KB898108 would be included "in the next Service Pack", but I'm unaware as to which one. I don't really know if it comes as a requisite driver with Vista or if the KB898108 even works with the new OS, so it might be worth shooting a message over to Microsoft and asking them if there is an alternative to the KB898108 for the Vista platform. Bear in mind that this is a very specialist driver update as it is specifically geared towards USB2 sound interfaces, so I suppose Microsoft have good reason for not including it as a general update/install to prevent any widespread incompatibilty issues.

    I personally think that MOTU aren't actually aware of the "bigger picture" being geared more towards the Mac platform and just providing the KB898108 in their Windows software installation and hoping for the best. I haven't read anything about this issue on any of their pages, so I might send them a message.

    I'm now currently using the much older drivers for my system and they're working fine (no drop-outs, pops, crackles etc.) and I don't really have a reason to update them on my current XP system ever again. I've also uninstalled my Symantec antivirus software too prior to all of this but I don't think that really had anything to do with this issue, so I'm gonna go ahead and reinstall it again.

    I apologise if I've totally been wasting your time with this post, but hopefully you'll find some use from it! Let me know how things are.

  9. stefcaron

    stefcaron TS Rookie

    No time wasted here...

    ...and thank you very much for the info!

    I will speak with the MOTU rep I've been dealing with. We spent the week testing my laptop with other soundcards and have not had any crashes. I plugged the MOTU back in and had problems the very moment I started running on of our 60+ track songs on Sonar.

    I will give you an update in a few days...
  10. stefcaron

    stefcaron TS Rookie

    ...and check your messages... just sent you something...
  11. darem

    darem TS Rookie

    I have the same problem here with Cubase 4 and the 828mk3 (Firewire) in Vista.

    Is there a solution already? just don't want to uninstall all usb drivers :)
  12. stefcaron

    stefcaron TS Rookie

    My problems with Cubase...

    Hey Darem,

    The only solution I have found is the one mentioned above by Maxsample in his Feb 23rd post. Unfortunately his solution doesn't work for me because I'm using Windows Vista, and he's using a USB driver update for Windows XP. Our USB driver configuations are completely different.

    What I did end up doing is uninstalling and reinstalling all my USB drivers with the latest Windows updates, and then uninstalling and reinstalling Sonar 6 and the MOTU.
    Since then, one crash: I was editing envelope eq filters on a guitar track in Sonar's sidebar in a song that had 79 tracks (two drummers, two bassists and three guitarists in this song, no wonder). I've since submixed the drummers down to two stereo tracks, all the synths and samples have been mixed down to another stereo track, the bassists' tracks have been submixed, and now I'm just in the middle of trying to figure out what to do with the guitars... all this to say that a USB port has a certain threshold of info it can handle: 60 Mb/s, but in theory its limit is 52~something Mb/s. Add to that automated edits, like volume slider movements, eq envelopes, panning envelopes and effects processing your sound and spitting it back at you, you eventually hit a ceiling.
    (I'm saying all of the above mostly for my own selfish reason - I just need to get this off my chest.)

    Firewire is supposed to be able to handle 100, 200 or 400 Mb/s, depending on the version you have, so I can't begin to imagine what the problem there would be.
    I found the guys at MOTU eager to help. Sign into your MOTU profile at motu.com (if you haven't done this yet and you just got the 828 mkIII, I recommend you do it now and register your new toy), go to their techsupport page (it's right here) and explain your problem. A conversation will start with the guys, you'll have some back and forth over the course of a week or so, and hopefully you'll find a solution for your exact situation.

    I have some pretty strong opinions about Cubase, which I will not share with you here. Needless to say, I would also contact Steinberger and see what solutions they might have, if they have any.

    That all said, you've probably already contacted MOTU and Steinberger and that's why you're here. I hope that's not the case...

    More gain, more pain.
  13. darem

    darem TS Rookie

    Thanks fr your reply.

    FYI, the crashes I experience aren't Cubase dependent. They can happen anytime, wihout Cubase being even started. In fact,the system never crashed on me when Cubase was running - either after it or without it.

    I'll register my product with motu immediately. I just have to slip under my racks to see the serial - but I will manage to do that.
  14. stefcaron

    stefcaron TS Rookie

    I've had a couple of crashes when Sonar was shut down, but the MOTU was still on. Maybe the MOTU sends somekind of weird message to the USB port - in your case, the Firewire port - that causes the computer to melt.

    I hope you get it figured out!

    Keep posting the results - I will eventually be investing in a Sonica laptop, and any info will help in case there are problems with that unit's Firewire and/or USB ports.
  15. darem

    darem TS Rookie

    Crashes are gone after a reinstall of the Motu-package. I don't know why, because I did a couple of reinstalls and registry wipes, but now I haven't had crashes since...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...