Unreachable network/No assigning of IPs

By PuzZah
Oct 26, 2005
  1. I've been trying to connect a newly aquired machine to my network with no luck what-so-ever. Initially I installed Windows XP professional with SP2 onto the machine only to be hit with the infamous "Limited or no connectivity" issue. Upon researching this error, I came across various solutions including the Microsoft SP2 Patch KB884020 with no luck. I still cannot get this machine to connect to the network. Everything I've tried is listed below.

    • Replaced the Hub twice
    • Tried with no Service packs, and with 1 seperately, and service packs 1 and 2
    • I've tried the winsock XP fix after reading it may be a corrupt IP table
    • I've run a registry fix i found on some forums (i have a feeling thats the same as the winsock XP fix though)
    • I've flushed out my DNS
    • I've tried 3 different network adapters, an nForce Motherboard mounted one. a Realtek one, and a Sitecom one
    • Manually assigned an IP address in the range which DHCP would assign

    All of the above has failed. It is only this machine which fails. I've got numerous other machines on my network which are all recieving dynamic IPs from DHCP perfectly every time yet this PC hasn't recieved an IP once.

    I read that if you can ping the computer's local IP, and ping its loopback address successfully, it's not a corrupt IP table, but bad network drivers. However having tried 3 different network adapters with CD drivers from purchase, and drivers obtained on the internet I'm at a complete loss.

    I've since tried Fedora Core 4 on the machine and still no joy. I guess this means a hardware or driver issue but I'm still stumped...

    Any support you might offer is appreciated hugely!

  2. Nodsu

    Nodsu TS Rookie Posts: 5,836   +6

    Replace the network cable?

    Instead of trying everything possible you should approach this step by step. Use a static IP when testing at all times.

    Do you get an ethernet link? (LEDs)
    Do ARP requests succeed?
    Big pings?
    What about duplex and speed settings?
  3. jobeard

    jobeard TS Ambassador Posts: 11,383   +1,062

    I read that if you can ping the computer's local IP, and ping its loopback address successfully, it's not a corrupt IP table, but bad network drivers. ​

    ping goes only to the NIC itself and implies the card is active.
    ipconfig /all should show your IP address, but that's the problem you're working on.
    If you had an IP address assigned, you would still be talking only to the NIC.

    To verify IP traffic is flowing, you need to ping your ISP gateway address.

    You might try a manual config like this:
    find your existing network range, it will be something like 192.168.0.x or 192.168.0.x
    now manually set
    ip address
    dns address​

    you should be able to ping or any other system on your net.
    then try ping (happens to google.com) and if this works,
    using the name should also work eg: ping google.com
  4. equinox137

    equinox137 TS Rookie

    Does your NIC detect a connection? Are you cutting and crimping your own CAT5 cable? If so, you may want to redo the cable. From what you're describing, it sounds like some of the wires might be reversed in the cable. Make sure you're using (or creating) a straight-thru cable and not a crossover cable.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...