Unusable hard drives?

By sakhurst ยท 11 replies
Sep 2, 2008
  1. Recently decided to get rid of the 3-drive RAID 5 array. Backed up all my data to an external drive, and deleted the array. I also designated each drive as a "non-member drive". However, now when I try to install windows xp SP3, it refuses to install on two of the drives (call them drive 2 and 3), and will only install on one partition of one drive (call it drive 1).

    In addition, drive 1 is divided into two partitions. One of these is usable and acts completely normal. However the other partition (actually just non-partitioned space) cannot be formated, or altered in any way. The weirdest part of drive 1's problems is that the first partition shows about a third of the drives capacity, while the other unpartitioned space shows 5/3s, for a total capacity of double the hard drive.

    Any ideas of how I can "recondition" the drives to get back to normal? Formatting doesn't change anything.

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    But Partitioning (or removing the Partitions - in Full) might :)
  3. sakhurst

    sakhurst TS Rookie Topic Starter

    Thanks for replying...I tried that too. Used Norton PartitionMagic to screw around with partitions - on drives 2 and 3 completely removed and repartitioned the entire drive. Then tried to reinstall windows on one of those drives, but no go. I get an error message saying something about not windows being unable to install on that partition...go back and try to delete a partition and create a new one. I did that too but keep getting the same error message.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    What you describe is the way it is supposed to work. Windows will only install to the first partition of the first drive unless you use special setups described at www.microsoft.com or if you use Acronis or other such software.
    The only easy way around this problem is to disconnect all drives but the one on which you wish to install Windows and delete the other partitions until after the install. Then restore the partitions.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Could I just throw in something here
    It would be better to allow Windows to automatically create the Partition on the unpartitioned space (hopefully being the entire drive)
  6. sakhurst

    sakhurst TS Rookie Topic Starter

    Tried that too...once installed, windows wouldn't let me delete the other partitions.

    Tried that too...wouldn't let me.

    Thanks for all the responses so far. I'm going to try writing zeros...last resort kinda thing.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    No just remove the Partitions, and don't create a new one (ie let Windows do that)
    I've said this twice now
  8. nickc

    nickc TechSpot Paladin Posts: 923   +11

    kimsland, what would one do if Windows will not boot even though the boot order in the BIOS is set to CD first and it just says it can not install to this partition?
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Here is Delpart http://www.juliatexas.com/delpart/Delpart.exe
    I've used it many times for stubborn partitions removal
    Here's some info on it: http://mirror.href.com/thestarman/DELpart.htm

    But what I'd do

    Is remove all HardDrives and data cables
    Plug in only one HardDrive
    Set it to CS (on ATA) or plug it into the 1st Stata Port (um for Sata)
    Boot from the Partition Magic bootable CD (or use Delpart on a boot Floppy/CD if you like)
    Remove all Partitions (note, we are not talking about backing up here)
    Then restart
    And Setup Windows
  10. sakhurst

    sakhurst TS Rookie Topic Starter


    So, at least one hard drive is working correctly now. I've managed to create a working partition that encompasses the entire drive during windows install. It's still installing, and I haven't had a chance to check if the other drives will work as well now, but here is what I did:

    • wrote zeros on entire drive - didn't work
    • formatted entire drive (not quick format) - didn't work
    • created, deleted numerous partitions using both norton partition magic as well as the windows install process - didn't work
    • pulled out all HD cables, replaced one cable only in different SATA slot than it was originally - worked.

    So thanks to all your replies. The solution doesn't make sense to me really, but as long as it worked, it must have been the right one.

    *Update: all drives working correctly. Original drive 1 was still showing multiple partitions after I hooked it up, but Norton PartitionMagic cleared it up quickly
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks for the update :grinthumb

    It was that Sata Port after all (or possibly a combination of Partitions, and Multiple HardDrives and the Sata Port (it could have even been the Sata data cable))
  12. sakhurst

    sakhurst TS Rookie Topic Starter

    Yeah, I don't think it was a specific sata port that was the problem - I'm still using the exact same ports. Connecting different HDs to different ports was the solution (i.e. mixing them up). Maybe there was still remnants of the RAID array configuration in the southbridge, and simply obliterating every last physical similarity to the previous setup was what finally convinced it to let go. Seems unlikely, but how else can you explain such a stupid solution? I just can't believe it took hours upon hours of testing, formatting etc., to finally land on a fix that took all of 10 seconds to rip out cables and put them in different slots! Sooo frustrating!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...