USB 2.0 Problems w/ ASUS P5W DH Deluxe MOBO

By Barnezz
Aug 27, 2007
  1. I purchased a ASUS P5W DH Deluxe Motherboard a couple weeks ago and have been have not been able to get the USB ports to perform at there full speed. Windows XP says that I have no "Hi-Speed USB host controllers" installed on my computer. Also with the driver cd for the motherboard, when I clicked on "install USB 2.0 drivers" a text document came up saying that if I was using windows xp or later I did not need to install the drivers (I actually had no choice- I couldn't install the drivers). In BIOS the USB ports are also set to function at Hi-Speed (480mbps). In case your wondering it takes around 200 minutes to transfer 9 gigabytes of files through the USB ports.

    Help Greatly Appreciated!
  2. Grafficks

    Grafficks TS Rookie Posts: 302

    When you go into Device Manager (right-click My Computer > Properties > Hardware(Tab) > Device Manager), is there a yellow mark labeled on any of the USB Host Controllers?

    I've had a very similar problem before, with the OS not detecting the USB 2.0 drivers. Allegedly, the USB 2.0 drivers for Windows XP are included with Service Pack 2 (I'm pretty sure you have SP2).

    I solved it by going into device manager, right-clicking on the flagged "USB host controller" entries and clicking Uninstall. After a reboot, the USB host controllers will get detected again (it will pop-up saying "New Hardware Detected!"), and the generic USB 2.0 drivers (included in Windows) will get reloaded, and will hopefully enable full USB 2.0 speeds.
  3. Barnezz

    Barnezz TS Rookie Topic Starter Posts: 27

    Wow :)Thanks!
    It worked.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...