1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB devices not loading

By ieoziges ยท 6 replies
Dec 19, 2012
Post New Reply
  1. I know this is a much discussed subject but I haven't yet found a thread with the answers I need.

    My problem started with a refurbished PC I bought earlier this year. It had a 500Gb HDD which sounded fine and it is running Windows 7 Ultimate 64. The HDD was formatted with two partitions C: and F:. Everything worked well enough to start with but I soon realised that not enough space had been allowed for the C: drive - only 38Gb. For various reasons I couldn't go back to the supplier so I carried on, thinking it would only be a slight inconvenience as I could direct software that defaulted to C: to install in the F: drive. That worked OK for a time until I downloaded some stuff that would not divert and the provider said it could only run in the C:drive so it was useless to me. I then concluded that I needed to re-partition it. After some unsuccessful searching I found Mini Tool Partition Wizard that was able to tackle my problem. I successfully removed partition F: and merged the space gained with C: thus providing more than enough capacity.

    Having done all this I discovered I had "lost" one of my two external HDDs, that I could not connect to my camera or my GPS running watch, and that my memory sticks were not recognised. Probably my Tom-Tom won't connect either but I haven't yet tried it. A Google search found what appeared to be a solution that was published on this site last year that involved uninstalling USB drivers and then plugging the equipment back in as at their first use. This, the instructions said, would enable the equipment to reinstall itself when plugged in. I did it wrong at first and succeeded only in "losing" the second HDD and my Epson DX6000 USB printer. A second shot paying meticulous attention to the instructions restored the HDD but not the printer. I had downloaded a set of Windows 7 drivers for the printer when I acquired this PC and switched from Windows XP Professional to Windows 7, so uninstalling and reinstalling them returned the printer to working order, almost. What that means is that every so often the printer is reported as not being ready to print but rebooting the PC seems to cure the problem.

    I am now left with the PC not acknowledging the presence of the camera, the Garmin Forerunner watch, the memory sticks, and one of the two HDDs. The odd thing is that having carried out the USB driver cleanup procedure and plugging the bits and pieces back in, the PC reports that Windows is now installing each item as it is reconnected. But they still don't show up anywhere. I will just add that when I disconnect the devices I do so at the device end, as to reach the back of the computer involves squirming around awkwardly under the built-in desk unit, but I read somewhere that disconnecting at either end is equally good. The camera, the memory sticks and the running watch are usually connected via the front sockets.

    I look forward to hearing from you,

  2. Vipin

    Vipin TS Rookie

    Unplug the USB device, and then plug the device back into the computer or hub.
    if still not working...
    In RUN, type : Devmgmt.msc
    The device managaer opens...
    On the Action Menu, click Scan for hardware changes...
    Then ur PC should recognize ur USB device...
    Restart ur computer...
    Hopefully these three methods should work...
  3. Ectech

    Ectech TS Rookie

    Do you use any registry cleaning tools?
  4. ieoziges

    ieoziges TS Rookie Topic Starter

    Thanks Vipin
    Actually I didn't need it in the end. After posting my problem last night I spent another three hours fiddling about and trying various things that didn't work and went to bed thoroughly fed-up with computers and all about an hour before your post landed, I guess.

    I have to say that I believe in miracles and the power of prayer, and, believe me, I have prayed several times about this whole thing. When I switched on this morning I noticed the indicator light on the front of the Buffalo drive was illuminated; this is the ext HDD that hadn't been working. The light hadn't been showing either. I went straightaway to "Computer" in Windows Explorer but the drive wasn't showing up there, so I decided to check it with the Mini Tool Wizard. It showed up immediately but without a drive letter for some reason and that had prevented it from showing under "Computer". I gave it a letter and of course it reappeared in Windows Explorer. The camera also showed up as a removable drive and the running watch and memory sticks all function properly without me having done anything more other than pray.

    I feel a fraud for having the problem solved so readily and wish to thank you for the opportunity of posting here where there is evidently so much expertise. I do have another small problem but will post it elsewhere and consider this thread as closed.

    Best wishes to all

  5. ieoziges

    ieoziges TS Rookie Topic Starter


    Sorry, I cross posted with you but just answer your question,, I do but nothing has showed up as being the cause of all this. I just put it down to mucking about with partitions and such but do not know why that should have affected other stuff as well.

  6. Ectech

    Ectech TS Rookie

    Have you considered system restore? I've seen it work miracles before.
  7. ieoziges

    ieoziges TS Rookie Topic Starter

    The matter is finished as I explained in reply #4


Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...