USB drive Format attempt failed midway thru process!

By dabooj ยท 4 replies
Feb 27, 2007
  1. Hi,

    I was attempting to format my USB drive to NTFS system.
    The drive was being formatted and got 50% thru the process when an erro msg came up saying windows could not complete the format. This is a brand new drive which was formatted to FAT32 originally.
    The drivers still detect the flash drive when it is inserted. The drive appears in my computer but i can't access it or fomat it. It says 'insert disk'.
    Disk management detects the drive and allocates a drive letter to it but no drive details appear. It just says 'no media'.
    I've tried Killdisk but this detects the drive but says 'drive not ready' so you can't do anything.
    I've also tried EASEUS Partition Manager 1.1 which is a windows version of the partition doctor but this acnnot even detect the drive at all.

    I know i was stupid in formatting the USB drive but please can you help me save my drive! There is no data on it that i need so re-formatting it is not a problem.
    I've heard suggestions of formatiing on Windows 98 but i'm going to struggle to find a PC with Win 98 on it.

    Any other suggestions or advice?

    Please, please, please help. I'm desperate.

    thanks in advance.

  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    you cannot format flash drives with NTSF. Use FAT32.

    format it using disk management under computer management. Don't format it by right clicking on the drive.
  3. dabooj

    dabooj TS Rookie Topic Starter


    Just to clear up - I ALREADY attempted to format my USB drive using NTFS and midway thru the process widows came up with an error. I can't access it now and i can't reformat cos it doesn't recognise it. Windows detects it but does recognise so it can't be used or formatted.
    I need help repairing it.

    Any ideas on what to do or is there an app that can do the job?
    no data on USB but need the usb to function again.


  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    read: you cannot use NTFS for usb flash drives.

    please re-read CAREFULLY, my previous help.
  5. dabooj

    dabooj TS Rookie Topic Starter


    Sorry Tedster, I don't think your getting my msg.

    I HAVE already tried to format the USB drive in NTFS and this is what caused the problem. I know i shouldn't format it in NTFS now.
    I am not misreading your msg. Before i started this thread i had already tried to format the USB drive using NTFS. This crashed halway thru and caused a problem on my USB drive.
    I can't access it anymore & i can't reformat. This is waht i need a solution for.
    Windows detects the drive but i can't access it.

    Does anyone know of a tool which can recover or repair my USB Drive to it's original working state.

    Thank you,

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...