USB flash memory has data but doesn't show the contents

By abbasi ยท 5 replies
Jun 19, 2013
Post New Reply
  1. Hi all,

    My friend's USB flash memory has data (its drive shows that there is data in it) but when I double click on it to open it and see the contents, it doesn't show any folders and files! I did the following works:

    1- I scanned it by my updated kaspersky AV. but no threat found
    2- Scanned by windows defender tool. same result!
    3- scanned by malwarebytes anti-malware. same.
    4- cmd (run as administrator) -> go to its drive (e.g., H:, when H is my flash drive) and typing the attarib -s -h *.* /s /d command. It could not to show the data.

    All my attempts faced failure till now.

    Can anyone help me please?
    Rodolfo Vicente likes this.
  2. ahmad_babug3

    ahmad_babug3 TS Rookie

    Go to cmd (run as administrator) -> go to its drive (e.g. H: where H is my flash drive) and type the attrib -s -h *.* /s /d
    Now flash will show the data.
    Your attrib spelling was wrong correct them
    Try it.
    Rodolfo Vicente likes this.
  3. Thanx dude its really work
  4. Thnx a lot it work :) I got ma data
  5. zarish

    zarish TS Rookie

    I have the same problm wd my flash..usb derive show data bt when I open it.. it totly empty...wht I do????
  6. JohnnyIT

    JohnnyIT TS Rookie

    Thanks a whole lot. it worked for my pc!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...