1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB Hub And Boot Problems

By Slash5 · 4 replies
Jan 2, 2005
  1. i have recently bought a USB 2.0 Hub to accomodate extra devices for my laptop.

    I runs fine, but only if it is connected to the PC AFTER it has booted up, if it is connected, then turn the PC on, it loads no further than the initial BIOS screen, and doesnt even look for boot devices

    I have been told that i need to update my pc's BIOS, but the support from 'Time Computers' is terrible and i am wondering if anyone has any ideas on what the probelm is or how to solve it

    BIOS is

    Insyde Software MobilePro Bios Version 4.00.01

    AMD AthalonK7 Mobile XP 2000+

    Chipset :- VIA VT8372 P/KN 266

    BIOS Version - V1.05
    BIOS Release Date - 11/19/2002

    If anyone can help i would be very grateful!
  2. El Presidente

    El Presidente TS Rookie Posts: 40

    I don't know your reason for having the hub connected when you boot up but the easiest solution would be to connect the hub after boot up. If you want to have it connected on boot up, check your BIOS's boot order to make sure that USB-HDD or similar USB devices are not listed. Also, your BIOS may be too old to recognize USB 2.0 (though, I'm not sure when USB 2.0 came out).
  3. lopsl

    lopsl TS Rookie

    I have the same problem with my PC and a simple passive USB 2.0 4 port mini hub. The PC will hang during boot up if it is plugged in, even without anything attached to the hub. If I plug it in after the system has booted up, there are no issues. This means I have to unplug it after I shut down so that it will boot up normally at the next power on. A real nuisance.

    Some research indicates it could be a BIOS issue because the built in USB controller on my PC motherboard is USB 1.1 only.
  4. rainer2105

    rainer2105 TS Rookie

    can you tell me, where i can get this version of Bios ? I need it for my notebook.
    Hope, you can help me, thanks
  5. manwe

    manwe TS Rookie

    Updating your BIOS is not a generic process. In the case of desktop PCs you need to know which motherboard you have, and in the case of laptops you have to know the maker and model. Anyway, even though some companies like AMI and Award make BIOS for many motherboards, you cannot update with generic images (eg. like being able to use nVIDIA drivers for both Asus and Albatron GeForce cards). You will have to find and download the BIOS update from the manufacturer’s site, otherwise your system might stop working altogether.

    I had the exact same problem with my new hub, which requires external power supply (I had no problem with my old hub which was powered directly through the USB ports). I used to cut power supply to the hub whenever I turned on or restarted the PC, otherwise it would not boot past the POST screen. Only when Windows loaded could I enable the hub. Both the old and the new were USB 2.0 enabled.

    I looked up my problem on the net and found some possible solutions. The one that worked for me was to change the USB 2.0 setting from HiSpeed to FullSpeed. Now all my USB devices are recognized by the BIOS and the system always boots properly.

    However, I will also post here some more solutions that worked for other people.

    1) Disable ACPI 2.0 support in BIOS.
    2) Disable APIC support in BIOS.
    3) Disable USB Legacy support in BIOS.
    4) Make sure that the boot sequence in BIOS does not include and USB devices.
    5) Insert an additional USB controller in the form of PCI card and connect the hub (or any other USB device which causes problems) to this card’s ports.
    6) Try various combinations of input devices:
    a) PS2 keyboard / PS2 mouse
    b) PS2 keyboard / USB mouse
    c) USB keyboard / PS2 mouse
    d) USB keyboard / USB mouse

    Right now my working BIOS settings are:

    PS2 mouse support : disabled
    ACPI 2.0 support : yes
    ACPI APIC support : enabled
    USB function : enabled
    Legacy USB support : enabled
    USB 2.0 controller mode : Full Speed
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...