USB port not working

By tgd151to
Jun 12, 2005
  1. I have installed a USB port on to my bay and I have connected the cables of the 2 USBs into the mother board in the appropriate slot.

    I have changed the letters of the other drivers (4 HD and 2 CD/DVD readers) starting from V down to Z and left the system HD on C: and the A: drive where they were.

    I also have 4 USB ports on the back of the bay and 2 are busy with High Speed Internet Cable and Camera cable. The other 2 are free.

    When I insert a flash memory stick into the installed FRONT USB port the light of the gadget lights up but I cannot access it. On the explorer I cannot see the drive (which I instaed see if I plug it into one of the back USB doors).

    I have Windows XP SP2 installed and I have no other troubles with the computer

    The hardware I have installed doesn't (apparently) require drivers to work

    Can anybody explain what I shall do to get the FRONt USB ports to work?

    Many thanks in advance

  2. IronDuke

    IronDuke TS Rookie Posts: 856

    Check in the manual how many USB ports are supported. It may an either/or situation.
  3. tgd151to

    tgd151to TS Rookie Topic Starter

    Thanks ID
    but what manual are you referring to? the mother board one? if so I have checked it already and it doesn't say anything about either/or situation

  4. Anthony_Punster

    Anthony_Punster TS Rookie

    How I fixed my USB headers

    Hi tgd151to,

    Did you fix your usb problem?

    I had the same problem with my Gigabyte motherboard running Windows 2000.
    The rear USB ports worked fine. I had a floppy drive with 2 card readers. I had the card readers connected to the internal USB headers and they did not work at all.

    Apparently Windows had trouble talking to the USB driver from Gigabyte. I fixed it by deleting the USB driver for the compact flash reader. Then I let Windows do an online search for a new driver. Viola, it worked! Then I did the same thing for the multimedia card reader, and it worked as well.

    First I tried to fix the problem with Device Manager. That was just confusing. It's much simpler to use Windows Explorer. Also, you can not fix this problem by telling Device Manager to update the USB driver. If you try that, Windows will think, 'You already have a USB driver. My job is done here.'

    This is from the Microsoft website:

    NOTE: The Microsoft USB 2.0 driver may not be listed as an available update if third-party USB 2.0 drivers are installed on your computer. You may have to remove the third-party USB 2.0 drivers, and then install the Microsoft USB 2.0 driver from the Windows Update Web site.

    Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

    I wonder if this fix will also work with Windows XP.

    I wish you success, Anthony :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...