1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB ports not working

By Hodsocks ยท 4 replies
Apr 10, 2013
Post New Reply
  1. I don't think there is an easy answer to this problem, its a Dell desktop and after a power cut non of the usb ports are working therefore my keyboard and mouse aren't working either, There are no ps/2 ports to use instead, it was booting into windows but with all the repeated turning off it now boots to a screen giving me a choice of boot up modes neither of which I can choose therefore it just sits there and goes no further. I fitted a PCI card with 4 x usb ports on it but of course it can't load the software for that therefore it won't recognise the keyboard/mouse. its a bit of a catch 22 situation.
    Has anyone any suggestions, other than changing the mobo as that's not going to be cheap as its a Dell?
  2. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    Can you try infrared or bluetooth devices?
  3. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 11,208   +4,873

    Does your keyboard and mouse appear to have power or are they completely without power?

    If the USB ports power has been cut off, it is possible the USB ports will still communicate. Using a USB hub with external power could help, if it is a power problem.

    Another thought would be to disconnect everything USB related, this includes internal card readers. If the power outage damaged one of the components, the damaged component could be causing your issue.
  4. hood6558

    hood6558 TS Evangelist Posts: 353   +110

    You didn't mention whether the KB works in BIOS. If it does, you can load generic USB drivers or do a Windows repair (by booting to a repair disk). If it doesn't, try clearing CMOS by powering down, moving the CLRCMOS jumper over 1 pin for 30 seconds, then moving it back to original position and powering up. On some boards you have to remove the CMOS battery for 30 sec., so do both to ensure proper clearing. If no jumper, just remove the batt. This will reset your motherboard to default settings. Good luck.
  5. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 390

    Thanks for your interest guys.
    I can confirm that the optical mouse does have power getting to it, we have disconnected all usb and then booted into windows, plugged them in again but still no joy. A powered usb hub has been tried but again without any success. KB is not working in BIOS, there seems to be no way to input into the machine.
    People wonder why I still use motherboards with a ps/2 port on them when building a new machine.
    Jobeard.... wouldn't I need to plug in a usb Bluetooth receiver to try a Bluetooth KB or mouse as it doesn't have it built in.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...