USB problems with a newly build system, please help

By flowerpower
May 26, 2007
  1. Guys, i'm having a problem with my USB ports on a system i just assembled. Let me start from the beginning, i'm currently using an old USB laser laptop mouse (i'm still waiting for my new keyboard and mouse to arrive) for which i have no software cause its so old, when i first booted up the system it didn't work at all so i had to use a ps/2 mouse instead. Upon second boot i entered BIOS to see if USB devices are enabled and they were, after that it started working. I have 6 usb ports on my system, 4 in the back that come with the mobo and 2 case ports in front. It worked for a while and was plugged in the mobo, then all of a sudden i get a message in windows that the USB port has malfunctioned and the mouse stopped working. So i plug it into a different port and it works. When i booted the system today the mouse wasnt working again, so i had to try 2 different ports before it worked. After that i decided to test all of the ports, most of the times they work but sometimes they don't. I don't understand what is going on here, is it a common problem with new systems? Could it be that this is a software problem, may be i should wait till i get a new mouse that comes with a cd and install it? May be i need USB 2.0 drvers, is there such a thing?

    P.S. What do i do about the malfuntioned USB port, is it dead?
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    In Device Manager ensure all your Root Hub Power Management check boxes for shutting off to save power are UNchecked.
  3. flowerpower

    flowerpower TS Rookie Topic Starter Posts: 102

    Ok, let's see if i got this right, went to device manager, in the USB controller directory selected USB Root Hub, then selected properties, in properties selected power management and unchecked the box that says allow the computer to turn off this device to save power. Same was done to the 2nd USB root Hub directory. There is also another box in the power management called allow this device to bring computer out of standby, but it is blank, i'm unable to check or uncheck it. I don't use standby anyway, i set my system to hibernate and turn off hdd and monitor after 15 min.

    It looks like this fixed the problem partially. I just tested the all the ports again and the mouse is working in all but 2, one that malfunctioned and supposedly died and another mobo port. Whats strange is that when i plug into the dead port, the mouse red light goes off and it doesn't work, but when i plug into the other port the light stays on but the mouse still doesn't work, i wonder why?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...