1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB Speedtouch 330 Modem Issues

By PhilH ยท 5 replies
Sep 7, 2007
  1. Hi All

    I'm out of idea with this problem that I'm having with the Speedtouch 330 USB modem so I need some urgent help.

    Firstly, someone unplugged it from its USB port, so we simply plugged it back in. The LED flashes red indicating congestion on the port. There are only two of the six USB ports in use and it went back into the one it came from and every USB port has congestion according to the modem.

    I went into the system information and was told that the driver was not installed for the device and its now recognising the modem as an audio device!!

    I put the installation disk in to repair the lost drivers and it says that drivers are already installed for this device. So I have the computer saying there are no drivers and also saying they are already there.

    Tried to uninstall through add/remove programs where I get the message
    "This package cannot install software", which is the oposite to what I want to do.

    I'm getting a lot of conflicting information from the machine. When I look at the USB ports the modem is shown as being there, but no drivers. Cant uninstall the package and cant repair the package as it thinks the drivers are there.

    Any one help?

    Much appriciated.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

  3. BlameCanada

    BlameCanada TS Rookie Posts: 314

    So you`ve gone into the Device Manager and tried to uninstall any modem or sound device,

    disconnected the modem from the computer,restarted the computer,hit cancel when Windows tries

    to install anything,then inserted the driver CD ?

    Doesn`t the CD give you any option to remove the drivers ?

    Try running a good registry cleaner like RegscrubXP

    Modem drivers are in C:\Windows\system32\drivers if you want to check that folder out,for modem references.
  4. PhilH

    PhilH TS Rookie Topic Starter

    I've tried the uninstall using the CD that came in the package and that gives the same "cannot install software" message.

    All USB ports show as congested but the only things ever installed on the PC through USB was the printer and modem.

    I'll try the drive cleaner and using run>regedit to remover. Will update of the outcome later.

  5. BlameCanada

    BlameCanada TS Rookie Posts: 314

    You could try uninstalling all your USB ports and every USB device (if you haven`t already).
    Maybe there is something wacky going on with them ?
  6. PhilH

    PhilH TS Rookie Topic Starter

    Well its now sorted. Went to the thomson website and got the latest driver rather which worked. Must have been an error somewhere since the original drivers wouldnt work. Strange!

    Thanks anyway for the advice.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...