Usbohci.sys BSOD lotsa fun

By FireHazard ยท 35 replies
Jan 21, 2009
  1. Hey folks,
    I have a strange problem and i'm having a hard time figuring out how to pin-point it. I built a new machine a few days ago.
    Asus M3A78 Pro
    AMD Phenom 9550
    OCZ 700 watt PS
    Corsair 4x2048 Ram Kit. 8500CDF, or something...
    XFX GeForce 9800 XXX Edition
    Seagate 750gig Sata3

    I did a clean install of XP Pro with SP3, and it looks and runs great until at random intervals, i get a BSOD with a USBOHCI.sys error...
    When i disable my USB settings in my BIOS, the computer runs solid as a rock. Gaming, surfing, burning DVDs.....the works.

    I've only got one stick of the 2 in the machine. With that 2gb stick in any of the 4 slots on the board, and all sorts of settings in the BIOS, it still gives that USBOHCI.sys BSOD. Now i dont mind using my old PS2 keyboard and mouse combo, when i give this computer to my brother, i would like it to be rock soild.

    I've run Memtest+ 2.11, for 17 hours with no errors. I turned the USB settings on while i ran the test, and i disables USB LEgacy support wile running memtest.

    I'm not too sure how to tell if it is a motherboard probelm, or a RAM problem?
    Any help would be greatly appreciated....
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All four minidumps are error 0xD1 and these are caused by either a faulty drive or buggy software.

    However, in your case, they all cite hardware as the issue (without further description) followed by usbohci.

    USBOHCI.sys is a Windows core driver and it has to do with USB miniport. Try the following:

    1. Update your Asus motherboard drivers.

    2. Update the USB Legacy support.
  3. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Hey Route44,
    Thank you for your quick reply.
    My chipset drivers are the same ones as the ones on the ASUS website;
    AMD Chipset Program Driver WHQL V5.10.1000.8 (Package Version 8.511).

    As for the USB Legacy support, how would i go about doing that. Google didnt help me too much.

    I'm thinking its a motherboard problem.

    * As of 10 minutes ago, there is a new BIOS version for my motherboard....i'm crossing my fingers.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    My suspicion has been the motherboard thus my suggestion for updating the chipset drivers, etc. I don't think at this point it is your OS. Let us know about the new BIOS. Good luck!
  5. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19 luck. I've tried a few different settings in the BIOS for my USB stuff. Legacy Off, FullSpeed USB, no luck.

    Whats my next step, replace motherboard?
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Before replacing the motherboard try doing a full harddrive scan and a Windows repair.
  7. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Windows repair done...and chkdsk luck.
    I'm getting sick of that damn blue screen. Want more minidumps?
    I'm going to send the board back and get a replacement, i've run out of all other options.
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Yeah, send your most recent 5. How old is this board?
  9. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    I bought the board on Jan 11th, of 2009. Not too sure the exact date of manufacture.
    Here are a few more, they are all the same. The system is solid as a rock with the USB disabled in the BIOS.
  10. Big Dan

    Big Dan TS Rookie

    Sorry, i've just read your post again and just realise you had not installed all the ram you've stated in your specs.
    Sorry again...

    Hi ,
    Only my 2 cents,
    if i read your system specs correctly, you have installed 4 x 2048 Mo (8G) of Ram ?
    Do you run WinXp 64bits, because only WinXp64 will operate on 8G of ram...

    The maximum amount of system ram that WinXp32 will support is 4G
    (2 x 2048Mo) according to Microsoft.
    I would remove 2 stick of ram and see if things get better...

  11. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Thanks Big Dan,
    It's a 4gig kit (2 sticks of 2gb each). Ive tried running both sticks, and just one....its gotta be this damn board.
  12. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Hey again folks....
    Alot more issues here. I returned the motherboard (Asus M3A78 Pro), and bought an Asus M3N72-D.
    Still having crazy issues with the Blue Screens.
    I've returned the RAM and i'm expecting new ones in the mail soon. In the meantime, i've picked up a 1gig stick for testing purposes.
    Here are a few more minidumps.

    Is it possible 2 bad boards?
    All of my hair is turning
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    firehazard, I read all four minidumps and one error is 0xD1, another two are 0x1E, and the remaining one is 0x3B. They all cite core Windows drivers.

    Questions: Are you still trying to run your system on 4 gigs? Have you tried running with just 2 gigs at this time? For information sake have you tried running harddrive diagnostics?

    Asus boards are well known for being picky about what RAM is used and configurations. What does the Manual and website say?
  14. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Right now, i'm trying to get the system stable with 1gig of ram. I'm going to run some HD diagnostics now.
    My 4gigs should come back in the mail in a week or so.
    The RAM that i'm using now is on the QVL for my board, and so is the 4gb kit that i'm waiting for.
    Newest BIOS, all windows updates, all driver updates.
  15. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Ran SeaTools from a boot cd, it took a while to run, but it passed with no errors.
    I ran a long test, short test, then a long test again. No problems with the tests.
    I'm going to format the drive and reinstall again. Hopefully the 12th time is a charm.
  16. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    No luck at all.
    New RAM, all sorts of settings and voltages.
    Its an SATA drive, and i didnt load the drivers at the start of windows. Its running in IDE mode, not RAID or AHCI.
    Any more ideas?
  17. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    I read all your dumps and the following errors were present: 0xFC, 0x3B (3x), 0x1E (4x). All cited core Windows drivers with the exception of avgntflt,sys which is an AVG driver. The latest version AVG 8 have given many problems. You might want to uninstall completely.

    * If you do let us know the results but make sure you use AVG's own removal tool to make sure all its remanants are gone. if you are still getting BSODs let us know.

    * One other thing. Your dumps repeatedly stated that checksum was unable to load for ntkrnlmp.exe which is a core Windows driver. Look up checksum.
  18. Big Dan

    Big Dan TS Rookie


    Very recently i had 2 systems with random BSOD's, i got 1 back on rails with the help of Route44 (VIA SATA driver problem), but the other one was pure misery until a made a try/install with an IDE drive... No more BSOD's, no errors whatsoever. So it had to have something to do with the SATA drive; I then scanned that Western Digital SATA drive with their tool and it passed with flying colors. Installed another brand SATA drive (Seagate), all is OK!
    Seems the system could'nt tolerate that SATA HDD, strange...
    After following Route44 instructions, i would suggest you try another HDD...
    Also, i would set "Default settings" and check the date/time in BIOS, before trying again.
    Have you tested your PSU with a PSU diagnostic tool ? Even new it can be defective, and the mtb needs all the power it can get...
    Whatever you do, change only 1 thing at a time before trying again... Its a lot
    of work but you'll get throu. Please post your results...

    Big Dan
  19. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Hey folks,
    Thanks for your replies.
    I've formatted (yet again), and loaded on Windows XP 32bit. I've just finished updating all the drivers. It blue screened on me 3 times before installing the Video Drivers, (0x0000008E), or something. After loading on the video drivers, its actually hung up twice. No blue screen, just stops responding, except the mouse can move.

    Unfortunately, the only thing i can swap out with my old machine is the power supply. So, i'm trying that....hopefully thats all.

    With the brand new PS, in the bios, the 5v rail is at 4.93? Thats the only odd thing i've noticed.
    I'll see if i can backup all my stuff from one of my old ATA hd's and try loading windows on that. If i get it to run stable with the ATA hd, can i still hook up the SATA 750gig as storage?
  20. Big Dan

    Big Dan TS Rookie

    Hi again,

    Don't worry about the 4.93v , voltage always varies a bit and its rarely on the nose... Its close enough... But its a good idea to swap PSU's..., Also try disconnecting stuff that is not essential to installing Windows, like the front usb/audio header and/or media card reader, etc... Keep the minimum.
    Then i suggest using a HHD tool such as "killdisk" to completly wipe/erase the HHD; There's been to many installations attempts on that drive and formatting doesn't really erase the data, it's still there and may interfere and corrupt your install. After using killdisk, you will start as if it were a factory new drive.
    And yes, you could also try installing on that ATA drive of yours... See if it works, then you could use the large SATA for storage. You will be able to choose on wich drive to boot in the BIOS setup. Just be carefull as for the jumpers (master/slave) on the ATA and CD/DVD drive if on the same IDE cable...
    But first try killdisk, i would rather have that speedy SATA 3 drive as system disk,
    if that doesn't work, then try with the ATA drive.

    Big Dan
  21. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    If your PSU is not functioning correctly that can cause all kinds of issues and it would go a long way in explaning a lot of things especially since you've got really good equipment. Do you have a digital multimeter that you can use to test the voltage?

    0x8E errors are almost always due to harddware. Can you attach your most recent minidumps in your next post? You can Zip up to 5 together.

    Also, when you reformatted again did you reinstall AVG? How are your connections between motherboard and HDs?
  22. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Hello again.....
    Between the 2 Power supplies, i cant get the new system to run stable at all.
    Both power supplies run fine in my old faithful tractor of a computer. I've tried 4 SATA cables on the new motherboard. Same thing.
    I didnt install AVG at all yet, i'll do that tomorrow.
    I do have a multimeter, but testing the PS with no loads on it seems kinda pointless.
    I've had hardware monitors running logs on it, all seemed normal, no spikes or dips.
    I'll have to get a few more blue screens before i attatch them again. I put the computer to bed for the night. I've probably got about 150 hours into this friggin AMD / ASUS computer....
    I'm seriously reconsidering the choices i've made for hardware....
  23. mflynn

    mflynn TS Rookie Posts: 2,655

    Hi FireHazard

    Since you have plenty of free time and nothing better to do......

    Wait on installing anything. If it is not stable it may be a waste of time at the very least.

    How unstable, other words can it run long enough to do a few diags?

    Questions below, answer by specifying the number and answer..

    1. Was your last install a full format?

    2. If so what other programs have you installed?

    3. Have you done any M$ updates?

    4. Have you copied any backed up/saved data back to the system drive?

    5. How many partitions on this drive and do you have a second drive?

    6. Do you have any external devices?

    7.Have you used a Flash drive for any reason since your last format?

    8. Is the system stable in Safe Mode?

    9. Have you checked the event logs for a recurring error.

    10 Is the XP CD you are using a Factory CD or a burned CD to produce a Slipstreamed SP?

    Now some things to do.

    After you have tested the stability in Safe Mode (and let me know results) then do the below.

    Boot to the Advanced Boot menu but instead of Safe Mode chose VGA mode and check for stability here.

    Then get me the Diags below.

    Download ComboFix ( I do not suspect Malware yet until you answer my questions above) but do this to get recovery console. And it may find something.

    NOTE: If you have had ComboFix more than a few days old delete and re-download.

    Get it here:
    Or here:

    Double click combofix.exe follow the prompts.

    Install Recovery Console if connected to the Internet!

    When finished, it will open a log.
    Attach the log and a new HJT log in your next reply.

    Note: Do not click combofix's window while its running. That may cause it to stall.


    D/L to Desktop: DDS by sUBs from one of these locations:

    double click DDS.scr to run

    When complete, DDS.txt will open.

    Click Yes for Optional Scan.
    Save both reports to your desktop.

    Attach the contents of both logs back here.

    Next get these unneeded services out of the way.

    Clean and tweak services

    In services stop and disable all of the below just to get them out of the way for now for trouble shooting purposes.

    Nothing is un-installed or deleted only disabled from running!

    They can be put back anytime later but I would not, as none of them are needed by most home users and very few business users. Basically stuff M$ thought you should have.

    Disabled uses no memory (RAM) and no CPU cycles.
    Manual uses the RAM but a small amount of CPU.
    Auto and not started they use even more RAM and CPU.
    Auto and started even more RAM and CPU ..

    Now in this case we disabling for trouble shooting purposes. But when we finish if you leave them all off until it is noticed that you need one (not likely for 99%) then it can be enabled.

    Leaving these all off, then becomes a performance tweak/boost as they free some RAM and CPU cycles! Special note. If you are going to pick and choose then be aware that the small amount of RAM and CPU cycles of each one individually is not significant but as a group it is! So if you need most of them (or just think you do because you don't) then just as well enable them all)!

    Distributed Link Tracking Client
    Distributed Transaction Coordinator
    DNS Client
    Fast User switching
    Health Key and Certificate Management Service
    Indexing service
    Net logon
    Net.TCP Port Sharing
    NetMeeting Remote Desktop Sharing
    IPsec services
    QoS RSVP
    Remote Registry
    Uninterruptable power supply
    Universal Plug and play
    Web Client
    Windows media player Network Sharing

    IF you are using a wired network card and "NOT" using wireless on this computer then you can
    also disable

    Wireless Zero configuration

    Wireless Zero configuration is only used on computers with a wireless NIC like a Laptop. Do not disable Wireless Zero configuration on a Laptop. Has nothing to do with other wireless hardware like wireless routers etc.

    In short if this computer has a CAT 5 or 6 cable and no ability to connect wirelessly if that cable is unplugged, then you can disable Wireless Zero configuration.

  24. FireHazard

    FireHazard TS Rookie Topic Starter Posts: 19

    Awesome....i love having a list of things to try. At least it doesnt feel like i'm spinning my wheels doing the same things over and over.
    I couldn't get that Active@ Killdisk to work, i tried 2 differnt ISOs. It boots to a little dos based menu, but when i click on the Killdisk, it just sits there for a while with some text at the bottom of the scree.
    1. Yes Full format, not the NTFS Quick one....took about an hour and a bit.
    2. The first and only thing i loaded up was WhoCrashed
    3. All M$ updates are currently downloading
    4. Have not backed up anything onto the new HD.
    5. This install....2 partitions. Same result with one big partition.
    6. 2 USB HD's, one currently using to drag the video drivers and chipset drivers over instead of downloading them all over.
    7. No flash drives
    8. Safe mode, i only tried to use it to use system restore after failing to boot.
    9. Event logs showed a DCOM error or something, after googling it, found out it was nothing to worry about.
    10. Factory CD, with SP2. Tried slipstreamed copies of XP32 and XP64.

    I'm gunna run it with my new install for a while, so i can get some minidumps. I'm crossing my fingers, and plucking out a few grey hairs.

    Thanks for the awesome support i've far.
  25. mflynn

    mflynn TS Rookie Posts: 2,655

    Opps the reason I was asking about partitions and external drives was that may be where you are getting reinfected.

    I suggest you immediately install Avira update and Full scan all drives.

    If it finds and removes ANYTHING then follow with DrWeb from here:

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...