VISTA BAD_POOL_CALLER (c2) after standby

By CyberCSK
Dec 6, 2007
  1. Hi,

    whenever my laptop wakes up from standby I get a BAD_POOL_CALLER (c2) BSOD. This problem occours since my default installation with Windows Vista.

    Hardware: Asus Z53JC

    I tried to analyse the crashdump by myself, but don't get to know what the reason is, because it says

    MODULE_NAME: rdbss

    IMAGE_NAME: rdbss.sys

    I found out that the rdbss.sys is some essential driver module. So I don't think that this is the real reason.
    I guess that this module is conflicting with any other driver, so I tried


    GetPointerFromAddress: unable to read from 821315b0
    THREAD 866296b0 Cid 0004.01b0 Teb: 00000000 Win32Thread: 00000000 RUNNING on processor 0
    Not impersonating
    GetUlongFromAddress: unable to read from 8210ad90
    Owning Process 83a7fd90 Image: System
    ffdf0000: Unable to get shared data
    Wait Start TickCount 3381924
    Context Switch Count 36
    ReadMemory error: Cannot get nt!KeMaximumIncrement value.
    UserTime 00:00:00.000
    KernelTime 00:00:00.000
    Win32 Start Address rdbss!RxBootstrapWorkerThreadDispatcher (0x8e13abf6)
    Stack Init 8a880000 Current 8a87f67c Base 8a880000 Limit 8a87d000 Call 0
    Priority 8 BasePriority 8 PriorityDecrement 0 IoPriority 2 PagePriority 5
    ChildEBP RetAddr Args to Child
    8a87fb10 822d6b35 000000c2 00000099 844b54c4 nt!KeBugCheckEx+0x1e
    8a87fb30 820469e8 844b54c4 00000000 844b54bc nt!VerifierBugCheckIfAppropriate+0x32
    8a87fb48 820e80bc 844b54c4 00000258 00000000 nt!VerifierFreeTrackedPool+0x24
    8a87fbbc 8e1316bd 844b54c4 00000000 86361e18 nt!ExFreePoolWithTag+0x552
    8a87fbd4 8e131436 86361e18 844b54c4 00000000 rdbss!RxNameCacheFreeEntry+0x4d (FPO: [Non-Fpo])
    8a87fbec 9ba65f56 86361e18 9ba57984 86361d60 rdbss!RxNameCacheFinalize+0x46 (FPO: [Non-Fpo])
    8a87fc04 9ba4c480 86361d60 8433f9e8 8a87fc34 mrxsmb10!SmbCeTearDownNetRootEntry+0x6f (FPO: [Non-Fpo])
    8a87fc14 9ba6604a 86361d60 9ba57984 000001af mrxsmb10!SmbCepDereferenceNetRootEntry+0xb1 (FPO: [Non-Fpo])
    8a87fc34 9ba7a389 8433f9e8 00000000 8433f9e8 mrxsmb10!MRxSmbFinalizeNetRoot+0x8a (FPO: [Non-Fpo])
    8a87fc48 8e112c9f 8433f9e8 00000000 8433f9e8 mrxsmb!SmbShellFinalizeNetRoot+0x23 (FPO: [Non-Fpo])
    8a87fc5c 8e1315d4 8433f9e8 00000001 0000eb11 rdbss!RxMRxFinalizeNetRoot+0x45 (FPO: [Non-Fpo])
    8a87fc78 8e12419f 8433f9e8 00000020 00000001 rdbss!RxFinalizeNetRoot+0x16c (FPO: [Non-Fpo])
    8a87fc9c 8e130f0c 8433f9e8 00000002 8e121000 rdbss!RxDereference+0x16a (FPO: [Non-Fpo])
    8a87fcbc 8e12f44e 8433f9e8 00000001 00000001 rdbss!RxFinalizeVNetRoot+0xdc (FPO: [Non-Fpo])
    8a87fcf4 8e12f63b 9c28d020 00000001 86659030 rdbss!RxScavengerFinalizeEntries+0x533 (FPO: [Non-Fpo])
    8a87fd14 8e10d210 0028d020 8a09ec8a 00000000 rdbss!RxScavengerTimerRoutine+0x6a (FPO: [Non-Fpo])
    8a87fd6c 8e13ac05 8e121fa0 00000000 8a87fdc0 rdbss!RxpWorkerThreadDispatcher+0x136 (FPO: [Non-Fpo])
    8a87fd7c 82225526 8e121fa0 8a874680 00000000 rdbss!RxBootstrapWorkerThreadDispatcher+0xf (FPO: [Non-Fpo])
    8a87fdc0 8209159e 8e13abf6 8e121fa0 00000000 nt!PspSystemThreadStartup+0x9d
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16

    But since it says "Unable to get shared data" I don't get further with it.

    Attached you find my Minidump.

    Please help and make suggestions on what I could try else.
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Do you have a recovery disk? I really don't know about Vista but I know under XP the way to resolve this was to insert the XP CD... Intall option... "Repair"
  3. CyberCSK

    CyberCSK TS Rookie Topic Starter


    thank you for your suggestions, but Vista has a different repair system. You can not perform a repair installation. The Vista DVD checks the existing installation for errors, and if no errors are found (like in my situation) nothing is done. The only option is to return to certain system restore points. But since my BSOD failure occours since the first installation, this does not seem to resolve my problem. I hope that someone will be able to read my crash dumps and can say what wents wrong in my system.

  4. CyberCSK

    CyberCSK TS Rookie Topic Starter


    now I have a different error message, but most propably caused by the same reason.


    But it's not as last time, when certain modules like rdbss.sys and mrxsmb10.sys where metioned. Now it is ntkrpamp.exe, which also is an essential windows component and no special 3rdparty driver is shown.

    I'm very confused about this, because under Windows XP this Laptop was very stable and reliable and now with Windows Vista some bad driver I don't know annoys me.

    Please help!

    Arg1: 00000000, memory referenced
    Arg2: 0000001b, IRQL
    Arg3: 00000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
    Arg4: 820a90b0, address which referenced memory

    Debugging Details:

    WRITE_ADDRESS: 00000000


    820a90b0 890a mov dword ptr [edx],ecx



    PROCESS_NAME: System

    TRAP_FRAME: 888bcbfc -- (.trap 0xffffffff888bcbfc)
    ErrCode = 00000002
    eax=842b84dc ebx=00000000 ecx=00000000 edx=00000000 esi=861893e0 edi=888bcd00
    eip=820a90b0 esp=888bcc70 ebp=888bcc84 iopl=0 nv up ei ng nz na pe cy
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010287
    820a90b0 890a mov dword ptr [edx],ecx ds:0023:00000000=????????
    Resetting default scope

    LAST_CONTROL_TRANSFER: from 820a90b0 to 8208fd84

    888bcbfc 820a90b0 badb0d00 00000000 823a74b4 nt!KiTrap0E+0x2ac
    888bcc84 820b17a5 00000003 861893e0 888bcd00 nt!KiUnwaitThread+0x19
    888bcca8 820b153e 83a7fd90 861893e0 00000000 nt!KiInsertQueueApc+0x23c
    888bccc8 82287a8f 888bcd00 888bccf0 00000000 nt!KeInsertQueueApc+0x4b
    888bcd34 82207816 00000001 00000000 888bcd7c nt!ExSwapinWorkerThreads+0x96
    888bcd44 82078fa0 00000000 00000000 83aa4ad0 nt!PopUnlockAfterSleepWorker+0xf
    888bcd7c 82225526 00000000 888b7680 00000000 nt!ExpWorkerThread+0xfd
    888bcdc0 8209159e 82078ea3 00000001 00000000 nt!PspSystemThreadStartup+0x9d
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


    820a90b0 890a mov dword ptr [edx],ecx


    SYMBOL_NAME: nt!KiUnwaitThread+19

    FOLLOWUP_NAME: MachineOwner


    IMAGE_NAME: ntkrpamp.exe


    FAILURE_BUCKET_ID: 0xA_W_nt!KiUnwaitThread+19

    BUCKET_ID: 0xA_W_nt!KiUnwaitThread+19

    Followup: MachineOwner
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...