Tech Stocking Stuffers: 18 awesome gifts under $50

Vista won't boot if second hard drive connected.

By vnf4ultra ยท 9 replies
Mar 8, 2007
  1. My copy of vista absolutely will not boot if I connect a second hard drive on the ide cable(as a slave). It does the little "loading bar," but then the screen blanks out after that, and never boots(stops at crcdisk.sys). If I remove the slave drive it boots fine. The slave drive has a copy of linux installed on it, and I was hoping to just dual boot by switching the boot order instead of using a boot loader. The linux drive will boot by itself(if it's master), but kernel panics if I boot it with the vista drive connected. So to sum up, neither os works if both drives are connected at the same time, but either os can boot if it's the only drive(master). What can this mean?

    Also, I can't get my vista disc to boot if the slave drive is installed(with linux on it), but it works if the linux drive is disconnected.

    I can't see what could be the problem, both drives are separately installed copies of the os, so no bootloaders should be interfering, as I just want to select the drive in bios to boot.

    I also thought it might be related to my overclock, but I reset to default, and the situation is the same.

    The vista drive is a 80gb ide seagate(set cable select) and the linux drive is a 160gb western digital(set cable select), if that matters...

    Hopefully someone can help me...I've been messing with this for hours, and it's stressing me out.
  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Have you tried having one hard drive on the Primary channel and the other on the secondary IDE channel?
  3. vnf4ultra

    vnf4ultra TechSpot Paladin Topic Starter Posts: 1,388

    No, but I guess I can...

    Edit: I tried it with each drive on their own channel set as cable select, and I get the exact same problem(neither will boot). I then tried each on their own channel, with each as master, and in that case, the bios can't detect ANY ide devices(and hangs), and neither drive even can boot, since it doesn't get past the bios.
  4. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Did you make sure to check your jumpers and everything? IF you have them on Cable Select, I would recommend making them a master and slave.
  5. tomrca

    tomrca TS Rookie Posts: 1,000

    it seems that you may have two master drives. on the back of each drive there are groups of pin connectors. in one of those groups you will see that there will be a small object connecting two of the pins together. this will need to be changed to slave. there is usually a diagram on the drive. the easy way is to remove the jumper connector completely. but you can only boot from one drive, (as i do) although, i can still boot from the OS on that drive, by replacing the jumpers. i use the second drive for storage only, although i can still initiate the start of a programme from that drive ar required..
  6. vnf4ultra

    vnf4ultra TechSpot Paladin Topic Starter Posts: 1,388

    Ok, I tried setting the two drives(on one channel) to master/slave, with the one at the end of the cable being master, and the drive in the middle of the cable set to slave, and I get the same results as having both drives as cable select. So master/slave didn't help, neither drive can boot when both are connected. For the heck of it I tried both drives as slave, lets say the computer didn't like that very much, and it didn't work.

    I think I'll take the second drive to work and connect it to a usb/ide adapter to see what happens. I might just reformat the whole drive to see if that helps. Maybe the linux on the drive created a messed up mbr or something on it that confuses the computer.
  7. tomrca

    tomrca TS Rookie Posts: 1,000

    i have mine on seperate ide's
  8. vnf4ultra

    vnf4ultra TechSpot Paladin Topic Starter Posts: 1,388

    issue fixed

    I got it working...kinda the hard way. I did as I said, I took it to work, "borrowed" a usb to ide adapter from a co-worker (I really need to buy one, this is my second time borrowing it), connected the drive to a pc at work. The drive showed up, proving the drive was ok. I then copied the files I wanted to save off the hard drive, wiped off all partitions and created one new partition for whole hard drive, and copied the files I wanted back on the drive. I got home from work, put the drive in (both as cs on one ide channel) and bam, it's working fine now (but obviously linux won't boot, since I formated the hard drive, but it's not a big loss. Beryl was fun while it lasted...) It obviously was a problem that was caused by the linux on the drive, I just don't know what exactly. I'm glad it isn't what my coworker suggested, a bad ide controller on the motherboard. Thanks for all the input.
  9. dancingfool

    dancingfool TS Rookie

    Vista will not boot when second HDD connected

    I have exactly same problem as vnf4ultra in that Vista happily boots when only one drive connected (primary IDE and set as Master); when second HDD with NO operating system installed is connected(secondary IDE and set as Master) start up fails at crcdisc.sys.
    XP on second partition of first drive boots no problem when second drive attached so I have have no problem multi booting as such ONLY when second drive connected . I have tried every permutation of Master/Slave/Cable Select to no avail.
    I have multibooted XP in virtually every way possible and been able to trouble shoot any problems but this seems of Vistas making.
    I suspect that when second disc is connected the actual drive letter attributed by boot is different than that already alloted. Any suggestions?
  10. theRealDozer

    theRealDozer TS Rookie

    I've encountered a rather similar problem...

    I had successfully setup a dual boot system with vista ultimate and debian etch, however, i wanted to share my XP-Leftovers-NTFS-formatted-storage drive between the two...

    i have 3 sata drives, and they *should* all be set to "sata II" (3.0gb).

    80gb hitachi for linux
    160gb WD for vista
    320gb seagate for "shared storage"

    However... if my storage drive is connected, Vista WILL NOT BOOT. The drive is detected in Bios, and works fine in linux using the Fuse/Ntfs-3g solution.

    The same symptom described above happens... if the extra drive is connected, vista begins to start normally, but hangs at a black screen just after the "windows loading bar" screen. If i boot into Linux instead, all goes well. If i disconnect the storage drive, windows loads perfectly.

    I've been letting this drive (and my linux drive) sit in my case disconnected for about 4 months, because i was never able to find a solution to this problem. I'm beginning to think that it will never be "fixed" and i'll be forced to buy yet another drive, just to xfer my files, so i can format the storage drive, in hopes that it will somehow "just work" after.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...