Tech Stocking Stuffers: 18 awesome gifts under $50

WD Notebook not working

By cifc
Feb 16, 2010
  1. Hi I did see a previous thread which is now closed for this but there was no solution to the issue.
    I have a 320gb external WD notebook and I have had it less then 6 months.
    It has been working fine without any issues but today I was copying some files over to it and half way through it came up with an error message.
    I rebotted my computer and when I came back the drive had gone from my computer.
    I have looked in disk management and it is not there but is recognised as a drive in device manager.
    When I plug it in the drive seems to start up and windows bings as usual but the drive never appears and after 5 minutes the drive itself stops whirring.
    I have tried it on another pc with no luck.
    I am ok on computers but not an expert so please can someone give me a hand and try not to get frustrated when I'm not sure what you mean :)
    I hope someone can help as I have alot of films and programs on here that i paid for from various websites.
  2. hughva

    hughva TS Rookie Posts: 58

    What is the error message?
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +419

    If you've tried it on other computers and it doesn't work the drive may be dead. You could try a drive diagnostic utility like SeaTools but I'm not sure if it will work if disk management isn't seeing it - worth a try though.
  4. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    As SNGX very rightfully pointed out that if your computer is not detecting the drive, mostly likely it is dead. However, if on the other hand if your system does detect it (or show some unidentified hardware in device manager); there may be a hope, you may choose to have a look at testdisk to see whether it helps as well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...