Webcam isn't detected/operating

Rick Miller

Posts: 17   +2
Good Day:

My laptop is a HP2000-210 notebook. I run a LinuxMint 17.1 cinnamon/Rebecca 64bit O.S. I have "cheese" & VLC available for webcam operation. However, I cannot get either to correctly active/operate the integrated webcam. I will try to provide as much detail as I can, then I have a few questions and demands. Every once-in-a-while the webcam will operate through "cheese"; albeit for only 7 seconds to about 2-2 1/2 minutes. Then it shuts down and error reports "No Device Found" or "Error Playing Video". In VLC, it's error reports "VLC is unable to open the MRL 'v4l2://'. Check the log for details." I've even tried guvcview and it's error report is "check for correct drivers". I've been to/on just about every Linux/Ubuntu forum I can find. I've been to/on HP~Linux forum. Have multiple postings at those forums dealing with this issue and as yet, all efforts have been futile. I getting the impression I have 'driver" issues, but I cannot ascertain what drivers I need from Linux; nor why they are not in the kernel?!!
#1. We know the webcam is operable(works), so we can rule out hardware. #2. I'm completely baffled as to how it will operate so intermittently. #3 How I get a different error report from each software app ( I.e. VLC~cheese~guvcview).
PLEASE, don't tell me to go to Linux/Ubuntu; Please, don't tell me to go to HP. I've have all but exhausted those avenues.
Forgive me if this post is not in the proper forum. Tell me and I'll post to the correct forum and delete this here! Should you need any other info please request specifically, what you want/need and I'll be glad to forward/post it.



Posts: 376   +8
Not to say that this is the Wrong place to put it, it is definitely a Laptop/Mobile computing issue, but not everyone knows Linux systems, I myself am not a Linux user and don't fully understand how to use it, so I will suggest posting the exact same stuff (Just copy the info and make a new thread) and post here:

For the Title, just add "Linux" at the end or something so that users can identify quickly and not have to read through the full post :) Best of luck with your issue, wish I could help more.