weird Networking ADSLROUTER -> Switch -> NIC problem

By milkmaid ยท 7 replies
Oct 12, 2005
  1. Firstly im new here so hello everybody!

    Im trying to do some what i would regard as some fancy stuff networking style

    i have this set up
    ADSL ROUTER --------- SWITCH ===========cables to several machines
    and it keeps dropping the internet works fine with just 1 computer connected thru the switch

    we have several machines in the house and we have been using internet connection sharing ICS with an old server machine and a switch in the roofspace to do all the connecting together to keep speeds up etc :) all well and good and worked fine enough...

    NEW ADSL ROUTER with wireless comes along and mucks it all up

    now i have an adsl router connected to the internet fine.. and i can plug PCs into the router directly and they work fine also.. problem is we have a number of computers... too many to all fit into the router and anyways wouldnt want to re route all the cables so i had the bright idea of connecting the router to the switch using the existing cable that the server was using.. IT WORKED! i was well happy.. but now ive noticed that it keeps dieing and i have to restart the router to get it all working again.. does anyone have any idea why this might be?

    works fine with just 1 machine connected thru the switch tho....??

    Im setting this up for my parents and family and need to get it all working before i go back home anyone have any thoughts would be v much appriciated


    Duncan :)
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your router cannot handle the load of many connections generated by many clients. Is it some El Cheapo (TM) brand by any chance?

    Are any of the computers running hogging programs like p2p clients? 300 connections for a p2p client times 10 computers is more than most routers can take.
  3. milkmaid

    milkmaid TS Rookie Topic Starter

    Hey Nodsu

    Its not mega expensive that is tru but it should be good enough

    It fails after a min or so.. even if the only trafic is a couple of searches on google.. perhaps even if just connected.. it does it with just 2 machines like this.. nothing intensive... its been fine in the past shoving all kindsa stuff thru it.. im sure its to do with the connection from the switch to the router as all connections run thru this... the router still assigns IPs etc thru the DHCP but DNS lookups are failing cant browse web etc... havent checked to see if u can ping an external ip addy ie the web...
  4. milkmaid

    milkmaid TS Rookie Topic Starter

    ok ever weirder!!

    i just tried to search on google for firewalls after replying to a different post and it turns out i cant access google.. but i can access this website.. and my dos window still lets me ping google ?? and i can post this reply as well! ???? wtf ? but i cant access
    ok i just used the IP address to access google so it looks like its just the dns which seams to not work! ?? ok well at least i have narrowed it down a bit! :)
  5. milkmaid

    milkmaid TS Rookie Topic Starter

    dns on router was not working i worked around this by setting the dns servers of the machines manually to the ISPs ugly but works.. ovislink dont seam to have any support at all no new firmware other than a french update im hesitant to use as i dont want a french interface on my router! :)

    hope this maybe of use to someone doubt it tho .. have a nice day
  6. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    statically adding the DNS address is going to bite you sooner or later, and
    you should get DHCP working correctly

    Are you wired correctly?
    there's an UPLINK port on the switch that can go to
    any LAN port on the router. The other systems go to any other port on the switch.

    For reasons of physical layout in the room, I have
    modem--->router ---->sys#1
    ......................+---->switch ----->sys#2

    shutdown EVERYTHING, modem first.
    restart the modem and let it settle down
    restart the router and " " " "
    start ONE system only and use Run to enter
    cmd /k ipconfig /all
    you must get an IP address, mask, gateway address and the DNS address.
    until you do, the rest will be wallering in the mud.

    You may need to login to the router and configure some stuff, in particular,
    the MAC address to be shown to your ISP. Some ISPs will only take the
    connection created when the service was installed (ie that first computer
    attached to the ASDL modem BEFORE the router was in place).
  7. milkmaid

    milkmaid TS Rookie Topic Starter

    That looks really hellpful i havent had a chance to try anything but what i can say is that currenly i have a single cable up to the switch from the router and it doesnt go to the uplink port it didnt seam to work when it was wired like that....

    The DHCP is working and if i leave all pcs to obtain settings auto then they all get ip adresses fine and all have the DNS server set to that of the router which i would thought would be correct.. but the dns just doesnt work with more than 1 pc...

    i dont see where i would enter the mac address to be shown to the ISP but this would make sense in the way that it is not working it may well be something along this line

    will have a play once i have finished setting up this new pc... ooh and new memory for my laptop :D

    cheers jobeard
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    If your ISP demanded a specific MAC address then the connection wouldn't work at all with the router. Even with only one PC connected.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...