Weird networking problem

By mikescorpio81 ยท 6 replies
Aug 9, 2006
  1. Hi all,

    Client consists of 5 PC users in a WORKGROUP environment. All PC's using XP pro OS and map a drive to a shared folder located on 1 of their PC's. Lets call this PC "SKY".

    Users can all ping the internent and each other; all except for sky. Sky can ping the internet and other users but no one can ping sky! They used to be able to due to the fact that they map drives to a share on sky's HDD! There is no software firewall present and windows firewall is switched OFF.

    Recently their switch was playing up so I replaced it with a more business-grade switch. Seemed to sort them out for a while until it started up again today.

    Before I replace SKY's network card I was wondering if anyone else has had a similar problem or could offer a suggestion.

    Cheers :grinthumb
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you pinging by IP address or computer name? I assume all other services on SKY are unavailable too?
  3. mikescorpio81

    mikescorpio81 TS Rookie Topic Starter Posts: 293

    I am pinging ip address as well as host name. From sky you can ping everyone both internally & externally, resolving host names into ip address and vice versa. Seems fine, until you try and ping sky internally from any other client pc.

    I am due to change the NIC today. Something tells me its the NIC.
  4. joked u 2

    joked u 2 TS Rookie Posts: 128

    Just recheck the ip settings. are they static or dhcp?? if dhcp renew the ips on all machines make shure they are on the same workgroup and domain[ if applicable] set the subnet mask [ie,] to the correct class. are you pinging from DOS or a third party program?try "net find" in DOS. see if you see all the machines. did this just happin arbitraly or after you did somthing?
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    does it say timed out or ?
    can try setting negotiate to 100 full dup
    on all
    check the managed switch that to should be set the same
    check the nic driver status see if you still have the advanced settings
    if not corrupt drive issue
    I just had to back date a pro 1000mt the newer driver where not staying
    on boot would revert to default xp and would loose connection to this machine

    make sure the netbios box is ticked
  6. mikescorpio81

    mikescorpio81 TS Rookie Topic Starter Posts: 293

    I tried swapping between full/half duplex settings on the NIC but to no avail. This PC (SKY) is statically assigned an ip address due to the fact that within the workgroup, sky is the main sharepoint. Setting it to DHCP will not sole the problem (believe me i've tried!). I have also assigned it different ip addresses in the past and have totally changed they network subnet but it didn't help. Clients receive time out errors when they try to ping sky.

    I have installed the new NIC btw. if this doesn't sort the problem I'll let u all know. This (I hope!) should be the end of it ... but then again Windows Workgroups always tend to suprise me!

    Cheers :grinthumb
  7. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    all servers should have a fixed IP address, a well known name, and an entry
    in the LDAP, DNS, or a host/LMHOST file you distribute.

    As you're behind a router, you will need ports 135-139 + 445 to be open on
    ALL systems in the subnet.

    re: ping; is there ANY chance that SKY has the NIC configured for IPv6
    while all others are IPv4?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...