Wii only connects with security disabled (error code 51330)

By leandrocorrea ยท 10 replies
Aug 1, 2010
Post New Reply
  1. Hi everyone,
    I'm having some trouble connecting Wii to my home wireless network, can anyone help?

    Everything goes ok when I disable the wireless network security (open access), but when I enable any combination of security supported by Wii (WEP, WPA/PSK, WPA2, AES or TKIP), it stopps connecting and give error code 51330. According to Nintendo Troubleshooting support, this code relates to incorrect wireless key, but I'm typing everything correctly...

    When searching for the Acess Point, the Wii always finds my wireless network, but only connects to it when security is disabled. When enabled, it asks for the key, but fails testing connection.

    Here's a list of every thing I already tried:

    - Enable / Unable MAC filtering
    - Changed wireless channels from 1 to 11 (and 2 and 3 and 4 ...to 11)
    - Manually entered IP (and sub-mask and DNS) settings instead Auto
    - Different uppercase / lowercase SSID and key passwords

    None of these worked.

    Here's some hardware information:
    - Wii Menu 4.3U (softmoded, HBC installed)
    - D-Link 524 router

    What I'm going crazy is the fact that the Wii wi-fi connection works perfectly without security; I've downloaded Wii channels, played Mario Kart online, all perfect. But I really don't wanna leave my wireless network open neither having to opening/closing all the time just to get Wii online... =(
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Sorry I can't help you, but my sister had an identical problem with hers. Then she moved and its working, she said she changed some setting on the router, I'll post back if she can tell me what it is.
  3. leandrocorrea

    leandrocorrea TS Rookie Topic Starter

    Thanks for your attention.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Well I talked to her, with disappointing results. She disabled something in security that sounded like an automatic setup. She's not the most tech savvy person so I wasn't able to get much good out of the conversation, but security is still enabled in some form I believe because she still has to enter a key to get connected.

    Sorry this wasn't any help. I suppose at worst case you can pick up a really cheap wireless router and connect it to your existing one (on different channels or even frequencies if your routers support), because even a cheap one should work fine for just supporting 1 wireless connection.
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A few thoughts...

    1) Have you checked for any firmware updates for both the Wii as well as your wireless router?

    2) I don't have a Wii so don't know... but can you actually see the key you enter? (so you know is correct?) Plus, i assume you know the keys are upper/lower case sensitive

    3) Do you have MAC filtering enabled on your router? (that further limits access to the router to very specific hardware)

    4) You might also try a friend's router. See if the problem is the Wii or the router
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OOps. My first quick skim missed the fact you already tried points 2 and 3. But do look for any firmware updates and try a different router. If only out of curiousity.. and to help any others finding this thread with similar problem in the future.. let us know what you find out :)
  7. leandrocorrea

    leandrocorrea TS Rookie Topic Starter

    I'm guessing she was luckier than me, then... I'll try connecting only the Wii (turning off my notebook wireless), maybe it only handles one connection (it shouldn't, but maybe?)

    1) Both Wii and router's firmware are now up to date
    2) Yes, I can see the key I type :) I've tried different case sensitive variations (Google told me to try that!)
    3) MAC filtering the Wii -- check!
    MAC filter off -- check!
    Both cases, doesn't make difference: it only connects if security is disabled :(
    4) Goog idea, I'll test with different router to see what happen.

    Anyway, thanks for all of your attention. If succeeded, I'll come back to share how I did.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for the update.....

    One last out-of-the blue thought as all else has failed so far.. You might also reset the router back to factory defaults (there should be a reset button). Don't know if the Wii has the same option but might also be worth a try. After both are reset, then try the wireless setup again for both devices.

    Hope you find something that works !
  9. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    this is a typical symptom of firmware mismatch, meaning both ends (the wifi and the router)
    are attempting encryption using some defined protocol {eg WEP, WPA, WPA2}
    and for whatever reason, the exchange fails which then drops the connection.

    I have seen previously that updating BOTH the router and wifi driver to the latest levels available will resolve this goofy issue.
    Most typically this symptom occurs with the better WPA & WPA2 protocols but WEP can be used successfully
    (albeit with the added risk that it is easily hacked). You appear to have a total incompatibiluty for all protocols.
  10. leandrocorrea

    leandrocorrea TS Rookie Topic Starter

    Thanks for your help. The firmware was already up to date (Firmware V4.05 - H/W H1), but I did the update process again just to make sure, and it didn't worked...
    I don't know if there is a way of updating Wii's firmware -- as long as I know, I can update the system menu only, and this too is already up to date (version 4.3U).

    I've made some tests turning off and rebooting both Wii and wireless router, didn't work too. I'm going nuts! :)
  11. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    sorry to hear of the continued suffering. Until the /RELEASE followed by a /RENEW will cooperate, sadly you will continue to have this symptom.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...