Windows 7 64-bit: 2.99GB usable RAM

By nismo91 ยท 16 replies
Oct 4, 2011
Post New Reply
  1. hey all, i've just downloaded windows 7 64-bit SP1 pro from MSDNAA and i just tried clean installing WIndows 7 64-bit Pro into my 3yo laptop with the following spec:

    Intel Core 2 Duo P8600 (2.40)
    4GB DDR2-667 RAM
    nVidia 9600M GT 512MB GDDR3
    320GB 5400RPM HDD

    and i only have '2.99GB usable' RAM in the computer properties and task manager. the laptop motherboard only support max 4GB of RAM, and i heard this might be the cause of the problem.

    so basically im asking for your opinions, should i return back to 32-bit? since it shows exactly same amount of RAM in the windows itself. or is there any 'hacks' that allows me to use those extra gig of RAM?
  2. Coodu

    Coodu TS Booster Posts: 173

    A quick Google search netted me this:

    Particularly the first answer, with the most striking quote:

    "In order to expose the entire 4GB RAM to the OS, the system hardware must actually support MORE THAN 4GB address space and implement a feature called memory remapping or memory hoisting."

    Going by that logic, you might be out of luck since your motherboard only supports up to 4GB. You could return to 32 bit if you like, but unless you're having software compatibility issues I'd just stay put if it was me.

    Hope this helps.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You could check if the BIOS has options for memory remapping.
  4. Arris

    Arris TS Evangelist Posts: 4,730   +379

    I would have guessed that the memory might be used by the graphics card but nVidia 9600M has its on ram so shouldn't be the case. I'd do a little bit of research and see if your laptop model has some feature that reserves ram for use which is disallowing the use of all the ram by Win7 64bit.
  5. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    thanks for the replies, after some more googling with my laptop model number, i found out that i might need to update the BIOS. the problem is when i tried to do so the .exe returns an WDM not found error. I assume this is because i'm running win7.

    i checked the BIOS and it doesn't have memory remapping option. someone claims that he can get this laptop to show 4GB in the task manager.

    yes, the 9600M GT has 'turbocache' feature but i can't figure out how to disable it. in dxdiag RAM shows 4GB (used to be 3 in 32bit) and VRAM shows 1.7GB, which is absurd. anyway i think im gonna install 64bit vista again, just curious.

    P.S. i need the extra gig cause i am doing some virtualization lately. i believe the extra memory would help this old lappy
  6. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    finally! apparently the BIOS update solves this issue. after going back into vista 64 and perform the bios update, 4GB of RAM shows up.

    i hope this thread will be useful for anyone who have similar problems. now i know why my laptop is not shipped with 64-bit out-of-the-box. it was not working then. luckily the key on the sticker works with the 64-bit as well.

  7. Harry Hill

    Harry Hill TS Rookie

    Hello--another twist to the ONLY 2.9 GB out of 6 GB useable.
    As I said, Win-8-64 (new install) and Ubuntu showed 6 GB installed.
    NOW!!..I just installed another Win-7-64 on another partition. Just the bare thing with no programs added. showed 6 GB. But-when I go back to my Win-7-64 Default working drive with programs installed, it ALSO SHOWS 6 GB. No mention of USEABLE.
    Problem solved-but WHY?
  8. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    in my i5 desktop running Win 7 Pro 64bit it says RAM: 8.00GB without any mention of usable as well. I believe it should just work.

    just one way to ensure is go to task manager and check the physical memory values in performance tab (refer to image above). no idea what seems to be the problem though.
  9. Coodu

    Coodu TS Booster Posts: 173

    Yeah mine says 6GB no usable value. Going into task manager gives me an available memory of "6134MB" so it's available to the system which is all that really matters I guess.

    Glad to see you got the problem sorted too nismo :)
  10. User1089

    User1089 TS Rookie

    I think I'm having a similar problem. I've got 3GB of memory installed, but almost 2.3GB is marked as 'hardware reserved'. On a system like mine I'm sure this figure should be more like 500MB. It's having a serious effect on performance. I've already tried:
    1. Updating the BIOS
    2. Updating the video card drivers
    3. Restoring the laptop to factory settings
    4. unchecking maximum memory in msconfig/boot/advanced
    After a lot of googling, I saw some forums recommending 'memory remapping' but I can't find that option in the BIOS


    Attached Files:

  11. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    have you tried resetting the bios instead? some amount of RAM may be reserved for your video adapter (AMD4200) but 2.3GB is clearly too much. also, do try to remove one module of RAM from your laptop. if only one is found, try to place it in another slot.
  12. User1089

    User1089 TS Rookie

    Bit of an amateur here. Both of those options require me to open up the laptop case right? How easy is it to do? My warranty is long expired and I don't think I can afford to accidentally mess something up permanently.
  13. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    for most laptop, there should be a maintenance cover which will directly lead you to the RAM. there is no need to dismantle the entire laptop to access the RAM.

    the underside of your laptop should look like this:

    and you can see the maintenance cover only requires you to remove 2 or 3 screws. you should be able to see two RAM modules attached there. just remove one of the RAM by pressing out the two side legs. the RAM should pop up.

    to insert the RAM back, just push it in firmly in slanted (just like when it pops up) all the way, and then press it down so it's securely locked. (you can always youtube how to remove laptop ram).

    note: always turn off computer, power adapter and battery before attempting to open the laptop cover!
  14. User1089

    User1089 TS Rookie

    Thanks! Reseating the RAM totally worked!
  15. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    good to hear! nice to see it worked. ;)
  16. romgod9208

    romgod9208 TS Member

    Hello, I decided to bump this thread, I have the same issue with RAM. Gotta say I've tried everything and anything, all without results. My laptop (Samsung NP-R525-JV01CA) has 6gb RAM installed, 2gb and 4gb sticks. Resource monitor, win7 sys properties and all of the rest shows 6gb physically installed, only 1.75 usable.
    Attempts to fix:
    Msconfig max memory change /no results;
    BIOS update /fail, no results found, no model can be found on any support resources;
    BIOS remapping feature doesnt even exist;
    BIOS setting on system boot have a video memory allocation which is less than 1gb, means the 2gb stick might share memory, still insignificant amount;
    System is windows 7 x64 professional genuine ed, no problems here;
    Swap ram sticks, no results, always shows the same;
    Attempted to work with only 4gb stick, system doesnt boot while power is on.

    So far I think it is the 4gb stick that is faulty, but Im not sure. I might need updates for BIOS, motherboard, but win update and Administrative tools update dont have anything. Going on Samsung, Phoenix (my momboard producer) sites doesnt help because either no model such as mine can be found, or similar model drivers dont work. The only app that actually showed which drivers I need is which I found on Phoenix support site. This esupport has a bisoagentplus, which after download showed few drivers outdated, and offered to buy the program to install them. Sorry but this is bullshit, Im not supposed to pay for drivers for a system I already bought. Anyway if anyone has any ideas, would be greatly appreciated!!!!
  17. nismo91

    nismo91 TS Evangelist Topic Starter Posts: 930   +33

    This probably explains why you only have 1.7GB left. I believe, if you boot with only 2GB of RAM it would display the same available RAM. bad RAM usually cause this problem. but sometimes motherboard incompatibility is the culprit.

    have you tried the pencil eraser method? and btw, any chance there is difference in RAM speed between the 2GB and 4GB modules?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...