Windows file protection  repair

By crone ยท 7 replies
Nov 18, 2010
Post New Reply
  1. i just reinstalled windows xp 64 bit.after installing it i notice it a bit sluggish so i ran the sfc scannow and it says that file needed for xp to run properly needs to be copied,so when it finished i rebooted and run sfc again and its asking for xp cd,is there any way of fixing it
  2. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    SFC /scannow requires the system Installtion disc to replace missing files.. So if you are trying to run SFC then you need the disc.. There is no work around unless you have all of the XP intalltion files on the hard drive itself. Otherwise, just don't run SFC, it wont ask for the disc.
  3. crone

    crone TS Rookie Topic Starter

    i have the cd the thing is that i put the cd in but it does not seem to work as after i reboot and run sfc / scannow it still asks for the cd so is it most likely the files needed on the cd are missing or corrupted
  4. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    The files on the CD could be possibly corrupt, or the hard drive has an issue copying to the sector that is it saved on.. I would suggest to do a hard drive diagnostics test on it.. Go to the manufacturers website of the hard drive and download their diagnostics tool and run that... If there are no issues then you can assume it's either the Disc, or a bad software install and you may need to do another re-install since this is a fresh install right ?
  5. crone

    crone TS Rookie Topic Starter

    yes its a fresh install
  6. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    OK, well try doing a hard ware diagnostics of the hard drive before you do another install, because if the same problem persists it's either the hard drive itself, or the disc.. And hopefully it is not the disc as XP is not sold anymore..

    If the hard drive is a fine and a new install doesn't help, I'm not sure where to go with it.. Either it is a hard ware problem elsewhere (RAM, CPU?) or the disc itself is actually damaged, though you would generally have an error happen during the copying process if that were the case.
  7. pjamme

    pjamme TS Enthusiast Posts: 208

  8. crone

    crone TS Rookie Topic Starter

    tried all what was suggested no luck tried a friends windows cd same thing strange things is that in the registry sourcepath location is pointing to the e: drive which is the dvd rom
    service packsource points to the e: drive and installation sources pointing to the e: its seems for some reason its not RECOGNISEing the c: seems it thinks the cd rom drive is the location very odd never encountered this before anyone have any other ideas

    edit: i have just see this in the registry cd install reg_dword 0x000001 (1) servicepack install reg_dword 0x0000000 (0)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...