Windows ME is killing me...

By philotius ยท 7 replies
Aug 13, 2005
  1. Trying to install Epson Stylus CX6600 on an older (but above min Req's) ME system. The drivers load fine but I keep getting CMDNINST and CMMCTRL.DLL errors when I try to plug the printer into the USB port. The USB's are working fine with other devices. Tried the microsoft fix by disabling all recommended devices then re-enabling one at a time. Still no good. Any time the printer is plugged in I get these errors. All loads and works great when loaded onto my Sony Viao (also with ME). I have to assume that its a USB control issue but I have no clue what to do to fix that either.

    I can't find any other info on what exactly these messages mean, let alone fixes

    Any help would be much appreciated!!
  2. tdeg

    tdeg TS Rookie Posts: 119

    The best fix is this.

    Windows 2000

    What does the Epson site say?
  3. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Me unfortunately is famous for Driver conflicts.
    I can only recommend deleteing all associated drivers you have for the USB and the Printer , Cleanly, in the Registry and HDD, and wiped off your HDD.
    When you re load each item , Make sure you have nothing else running ,Use the Task manager to shut everything you can, off.
    Otherwise ,update the O/S ?
  4. philotius

    philotius TS Rookie Topic Starter

    I think the OS upgrade is looking better and better. Thanks for the advice. I'll give it a try. Also new development : Tried installing a PCI to USB 2.0 adaptor, getting the exact same error messages.

    Epson site said to download their driver, did that... no help. Still waiting for a tech support reply.
  5. thefighter

    thefighter TS Rookie Posts: 21

  6. philotius

    philotius TS Rookie Topic Starter

    Thanks all for the info but I think my problem goes deeper. I put everything back to my original configuration. My PC works fine. Now when I go to settings and click add new hardware I get a RUNDLL32 caused an error in COMMCNTL.DLL.

    Tried to install a CD burner today to back up for a new OS, I can't even install that. I guess all is lost, need to clean install a new OS.

    The funny thing is that BIOS saw the new drive, I only get the error right before windows starts. I recently installed a firewire card (which works great) I wonder if that may be causing this, as far as driver conflicts.

    By the way, there are no devices flagged in the device manager.

    I'm starting to bug out but I won't let this beat me, it's only a machine....isn't it? All I want is to be able to print that to much to ask?

    (The 16 pound sledge keeps calling me :mad: )
  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Check thru the BIOS ,CMOS setup pages for USB and related items?
    One setting in some BIOS changes the Speed of the USB bus; eg. Hi-speed , Fast change existing setting and try .
    Try the Printer with everything turned off in TaskManager you can, no Tsr's, Wallpaper, Anti virus etc.
  8. philotius

    philotius TS Rookie Topic Starter

    All Better now !!

    Thanks everyone for the great ideas. I learned very much about general computing and the way things are supposed to work from this.

    I ended up Upgrading to XP. I lost some of my files, Kinda bummed, some pics of my son, lots of music and some small budget and accounting programs I wrote. Oh well !!

    Any way, I had to install Sp2 and use most of the drivers from it to run my USB 2.0 card and a couple of other things, but all is now well, except for the fact that I'm still using a stone age computer.

    Best of all the printer works beatifully and my smart wife uploaded most of the pictures to an online storage thingy!!

    Thanks again, I'll be here checking out the rest of the boards perhaps we'll meet again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...