Windows won't install on new hard drive

By rbbibble ยท 17 replies
Dec 31, 2005
  1. After my old hard drive broke I recently installed a new hard drive and I can't get XP to install correctly on it. During the installation process certain files won't install (tosdvd.sys, tsbvcap.sys .... there are more). The windows CD is new so that isn't the problem. Any suggestions?
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Is this a SATA or EIDE hard drive? If EIDE, does it share a controller with another device? If so, did you set the jumper to match the old HDD?
  3. rbbibble

    rbbibble TS Rookie Topic Starter

    It is a SATA drive. The jumpers are set so that it is the master drive and all the cables seem to be installed correctly. I had no problems setting up partitions either through the windows cd or the hard drive cd. Could it be a problem with the DVD drive? Sometimes I get an error message saying, "an attempt was made to write to read only memory," and the windows installation fails.

    Thanks for the feedback.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    sounds like the files need the original install to copy or load
    ignor for now and rerun the dvd software that came with the installed dvd or go to TOSHIBA website and get the stream drivers
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Looks like bad RAM.. Test your RAM, change the hard drive cables, test the hard drive.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    if you can boot to windows after this install
    put install disc back in machine
    go to start /run
    in window type
    scan /scannow
    do search on windows protected files
    if you have a video capture card in machine this may be causing a conflict.
    you don't say what version of xp and service pack ?
    the machine may now have hardware that needs spk2 ?
    the only time I ever had files not copied was a cdrom device can't find anything related to memory failure
    do you have the memory over clocked in bios ?
  7. rbbibble

    rbbibble TS Rookie Topic Starter

    My hardware:

    MSI 865G Neo2 mobo
    2.8 ghz pentium 4
    ati radeon 9800 pro 128mb
    2gb pc 3200 ddr400 RAM
    creative 5.1 sound card
    seagate 7200 rpm hard drive 160 gb
    dvd ROM drive
    pioneer dvd burner

    I tried installing windows on both dvd drives and the same files won't install. It seems unlikely that the drives are both broken and not installing the same files. The hard drive is brand new so that seems like an unlikely culprit. The windows cd is also brand new so that isn't it. My bios settings are default. As far as RAM testing goes, I can't use memtest cuz I don't even have an OS. Is the only other way to test RAM by plugging the chips into a different computer?
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Memtest doesn't need an OS. It would be a useless utility if it did. You write a floppy or a CD and boot memtest directly from that.

    Also, the brand newness of your hard drive does not mean it cannot be defective.
  9. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Try cleaning your Windows CD. Sometimes a smudge, piece of dirt, fingerprint, scratch, etc. will prevent files from installing. Especially since two different optical drives have the same problem with the same files which would be on the same place on the disc.
  10. rbbibble

    rbbibble TS Rookie Topic Starter

    Cleaned disk. Same problem. I'll give memtest a try. Are there any similar utilities for hard drives?
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your hard drive manufacturer has a diagnostic utility available on their website and there are some that work on any brand.
  12. Eko

    Eko TS Rookie

    Try with something else

    Just try a LiveCD or a live DVD (for example, from Knoppix) and see if it manages to boot up. Try to install another operating system first, see if it works. Try Windows 2000.
    Check out in BIOS if there are some devices conflicting. Check out the cables, if they're OK try to clean the CD Rom unit with a special cleaning disk.
    Try to replace your optical drive with another, see what happens then !
  13. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    if the mem test does not show anything
    all I found out was generic memory failures with xp reinstalls
    don't ask me?? but thats what I have found
    try underclocking your memory if test does not show anything
    ps I tried to load a copy on to an old 500 mhz with 2 sticks of memory 1 was a kingston liftime the other a gen brand X
    sure enough
    nodsu got it, the memory got fried on first boot
    machine locked up reboot failed reinstall would not work ,but removed the cheap stick and it booted right up
    go figure
  14. rbbibble

    rbbibble TS Rookie Topic Starter


    Sorry for the delay. Turns out it was a bad memory module. Good call Nodsu. Checked all modules individually with memtest86+. One was found with errors and when I removed that one, I was able to set up windows just fine. For all who haven't checked it out has good articles on setting up windows and hard drive partitioning. My computer is running very nicely right now.

    Thanks all for your posts.
  15. pierrrre

    pierrrre TS Rookie

    Had the same problem couple days ago (Windows would not install because it could not copy some files). The files were different every time i tried to install. I read this thread yesterday, downloaded memtest86 and ran the program from a boot disk. Two of my three sticks of RAM showed errors (lots of them). I removed them and bingo, everything is working as it should be. Windows is installed and my kids are off my back to fix the computer.......

    Thanks for all those who replied to rbbibble, specially NODSU.
  16. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Posts: 156

    that command is actually SFC /scannow for system file checker it will make sure that all major system file are in the correct spot and original
  17. nboogerz

    nboogerz TS Rookie

    Xp pro help

    Hi guys. I'm trying to reinstall windows xp pro using an unoriginal xp disk. Windows does boot from the cd. However when windows goes to start an error message pops up saying windows has to shut down. I have tried all the message suggests such as updating my bios and changing the video card settings. Yet the same error messages appears

    *** STOP: 0x0000007e ( 0x0000005, 0xf76120bf, 0xf7a5e208, 0xf7a50f08)

    *** pci.sys - ADDRESS F7612013F base at F760b000 Datestamp 3b7d855c)

    Really hope someone can help.
  18. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How about the good suggestions: testing the RAM and testing the hard drive?! :p

    Also, since pci.sys is crashing, maybe it's a bad PCI card in your system?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...