Windows XP Hibernation fails with 3gigs RAM

By Boogityboo04
Nov 7, 2007
  1. I just bought two extra gigs of RAM for my Windows XP Professional box and it now refuses to hibernate about every other time I try it. I receive an Insufficient System Resources Exist to Complete the API. error message. Does anybody know how to fix this? I tried the kb909095 hotfix which is supposed to correct this, but when I run the installer it tells me that all my ntkrnl.exe and related files are "invalid". It claims that they are version 5.1.2600.3093, and the hotfix claims to update them to a lower version 5.1.2600.2774.

    Why isn't this working? Isn't this a pretty widespread problem? How can I fix it?
  2. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    First of all...

    What is your old memory specification? ( Manufacturer, Latency, Voltage and Data Speed)

    What is your new memory specification? ( Same as above)

    In most case, you should not mix the memory speed and / or latency. They causes the errors. Mixing the manufacturer never hurts.

    Also did you run the MemTest86 ?
  3. Boogityboo04

    Boogityboo04 TS Rookie Topic Starter Posts: 302

    I don't think my issue is a memory problem. Memtest runs clear and the memory is the same speed. What I am experiencing is a known bug shown here.

    My issue is that the hotfix claims my ntkrnl.exe and other ntos related files are "invalid". I can't get the hotfix to install at all because it thinks that my current ntkrnl.exe is a newer version than what it is supposed to fix.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...