Windows XP installation stability problems with SATA RAID H.D.

By Polders ยท 109 replies
Sep 16, 2004
  1. Jank

    Jank TS Rookie

    Assuming you've done all of the regular stuff . . .

    we might just want to chalk this up to the mystery of nforce chipsets . . . 'cause that's the only thing that a lot of these weird problems have in common (and it's across the board with Epox, Asus and other motherboards as you've probably seen on lots of tech support sights).
    So you've done all the regular stuff such as clear CMOS overnight (not just 10 seconds), isolated motherboard from chasis, one stick of ram that you know to be good, bare essentials installed (floppy, one SATA HD, graphics card, CDROM, RAM), tested PSU for correct voltages, newest BIOS flash, etc?
    I'm tapped out as far as solutions, otherwise.
    It's the nforce chipset curse, I'd reckon.
    Please keep us informed if you ever find a cure, OK?
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    What I don't get is why XP won't save the driver. I don't get why it needs the driver again and again.

    What I would do, when you ARE in Windows.
    I don't remember you mentioning nForce chipset but if you haven't updated that, this is the Unified driver for XP:

    I'm sure you updated the SIL drivers, but make SURE that Device Manager actually shows the new driver, and is not reverting to the old one (because you put the old one back in when you do the F6 thing).
    See if Windows will actually get those drivers to stay put. For example, in Device Manager, go to driver details and write down the names and dates there. Then update the driver and restart. If it fails and you have to hit F6 again, keep comparing the driver details and see what XP is doing to them.

    Other than that I'd have to be sitting in front of it to find out what the heck is going on!
  3. Jank

    Jank TS Rookie

    Virtual drive . . .

    I believe Windows puts the SATA driver on a "virtual drive" when you hit the F6 key. It's not until the actual file transfer from the XP CD to the HD that the driver is actually installed (that's why you're asked a second time during install to put the Sil 3112/3114 floppy in the drive so that the file can be permanently installed, permitting booting to the SATA drive).
    One thing I didn't mention in the last reply: you might want to low level format the drive and check for bad sectors before trying an install. If you can get to an "A" prompt, PowerMax (Maxtor) or Seatools (Seagate) will check out the "health" of the drive and low level format it, too.
    What this procedure will also do is remove conflicting "metadata" (drive connection information) from the drive(s) so that you can start from scratch.
    Other than this, all I can say is that I have never, ever had an easy time installing Maxtor drives (SATA or IDE) on motherboards with nforce2, ultra 400 chipsets . . . that goes for Asus, Epox, Chaintech and Abit MB's. Seagate drives, especially SATA drives, don't seem to mind nforce chips as much as drives from other manufacturers.
    Hope this helps.
  4. bagwafu

    bagwafu TS Rookie

    Vigilante and Jank

    I'm using the latest drivers for the F6 thing and when I go to "update driver" within windows it wont allow it as its says the one's installed are the most current. I will try a drive diagnostic tool as I havent done that yet - might be nice to get rid of any conflicting metadata. I will also update the nvidia chipset. Then we'll see if any of that works! I'll let you know.



    p.s. Vigilante - notice you are in AZ - I'm only in Nevada if you want to come and have a look next time you head west!
  5. Jank

    Jank TS Rookie

    A word of caution . . .

    When updating the nvidia drivers, play special attention to the IDE driver. Some folks are having trouble with playing music on CDs with the driver that comes with this bundle. If you experience problems, go with previous version of this IDE driver (they are available on the XP disk when you manually install IDE drivers).
    Good luck.
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I know it's been a while since you started this thread, but I hope you're still keen on the idea of getting it fixed. Don't give up!

    I'm still curious on the XP CD and F6 thing. I take it you are NOT actually loading Windows, or doing a repair install, or anything like that. I assume after it asks for the disk with the drivers, you just exit setup?

    I don't remember but did you try a soft reboot when it fails? Like when the boot falls apart, just hit ctrl-alt-del to have it restart and it still fails?
    Have you mentioned what your RAID is yet? A stripe or a mirror? Can you just screw the array and put just your one drive in there by itself?
    You might also try resetting the BIOS to defaults in case there is a setting related to SATA or RAID that is interferring.
    Make sure your boot order actually has the proper SATA drive in the list in CMOS.
    For fun you may look at all the CMOS settings just in case something pops out at you.

    It's coming down to the process of elimination. Try just one HDD, reset BIOS, check settings. Trim the system down.

    Also, relating to drivers. The disk you use when you press F6, is that the original motherboard driver? Or a new nForce or SIL driver? You might create a floppy with the new SIL driver and see if XP will retain and use that.

    As a last resort, check your Windows updates, on the chance that MS put out a driver they support better, and maybe that driver will work properly.

    Oh, and I rarely ever leave the state. Matter of fact, I rarely leave anywhere besides my home and office :)

    keep kickin'
  7. bagwafu

    bagwafu TS Rookie

    I am very keen on getting it fixed !

    To answer some of your questions:

    HDDs are 2 120 gig Seagate Barracudas operating at 7200 rpm on a RAID 0 array ie Striped (?).

    When I do the procedure I exit the setup after loading the RAID drivers ie I dont do a repair install (although I did do a couple earlier on when the problem first appeared)

    Boot order is OK. Will try a BIOS default setting to see if that works but doubt it. Had a look through CMOS jumper settings last night but nothing was amiss - also look at all BIOS setting and they seemed OK. Don't want to just use 1 drive as this will mean I lose 18 months worth of stuff. I may do this in June when I get some free time so I can back all the importatnt stuff up on CD but for now I want to keep running both drives as RAID 0.

    I think it may be PSU related however did an online Seagate Scan last night - said the drives had errors but they had no fix. Could not find CHKDSK within Windows (where is it?). Also is there a setting in the BIOS that allows some time between POST and boot ? maybe the drives are not spinning up quickly enough during boot up for the system to see them after the POST on a cold start, maybe indicative of a PSU problem.

    Any thoughts ??


  8. Jank

    Jank TS Rookie

    Check out Seatools.

    The Seagate online HD check said there was something wrong with the drive(s) but can't fix it? That makes sense because you have to be in DOS in order to fix bad sectors (which sounds like the problem with your disk(s)(they can be detected in Windows, however).
    Download Seatools from the Seagate site and follow the instructions for troubleshooting your drives. This tool can check each drive individually, detect bad sectors and then overwrite the sectors (so they are not detectable by your OS--at least that's the theory :haha: ).
    I once had a system that refused to install XP because there were so many bad sectors on the drive. Overwriting the bad sectors enabled me to install the OS, but the drive kept on accumulating the sectors and eventually I had to dump it.
    One word of caution about using Seatools . . . If you check the option to repair the sectors, some or all of those bad puppies may be holding onto some of your files. But I've never had a problem ending up with missing or corrupted files after repairing the sectors (since they were bad, anyway).
    My opinion is that you have unstable voltage problems in the PS, possibly caused by a defective capacitor or two. Can you detect a slight whistling noise from your power supply? That would indicated a bad capacitor.
    Got access to a known-good power supply of at least 350 watts? Try swapping.
  9. bagwafu

    bagwafu TS Rookie

    I did download Seatools but the second floppy didnt work. I didnt have time to go through it again and download to a different floppy but I will later. Will also listen to the PSU to see if there is any whistling. Cheers.
  10. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Ya if you have it set to RAID 0 then it is stripping, which means if one drive goes, your data is caput. The only way to save your data, AND break the RAID, is if you have enough free space on one drive for all your data to be recompiled to. That is if you were to take the RAID off and remove a drive.

    Hard drive checking tools, I'm not sure, may or may not have trouble checking the drives within a RAID setup. For example on a mirror, you're not even supposed to SEE the second drive, let alone scan it. And a stripped set you're only supposed to see ONE drive as well. So I don't know if that would effect the results of a hard drive checker or not. What would seem to be a "fix" of a "problem" may only be the tools not reading the drives properly. Again, I don't know.

    And also, if your "18 months" of data is that important to you, note that you are NOT on a redundant array. If either drive crashes your data is gone! RAID 1 would be your choice for important data, which is a mirror. Data stripping would not help you in the case of an emergency!

  11. Jank

    Jank TS Rookie

    Seatools is a DOS utility . . .

    . . . you fire it up and it detects each drive in the system whether they are IDE or SATA--no matter what RAID setup is invoked. One can work with one drive at a time. Also, if you happen to have, say, a Maxtor IDE drive hooked up in addition to Seagate SATA drives, it will diagnose and fix bad sectors on that drive, too. Checking for bad sectors and fixing them is a two part process invoked by the user--you don't have to fix them if you don't want to.
    If there isn't a Seagate drive in the computer, Seatool will refuse to work, however. Same goes for Maxtor's PowerMax utility--it will check all drives in the system as long as one of them is a Maxtor.
    Each of these utilities is much more "powerful" than ChkDsk in that they are capable of overwriting bad sectors, making them "invisible" to an operating system.
    I've found that these utilities work well except when the HD continues to produce bad sectors. Then it's time for a new hard disk.
  12. Merc14

    Merc14 TS Rookie Posts: 171

    After flashing the BIOS did you go back through the BIOS and adjust everything back to where it should be for your setup?
  13. Jank

    Jank TS Rookie

    Reviewing what has been tried so far, I see that nobody has mentioned the serial ATA jumper on the motherboard (on your motherboard it's located at about the 5 o'clock position next to the battery). Is it in the default position (pins 1 and 2 jumpered)?
  14. bagwafu

    bagwafu TS Rookie

    Merc 14 - yes
    Jank - Yes

    Sorry to be blunt but all is as it should be, it just dont work :(
  15. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    What a weird problem man.

    To simplify this as much as possible, would this statement be correct:

    "XP can't start, because it doesn't have the RAID driver loaded"
    "Once the RAID driver is loaded (F6), Windows works fine"


    If so, then all hardware aside, this would seem to be a software only issue. Coming down to a driver problem in XP.
    I'm afraid my only suggestion at this point would be to reload Windows. Only because that BIOS upgrade could have changed the system layout just enough to where XP couldn't adjust. And a full reload with all new proper drivers, may be the solution.

    Seems to me, XP simply refuses to retain the proper driver once you load it with XP setup. Which means perhaps the registry is being restored? Or permissions for it are wrong? Or Windows thinks it has a bad file and replaces it with an older one?

    This can't be verified however, because you can't get into Windows without loading the right driver, so we won't know what driver XP is trying to load with on a cold boot.

    I'm still trying to figure this one out.
  16. bagwafu

    bagwafu TS Rookie

    Your quote is correct.

    The HDDs are partitioned with a small secondary partition that holds the original version of the PC as it was when I got it. Therefore I'm going to back up all the important stuff to CD then reinstall Windows using the version at this second partition and see if that makes a difference.


  17. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Excellent. When you reload, use all the new drivers you've been downloading thus far.

    Then apparently XP has decided that it won't accept any new drivers for it's own boot partition. So I'm pretty sure, this has got to be the next step. And once your data is succesfully backed up and verified, you have all freedom to play with your drives and RAID setup and get to the bottom of this.

    Good luck, keep us posted on the results.
  18. bagwafu

    bagwafu TS Rookie

    Well -

    It didnt work :mad: Still have the same problem having returned software side of PC to original factory condition. Turned it off overnight then booted up again - exactly the same problem.

    Guess it is a hardware issue. Is the next best thing to to swop out the PSU or change the motherboard ??

    Yours sadly

  19. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I still think maybe you got into a bum BIOS. Keep your eye out for a new one, or E-mail the tech support of whoever.

    I might add again, if you want to experiment. Since you are reloading now I assume you got your data off somehow?
    Reload your XP onto just one HDD with no RAIDing taking place at all. Be sure to do F6 during load, I'm sure you know.
    And does it still crap out on you then with only one drive and not even using RAID?
  20. xabinhas

    xabinhas TS Rookie

    250Gb Western Digital Caviar 2500JD SATA on Gigabyte Dual GA-7A8DW MOBO

    New Here!

    I think this forum is of big help, but i still couldn't find an answer for my problem! I have a Gigabyte Dual GA-7A8DW Mobo with a 250 gb SATA HDD and i'm having a problem. After windows xp was installed i rebooted the pc and as soon as the windows loading screen appears the it restarts by itself. I can only load XP on safe mode. Can it be a PSU problem? Not enough power? i have a 380W Tagan Whisper quiet 20db aPFC. is it enough?

    Can somebody help me please? I'm geeting desperatted! Thanks
  21. Merc14

    Merc14 TS Rookie Posts: 171

    Have you tried resetting the boot order in BIOS?
  22. xabinhas

    xabinhas TS Rookie

    Yes i changed the booting sequence and previously i tried all the steps mentioned on this forum including the sata drivers instalation on the begining of the xp installation by pressing F6, and the HDD was recognized by the system but when the xp is starting to load sudently it reboots by itself.
  23. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    xabinhas, you might want to start a new thread. Your problem is a bit different from the one in this thread.

    However, there are some Recovery Console commands you could try.

    Any luck, Bagwafu?
  24. Jank

    Jank TS Rookie

    A shot in the dark, but . . .

    . . . I had a problem similar to this one a while back. I cured it by clearing the CMOS (leave the jumper off overnight), going into bios and loading setup defaults. Do not change any of the fail safe parameters no matter what. Save and reboot.
    Or, it could be a problem that could be detected by following these instructions: (if you can get into Safe Mode).
  25. bagwafu

    bagwafu TS Rookie

    A local PC expert initially seemed to think it is a duff BIOS chip and advised me to flash my BIOS a few times to different versions. I did this and the problem is still there. He then thinks because it works OK during hot reboots and only loses the RAID array when fully powered down, it is a problem with the MB core voltage - I changed the BIOS battery same problem so now it is a duff motherboard itself (??).

    Please can someone explain about the core voltage thing (he mentioned +5V) and whether you agree a new MB is in order (they are about $30-$50 on Ebay)? I take it some information is stored electrically even when you power right down - does this include the RAID information? My friend thinks it is not a PSU or dodgy HDD problem however I am not convinced.


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...