Windows XP installation stability problems with SATA RAID H.D.

Not open for further replies.
I hope somebody can help me, I just bought 2 identical hard drives Western Digital Raptor 36 Giga Sata drives that I wanted to RAID-0 using the motherboard controller I have on the ASUS A7N8X deluxe which is called Silicon Image Sil 3112A controller, so first of all I plugged the sata wires and I started my PC ( Barton 2500+) and setting up the RAID-0 pressing F4 , this operation was succesfull and the bios recognize the 2 hard drives with no problems at all and no conflict.

After that I started installing Windows XP PRO using the 6 floppies + the one containing the Sata Raid controller drivers necessary for WIN to be recognised, I downloaded these drivers from the ASUS website (after unzipping the file) after a while WIN asked me to insert the floppy containing the drivers since I pressed the F6 option that initially the installing program ask if a SATA RAID OR SCSI controller need to be installed. Windows XP PRO recognised the drivers with the only problem that were not digitally signed and this could be the cause of Windows Instability problems, I pressed to "continue anyway" button and the installation proceeded normally even though the same message advising me of istability problems appeared a couple of times more exactly right before WIN XP PRO ask you the time region you are located etc... At the end the program booted and Windows XP PRO was launched properly. This only happened 3 times because at the fourth time I turned on the PC one blue screen appeared and freezed the system, launching WIN XP PRO in the safe mode was not changing anything, always the blue screen and after that nothing and just rebooting rebooting and rebooting.

So, is there a way I can install WINDOWS XP PRO on my new SATA hd drives with RAID-0 without having this big problem? My modo bios is updated with the latest rev. 1008 so I think the problems are that the raid controller sil 3112a 's drivers are not digitally signeed and this cause the instability that now means no Windows at all because of the blue screen.

Can somebody help me or does somebody have any suggestion?
I would really appreciate your help. Thank you Erwin
Hi i have a problem with my HDD's.I just bought 2 Maxtor 200GB SATA disks
and i tried to make them work as raid.I plugged the disks to the mainboard and the i started my pc.The disks were idintified with no conflict and i turned
on the SATA on RAID feature in Bios and enabled SATA BootROM.Then i created a raid volume as stripe.I started windows installation and pressed F6
to install Raid controller.I have the Asus P4C800 E-Deluxe mainboard.I place the disk with the drivers for the controller in the drive and the when i try to continue installation of windows it says that no hard disks are connected in the computer and promts only to quit.I just bought the hard disks and i'm fricked out.I have updated bios for the mainboard and the drivers that i used for the raid controler are Fasttrack 378 for xp which i have downloaded from asus site.What must i do to make it work?
Hello All,

I am having a similar problem to Gargalakis, tho with an Assus A7N8X-E Deluxe. Have not updated Bios yet nor installed raid drivers as there was no guidance to do it, rather used the onboard raid configuration to set up RAIDstipe.
The discs do not appear in bios anywhere but do in the raid configuration in POST.

Any thoughts gratefully received.
Same problem here

I also am having a problem with my ASUS P4P800 Deluxe. I have RAID 0 set up with two 120 GB Sata Western Digital hard drives. The BIOS recognizes the array but when I go to install Windows XP, I receive the following message "An Internal Setup error occurred. Could not find a place for a swap file. Setup cannot continue. Press ENTER to exit." I'm completely stuck and frustrated.

What is really weird is that one of the drives I was using as non-RAID with an IDE 80GB WD hard drive nad everything was fine. I've been looking eveywhere and no one seems to have an answer to this problem. Anyone have any updates?
update ...

So I got everything to work last night. I simply used a different CD to load Windows and it partioned and formatted the RAID-0 array with no problems. I also loaded the Intel RAID drivers at the begiinning of setup by pushing F6. Be sure to copy your RAID drivers and leave them in the floppy driver until Windows restarts to finish completing the files. Ayway ... onward!
Hi, new here, this forum looks to hold some promise for my problem:

Asus A7N8 Deluxe running 2 RAID 0 HDD. Win XP Pro. SiL 3112 Raid.

Recently had some overheating problems, cleaned out the dust, more ventilation etc. Also flashed the BIOS to the latest version. PC then wouldnt boot, wouldnt recognise the RAID HDDs. So run the Win XP reinstallation, hit F6, loaded the RAID driver(s) from floppy, booted up OK. Whilst power still on PC can reboot OK everytime. After power has been rmoved on full shutdown, subsequent problems rebooting, PC doesnt recognise array again, have to do the whole F6 thing all over again. Have tried various versions of drivers from various sources (Silicon Image Website, ASUS website, MOBO Installation disk etc) to no avail.

Does anyone have any tips? Thanks.


Posts: 1,634   +0
When looking for updated drivers. Try looking for your Silicon Image chip instead of Asus. In case they have a better driver.

You could also try using just one HDD and load Windows on that. If it works, add the second HDD and RAID them after-the-fact.

Just a thought.
Vigilante, thanks for the quick reply.

Windows is already loaded onto the HDD, the only thing I have done is update the BIOS and yet the array is not recognised after a full power down. I have used the drivers off the Silicon Image website, also tried the ASUS drivers, also the ones off the original motherboard disk etc etc all to no avail. I dont really know what else to do hence this request for help.


Posts: 615   +2
Silicon Image 3112 drivers


it's version now, the older drivers and earlier caused data corruption.


Posts: 1,634   +0
RAID can be pretty tricky. It might seem redundant but find a user manual or some type of instruction either from ASUS or Silicon Image for how to set that RAID up in the hardware setup program. Just in case you're missing a step somewhere.

Usually BOTH HDDs have to be identical. At least in size, for some RAID setups.

Also make sure the 2nd HDD is empty and un-partitioned. It may or may not care but you can try.

Hope you get it going soon!


Posts: 615   +2
oh, and there was a BIOS update back in the old days that fixed the problem, so if you had the board a long time and are just now trying the RAID then you may need to update toeh BIOS to 1005, or higher. Think they are at 1007 or 1008 now.
Thanks for your replies

I am running BIOS 1008

Both HDD are identical and the PC has been running flawlessly for 18 months.
All I did was clean out some dust and flash the BIOS and now the RAID array is not recognised upon startup. So I load the Win recovery CD, hit F6, load the drivers, exit the setup, reboot (with power still on) and it works fine. After power off RAID again not recognised, load Win recovery CD, hit F6 etc etc etc

Therefore the windows installation is fine, its just the BIOS (?) can see the RAID drives after a cold reboot.



Posts: 1,634   +0
So are you saying you already HAD a working RAID array? Then it stopped working after a BIOS flash?

In that case the firmware or something may have been updated in such a way as your previous array can't work the same anymore.

Is this hardware RAID or Software RAID in Windows? If it's a windows RAID, you should be able to load the new drivers IN windows, and not have to do the F6 thing. As long as Windows has the new driver when you check Device Manager. Then break and re-create the array, and not try to fix it the way it is.

If it's hardware RAID I would do the same thing. Break the array, then try recreating it.

If it's neither of those, perhaps that latest BIOS was bum and perhaps you need to wait for a new one, or E-mail ASUS or whoever it is and find out what's up.

Whenever I've had a broken RAID array, I almost always have to break it entirely and start over with a new array.
Yes had a working array no problems for 18 months - all went wrong post BIOS flash.

Can you explain what you mean by breaking the array - I think this is what I may have to do.




Posts: 1,634   +0
Well basically, in your RAID setup, turn off RAID, so that the drives are separate again and the setup shows no RAID function at all.

So for example if you go in the setup and is shows one RAID 1 set but is not working, break the array so it's not trying to do anything with your drives. I don't really know the correct term But in setup you should be able to turn off RAID or stop it or kill it or whatever you call it.
That way you can make a new RAID from scratch rather then try to fix the existing setup.

Thanks for the advice will think about it - I dont really want to lose my data. However if that is the only way to get it working again then I may have to.




Posts: 1,634   +0
If you're on a RAID 1 (mirror) you shouldn't lose any data because it's all on the 1st drive. Breaking an array doesn't mean losing data, just stopping the RAID functionality.

If it's a RAID 0 (stripe) then that's a different story. I believe it will put all your data on the one drive, if there is enough space to do it.

Well glad I helped a little. Let us know what your end result was.


Posts: 7   +0
Is the RAID array not recognized or is it the HD's that aren't being listed? I ran into the latter problem recently after cleaning out my case and found that the only thing needed was to reseat the SATA cables (including power cables) into the motherboard and hard drives. Be sure and place the cables in their respective ports on the motherboard because you'll wind up with coflicting metadata which you might be able to resolve with the Resolve Conflict selection.

In reply to you I dont know!
This is what I do and what I see !

Turn on, initial POST - fine.(says Hit Delete to enter BIOS prompt etc etc)
1/2 Second blank screen, then RAID page appears with the RAID BIOS info and just a prompt to Hit F4 for RAID setup (which is useless if I try to do anything) - then boot falls apart.

So - insert Win XP recovery disk - Hit F6 - Load RAID drivers from floppy - Win XP disk continues then gives 3 options - Load Windows / Go to recovery console / Hit F3 to exit setup.

So I hit F3 to exit setup, then machine hot reboots, same initial screen with POST, second screen now sees the HDDs with their details (which is different from when trying to start after a cold shutdown) then Windows loads normally and the PC is fine. Subsequent hot restarts are all good, its only when I try to start after a cold shutdown (ie all power off) that the problem arises.

I'm sure all the cables are securely attached and on the right bits - if not it wouldnt work at all right ?

So confused at the moment!


Posts: 7   +0
Hmmmm. Sort of sounds like start-up current draw . . .

. . . may be the culprit. That is, a power supply that isn't giving enough initial current when cold booting. The motors on those hard drives of your's are really big power consumers--especially at start-up, which could explain the boot process screw-up and then normal operation after things start to hum.
An under-powered power supply would be my guess.
PSU Underperformance

Is there any way of checking how many wigglies the PSU is pushing out vice what it should be pushing out?




Posts: 7   +0
The "easiest" way to test the "power" of your psu . . .

. . . is to add up the total wattage of all the components on your system. I notice that you are running scsi 10000/rpm drives. Those babies suck up lots of current--especially at start-up. Depending upon what else you have in that box of yours, you could be talking about 430 watts minimum for a power supply.
What is the wattage rating of your power supply? If you are at 300 watts or below, it's time to upgrade.
Here's something else to consider . . . on two motherboards that I have worked with (your's and an Epox 8KTA3L) I simply couldn't install Maxtor drives (either IDE or SATA) and have Windows XP install itself. When I switched to Seagate SATA drives, the problem disappeared. May be just a quirk of two motherboards . . . but you never know.
If I can make one general, assumption it's that every system has its idosycracies; no two of them are alike. I've assembled systems that were identical in every respect and ran into totally different problems with each.
The problem is--I think--that things are getting much too complicated for the features they offer. I've run into more problems with my last nvidia2 chipset motherboards than I've experienced with ten non-nvidia boards in the past.
The good news is once you get them tweaked and working . . . they are incredible.
Just keep plugging away and you'll eventually come up with a solution to your problem. At least that's the theory.
Good luck.


Posts: 1,634   +0
[EDIT] Sorry I posted this before I saw the last 4 posts. A PS could be the issue [/EDIT]

That's very odd indeed. I'm wondering if the XP disk thing is what is actually "fixing" it. Because XP doesn't use those drivers until later in the boot process.

When you say "boot falls apart", what do you mean there? Exactly how far DOES it go? Do you get an error? Blank screen?

Secondly, if you hit F4 to enter the RAID config, on a cold boot I guess, what is the status of your array? Does it say whether or not it's functional or "healthy" or does it have an error?
Because here in the RAID setup is where you need to just break the array and have it re-build your data onto just one drive.

To be honest with you, I'm wondering if it's even the RAID that's the problem!
Boot falls apart - various screens with stuff (!) (including a pause with a MAC address showing, also one with Nvidia boot agent or something), always ending up with Disk Boot Failure Insert System Disk.

If hit F4 to enter the RAID config - it says there are no errors and says the array is OK when I try to "fix" it.

I dont think it is the RAID cos after the drivers are loaded using F6 etc it works fine. Maybe it is a PSU problem although the unit is rated at 480W. So dont know what to do - have tried isolating all other pheripherals that use power, still no joy. One thing I could do is have the drives powered on their own cord from the PSU but this is difficult to do without ripping out the guts of the PC and reconfiguring the PSU wiring.

Thanks for your help, any more suggestions?
Not open for further replies.