Windows XP installation stability problems with SATA RAID H.D.

By Polders ยท 109 replies
Sep 16, 2004
  1. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    lol. I am still reluctant to support SATA drives until there is much better support for them. Or at least until they are as easy to use as IDE. To many bugs.

    sundewzer, you might try to get the bios from the global site instead of the USA site. Which is
    Just type A8V Delux in the search bar and select BIOS in the 2nd drop-down. Looks like 1013 is the latest though, so may not matter. But looks like you have the latest version. Double check that your system actually lists that THAT version is installed though. That is was successful. You may even want to flash it again with the same version just to be sure. Use the DOS flash rather than Windows flash version. Make sure your floppies are good with a scandisk on them first.

    Other than that, if you think the BIOS is right and the latest version, I would pull the battery and set the CMOS clear jumper, remove power from the system and let it sit a few minutes. Then set back and boot up into CMOS. Set Fail-Safe defaults. And then from that point go through and set the options you need, such as date-time, CPU speed etc... The boot order too of course.

    Now what happens when you turn it on? Does it even try to get into Windows? Does it go but then error? Does it just say no OS found?
    If it actually goes into Windows to some degree and fails, it may be a driver issue. But if something happens before Windows ever comes into view, it couldn't be a driver. Drivers aren't used outside of Windows. Well, technically they are, but not in the same sence as a Windows driver.
    Anyways, what happens again?
  2. sundewzer

    sundewzer TS Rookie

    bios goes through fine but the it says that there is no boot device insert bootable media. But I fixed the problem. When it flashed the bios it reset all my setting and it had the number one hdd as the ide drive and the sata was set as num two. Once I change that win booted up just fine. Thanks for trying to help though.

    Is there any way to check the running bios version from windows? I do want to check and see if the bios actualy updated. Cause the first bios screen take about 10 sec and it only use to take about 1 and I was hoping the new bios would fix that. Thanks
  3. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Didn't someone suggest boot order a while back? How easy was that?

    Anyway, I think CPUZ will tell you BIOS version from windows:
    Not sure though, but it gives some other cool info.

    Besides that you'll have to see just as you turn the PC on, within a few seconds, what version you have running. You can usually use the "pause" button on the keyboard to stop it so you can look. It will be one of the first lines of text after video card.

    Glad it's working though!
  4. sundewzer

    sundewzer TS Rookie

    I found current bios in system info and it did update. Yes it was quite easy but the thing is that I had changed it and then the bios boot failed and I reloaded the default setting and I didn't event think about it.*bangs head aginst desk* such a waist of time. Ohh well I won't do it again, that is for sure.
  5. sumdum mofo

    sumdum mofo TS Rookie

    sumdum mofo

    I've got a Dell Dimension 8400 with two 400GB SATA drives originally set up as RAID MIRROR. I need to reinstal Windows XP because of some serious problems. However, when I try to do so, it tells me there is no hard disk. I press F6 and install the Intel 82801 drivers like you're supposed to but still no dice.

    The BIOS appears to be configured properly.

    I am able to install Win XP on other IDE drives in this machine no problem.

    I have an SATA to IDE adaptor. I've thought of removing the master drive, installing it as an IDE drive using the converter and installing Win XP on it and then replacing it back into the array without the adaptor. Will that work?

    Ideas, comments, advice are most welcome.

  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Easiest way may be to break the array, use just ONE HDD and use the driver disk during setup. Once setup is complete, plug the other HDD and re-setup the RAID.

    Note that I think there are different drivers you need in Windows setup depending on if you are using RAID or just SATA. This was the case on mine. But both driver selections were available on the ONE diskette. So break the array, use one disk, use your driver. If it doesn't detect, try the other driver on the disk if it shows another one.
    Re-create the array when you get XP onto one of the drives.

  7. Jank

    Jank TS Rookie

    I'm not familiar with this motherboard . . .

    . . . so I'll ask the first, obvious question: Is there a SATA jumper on the board? If so, is it jumped to the SATA position?
  8. shaka aff

    shaka aff TS Rookie

    i got that error

    i have the same screen pop up on me i just got a maxtor 200gb for my new comp im using my xp pro cd and ezreload to boot it. and when i get to start installing xp that error pops up i have no idea what to do plz hlp me.
  9. shaka aff

    shaka aff TS Rookie

    same prob here man i got a 200gb hd maxtor and am trying to get windows xp pro on it and im using ezreload to boot it and cant figure it out i need hlp and yeah im not that good at comps so if u could hlp me out that would be great....
  10. Jank

    Jank TS Rookie

    It's been my experience that the Maxtor drives are the culprit . . .

    . . . if you can, ship back the Maxtor drives and get Seagate SATA drives in their place.
    I know this may sound like a commercial for Seagate . . . but it ain't. It seems that Seagate and Asus go together for some reason.
    And that's the way it is . . .
  11. Kevin121

    Kevin121 TS Rookie

    Here is my situation, can anyone provide any help?:

    I was running a Striped RAID Install on my system:

    ASUS A7N8X-E Deluxe
    2 SATA Seagate Barracuda 120Gb drives.

    One of the drives went bad, and I had to send it away for replacement.

    So I tried to reinstall XP, and when it gets to the drive selection, it still lists 2 seperate 120GB drives, instead of 1 240.

    I tried deleting the RAID set, low level formatting and re-creating the RAID set, still the same thing. (this is using both the default XP driver, and the one downloaded from the ASUS website).

    I installed an IDE drive in the system, installed XP on it and booted.

    I was able to create a partition on a 240 GB drive (made one 12GB, and one with the rest), and formatted them.

    Removed the IDE drive, started the XP install again. When I get to the drive selection, it still lists 2 120 drives, but the 2nd drive has 2 partitions, one 12GB, and one ~212GB. I tried installing on the 12GB partition (again using both drivers), and every time the computer reboots after the initial file copying, there is no operating system to boot from on the HDs.

    Can anyone please help me?

    This is the second time I have had problems with a RAID setup. On my last system (2 80GB WD IDE drives), it worked fine, had a problem, and when I went to reinstall XP (using the same driver disk as the first time), it wouldn't find the drive.

    Is there something that only allows you to install a striped RAID once, and then your out of luck, or is it just something I am doing wrong?

    Any help would be appreciated.

  12. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Shaka Aff - Sounds like XP has the swap set on an old drive. If you can get into Safe Mode, check the swap settings from there, that the swap is set on the primary drive. And not anywhere else.
    Otherwise, maybe the swap file is corrupt, try turning swap all the way off. If not, try deleting the swap file outside of Windows.

    First off, in XP Setup, I don't think you are supposed to use "both" drivers. I assume what you mean is that, during setup when you look on the floppy, you see TWO drivers. Are you are circling back and loading both of them. Not right, you only want to use one. My setup had the same thing. I believe one is a SATA driver and one is for RAID. But since you are not on RAID right now, you just need to load the SATA driver and that's it.

    The two "drives" that XP shows, you sure they are not partitions? Are you trying to load a "fresh" copy of Windows, ie, with a format? If you want to format and have a blank HDD, then, in setup, delete everything XP shows, all those partitions, until just the ONE entry, for your ONE drive, is in the list. Then continue and format. Of course, this erases your drive. Across all the HDDs you have, you are trying to install Windows on one 120gb SATA? Those other drives are not connected, right?

    If in fact you have only ONE drive but XP shows TWO physical drives, that is very odd. If the driver thing doesn't fix it, or deleting partitions, then maybe it is the SATA drive's meta-data. Though I'm not sure how to clear it. Through a utility, someone can explain. When the system first boots and says Press F4 for RAID setup, or something like that, go in that RAID setup and remove and settings that are set.

    Anyhoo, I wrote this in a hurry, hope it helps.
  13. Kevin121

    Kevin121 TS Rookie

    What I meant by both drivers, is I tried installing with the XP drivers (not pressing F6 at startup), and using the drivers from the ASUS site. Same thing both times. I have tried everything I can think of to clear the HD's, including the F4 Utililty (deleted the raid set, low level format each drive individually, and re-creating the raid set), with no luck at all.....

  14. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    How come you are recreating the RAID set? Did you get the replacement HDD back? You don't want ANY sets made if you're trying to load on one HDD.
    In XP setup you DO want to use F6. Make sure the driver you get is on the ROOT of the floppy, and not in a subfolder. All the files must be in the root.
  15. Kevin121

    Kevin121 TS Rookie

    Yes, I got the replacement HDD back from Seagate, and I am trying to re-create the RAID set. I tried using both the F6 to load the drivers (downloaded from the ASUS site), and without using F6. Exact same result both times. Instead of XP Seeing one 240 drive, it sees 2 120 drives.

  16. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    In that case I really think maybe the RAID set isn't fully created yet. You are doing a stripe set, double check your RAID utility and make sure the set looks right and is "healthy" and bla bla. If the RAID set was working XP wouldn't see it that way. And for the driver use the RAID driver and not the SATA driver.
    Anyway, that's just my guess, that the RAID isn't right yet.
  17. Kevin121

    Kevin121 TS Rookie

    If there were a problem with the BIOS setup (which it doesn't show, it lists everything as healty), why does XP read it as one 240gb drive if I boot off an installed XP on a seperate IDE drive, but it reads it as 2 120s during the install? I tried using the exact same driver that is listed for RAID controller in the device manager of the IDE install, and it still reads it as 2 120s during install....

  18. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    My guess may be because XP is reading physical drives. Perhaps because there is no data, there is no striping taking place? XP "sees" two drives, but you are to load it onto only the first one, and striping will take place normally? Just a guess.

    Once Windows is loaded, and actually using the RAID drivers, it won't be trying to reading physical disks any more. And should see just the one drive.

    I've loaded XP onto a mirror set a few times, and it only shows one drive. But I've never loaded onto a Stripe, so that may even be normal behavior. Not sure. Sounds real fishy though.
  19. Ath

    Ath TS Rookie

    Hi, I need help here.
    My mobo: Asus P4P800 - intel 865 chipset
    Bios is the latest stable version(1019)
    I just install a pair of SATA 80gb Maxtor and set them to RAID0.

    I tried to install Win XP Pro but after copying setup files and restarted, the pc cannot boot. It says error reading drive. it asked me to reboot.

    The raid is created correctly and is reconized by win xp setup. I partitioned the strip into 2 partitions, 40 gb and 120gb using my existing WinXP. when i was installing xp into the raid, i unplugged my old existing hdd.

    When i rebooted my pc using existing old os, the installation file is in the new partition. It seems that after rebooting the system cannot read from the raid drive.

    Any idea how to solve this?
  20. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Doesn't sound like you used the correct process. Is XP Pro also on the old HDD? Is your RAID0 set up in Windows or by a hardware RAID controller? In either case, when inside the XP Setup, did you make sure to load RAID drivers as well as SATA drivers? I think you would have to have BOTH loaded. Not 100% sure though.
  21. Ath

    Ath TS Rookie

    when installation i unplug the old ide hdd which has the old xp. the xp installation reconize the sata raid drives.

    the raid was setup using the bios(ctrl+I) and i made the partitions using win xp. 2 partitions: 40gb and 120gb.

    the installation process cannot continue after it copied files and drives into the hdd and restarted. i did not use SATA driver though. maybe i try load that also, but where to find one?

  22. odwoh

    odwoh TS Rookie

    SATA and WinXP

    Well i've had similar results with my P4P800 SE SATA mobo. I have 2x80Gb SATA drives no IDE installed.
    Here are some interesting observations.
    1. Initially installed with Raid 0. Was able to install both WinXP with SP2 and W2K3 with no problems
    2. I found the Raid to be a little unstable and Raid not so practical when it crashes so I switched to non Raid setup. Using the SATA drives in IDE mode.
    3. Attempted to install WinXP/SP2 but it gave me a BSOD. Played around and installed WInXP/SP1 ok and things looked fine for awhile till I started adding a Security Fire Wall and burning apps and then started getting BSODs again.
    4. Switched to W2K3 and things are looking stable once again. Can burn and Zone Alarm Security works fine despite recognizing it as a server.
    So....I surmise that its not a hardware issue per se but crappy code in WinXP .....everytime I think its safe to try XP again it keeps biting me in the backside.....grrrr
  23. pops5150

    pops5150 TS Rookie

    r u using xp pro Service Pack 2?

    it might be the problem.....
  24. Evil_Elvis

    Evil_Elvis TS Rookie

    Re: Raid Install

    I read this on the Winblows web site:

    * Do not install Windows XP Professional on a mirrored system or boot volume. Although the installation completes successfully, Windows XP Professional cannot start because it does not support mirrored volumes.
    I'm not totally sure about this and I wonder if this problem is still applicable with the 64 bit version. I am still looking into the problem myself as I am trying to use an Adaptec 2120s raid card and 2 Compaq 18.2 SCSI 15k rpm hard drives using raid 0. I can get the initial install but after reboot I get nothing.
  25. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I would be surprised if that were the case. As I'm sure plenty of people mirror Pro. Because this is a hardware mirror, XP should not even know a mirror is taking place, and just thinks there is one drive and that's it. Because this isn't a software RAID, which on the server editions can do I think.

    So perhaps load without the RAID driver? Odd, not sure.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...