1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Windows XP installation stability problems with SATA RAID H.D.

By Polders ยท 109 replies
Sep 16, 2004
  1. Evil_Elvis

    Evil_Elvis TS Rookie

    Raid Windows XP 64 install

    Actually after spending some time on the phone with Adaptec tech support and too many "Error Codes: EF Panic Errors!!!" from the Raid card post I went ahead and sent the card back for a new one. I agree with what you said about this being a hardware mirror and look forward to a flawless install when I get my new Adaptec 2120s raid card.
    Thanks for the help.
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Hmm, you say this is 64bit edition? Wonder if that has different RAID handling. Well anyhoo, I hope something starts working soon.

    good luck
  3. mrmojorisin18

    mrmojorisin18 TS Rookie

    Possible Solution...

    I work in a small shop in town...a man brought his machine in with some serious software problems...we decided the most efficient route to take was to format and start from scratch...

    Heres the system specs:
    Wintergreen - brand system(something like that)
    p4 via chipset vt8237 motherboard m952 ver 1.3b
    DVD drive pri master IDE
    80 GB Segway HDD SATA
    512 megs of RAM ...etc...

    I told him to bring in his software bundle that came with the pc...windows xp home (proprietary CD "wintergreen brand" customized system restore) This method of restoring a machine back to its original factory software settings is popular among large computer retailers such as emachines, gateway, and dell...I put the cd in the drive, turned the machine on, booted into the windows setup from the CD..and it said no HDD recognized.

    Anyway, I found the drivers needed to run the onboard SATA controller, put them on a floppy in the correct manner which i wont discuss now (google: sata drivers windows xp install) ...pressed F6 as needed to load 3rd party drivers...then selected from a list the proper drivers for my OS (winxp home)...the installation accepts the drivers, continues on to format the drive..then when its finished it asks for the files off the floppy again saying "cant find file viamraid.sys" which was on the floppy...it simply couldnt find the files it had just used, i was amazed..not having much of another option, i skipped the files it couldnt find on the floppy and tried to continue the installation but got a blue screen STOP 0x7B...

    I wound up having to use another copy of windows XP home v2002 with sp1 on it... in combination with the driver disk pressing F6...for some reason the cd that came with the machine didnt work properly...hopefully this post will save someone the hours i spent figureing...
  4. regnier

    regnier TS Rookie


    I bought a new computer and I got the same problem. After only one
    update from Windows xp the computer has froozen. I decided to start
    windows in safe mode, but could not see where to start to solve the problem.
    After a wide, I decided to install XP again. Impossible because Xp did not
    recognized my disks (two SATA 165 Go). From the web I got information about it
    and manage to turn off the RAID IDE configuration to a normal standard IDE.
    Now I install again XP and it seems ok. Some peolpe advices to turn on RAID
    after successfull installation but since I do not know what means RAID exactly
    I am a bit afraid to try even that.
    My BIOS is so with a standard config and If someone has some advices
    I will be pleased to apply them

    I have also another problem xp doesn not see more than 3071 Mb RAM
    memory and I do not know how to solve that ?

    All the best


    My config:
    ASUS P5WD2 PREMIUM P+ 3 GHz 830 D
    Two 2 GHz DDR2 533Mh (but see only 3071 instead of around 4000)
    LEADTEAK 7800 GTX (graphic card)
    Two 160 GB Sata2 (here I am afraid I should use RAID ? but not sure)
  5. Vash

    Vash TS Rookie

    For people with problems with getting Windows XP to recognise your RAID setup I found a way to do it.

    Use nlite (www.nliteos.com) and add the required SATA / RAID drivers (look in the FAQ (http://www.nliteos.com/faq.html#Q2), note this is only for nforce chipsets but it may/should work for others.

    Then when you install Windows there is no need to use a floppy and F6, handy if like me, your PC doesn't have a floppy drive!

    I used this method and now XP see's my RAID array instead of two HD's!
    Btw, XP was seeing the RAID array as two HD's sized (130/140GB rather than 250GB).

    For my setup I used the latest nforce4 drivers (6.70) and nvidia RAID BIOS 4.81. The mobo itself is a GA-K8N Ultra SLi. And the HD's are SATA 150 HD's - 250GB Seagate Barracuda 7200rpm, 8MB cache. The two disks are in a RAID 0 Stripe.

    The problem seems to be XP doesn't know crap all about SATA drives. Also when you use F6 XP will use those drivers but then discard them and use its own instead of installing them. That's why I used nlite to make a custom install disk that does install them. Consequently using my custom disk XP now sees my RAID array as one disk sized about 465GB!

    Other source/s of information:
  6. Evil_Elvis

    Evil_Elvis TS Rookie

    For your ram problem I'm not sure if this will help but it's either one or the other. Either Windoz XP has a problem with recognizing more than 3 Gigs of ram or it may be your motherboard.
  7. Evil_Elvis

    Evil_Elvis TS Rookie

    As far as my problem with my SCSI raid, I received a new Adaptec raid 2120s card and updated it as well as the drivers during the install and everything worked fine. Thanks for all of the help.
    Actually it worked flawlessly for roughly 3 months untill I added a new Soundblaster X-Fi sound card and it started crashing/ rebooting randomly. After RMA'ing 2 motherboards and 2 power supplies I figured out that my power supply couldn't handle the Amperage loads. To make a long story short I learned some more about motherboard minimum power requirements and power supplies. In the past it really wasn't a big issue for most of us because either we didn't have the hardware or it didn't require that much power.
    Here is a good web page for reference: http://forums.livingwithstyle.com/t241306-choosing-powersupply-long.html

    I am moving from a 500W (Ultra from Tigerdirect) psu to a 600W(Ultra) to an Enermax 620W. It turns out that with all of my hardware I am pulling around 37A.
    And now a new motherboard and psu on its way, hopefully, I will have my system back up and running very soon.
    Here are my specs for my computer:
    ASUS A8N-SLI Deluxe
    (2) OCZ Platinum Series 1GB 184-Pin DDR SDRAM DDR 400 (PC 3200)
    AMD 4400+Athlon X2 cpu retail
    (2) BFG Geforce 7800 GT OC sli gfx
    Adaptec 2120s SCSI raid pcie card
    Ultra 600W X-Finity psu
    (2) Compaq 18.2 gig 15k rpm SCSI hd (for XP 64 os only) Mirrored
    (2) SAMSUNG SpinPoint P Series 250GB 7200 RPM 8MB Cache SATA 3.0Gb/s ( for everything else except OS related info) Mirrored
    Creative Labs Sound Blaster X-Fi sound card
    1 DVD-R/RW+-
    1 standard 3.5" floppy drive
    1 standard Modem
  8. tweakboy

    tweakboy TS Guru Posts: 467

    Your gonna need proper drivers to install them upon your xp installation,
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Please look at the date of threads before posting.

    Regards Howard :cool:
  10. Mikkel315

    Mikkel315 TS Rookie

    Samo - problem on reinstall

    I have been using Raid 0 for a year on a computer with a Asus p4p800 mb.
    I got an error the other nite on a reboot saying command com was corrupted.
    So I was going to reinstal Xp pro as I have on other systems. The raid controller shows the drives as it posts. I press F6 and the system sees the drivers and seems to install them. When i get to the point of a reinstall it says "drives are found and forces me to quite. It does this for the R repair choice and Reinstall. I used norton to check the disks by booting the rescue disks and all the data seems fine.

    Help appreciated
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...