1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Windows XP repair

By PatrickC ยท 4 replies
Dec 9, 2012
Post New Reply
  1. Tried to do a windows update. It failed. Had to reboot from the CD. Started the XP repair. Part way thru it couldn't find a file on the CD. I pressed continued and it froze. Tried to run the XP repair again and it couldn't find an operating system to repair. bootcfg or chkdsk wouldn't work from the console repair ... unrecoverable error. I was able to slave the hard drive on another computer. Couldn't see the slave drive in windows but could from the c: prompt. chkdsk worked fine ... no errors or bad sectors. Looks like the "documents and settings" directory is there and ok. Anyway to do a repair or is a fresh install in order? Thanks.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Lol That's an oddly contradictory set of symptoms. Looks as if the HDD in your PC is unreadable. Slaving it to another PC still unreadable, except in DOS mode. That is hard to understand, but does point to HDD hardware fault. When you say you could see the drive from a C: prompt, are you certain you were looking at the slaved drive, and not simply the c: drive of the donor PC ?
    I recommend you use the extra PC with your HDD slaved on it. Download Eusueus Partition Manager http://www.easeus.com/partition-manager/ to view exactly what is says about your slaved HDD. It might, for instance, be 'hidden' when it needs to be 'primary, system'. You would also be able to do a full disk check on it.
  3. PatrickC

    PatrickC TS Rookie Topic Starter

    Thanks for the reply. Yes, I was looking at the slave drive ... typo on my part calling it the c: drive as it was the g: drive in my case. I was able to back up the "documents and settings" directory. After I did a chkdsk in dos (everything was fine) I was now able to see the slave drive in windows explorer ... very odd. So I tried the repair disk again with the slave drive now the primary drive and it saw the OS. Downloaded all the files ok. Restarted without the bootable CD and got a password error message related to the lsass.exe file. It was late and I should have researched this error message some but instead in my lack of infinite wisdom I tried a fixboot and fixmbr from the recovery console ... big mistake. At that point I could see nothing on the disk either from the repair CD or as a slave drive in my other computer so I did a full install from the bootable CD.

    A couple helpful hints here doing the full install for anyone reading this: 1) make sure you use a XP SP2 bootable CD if you have a large HD (I think over 130Gig) or it won't be able to partition or format the whole HD; 2) Make sure you select and partition the HD before doing the install even if you only want a single partition. I didn't do it at first thinking I only wanted a single partition so I shouldn't have to do it but trying to start windows after the files where copied from the CD caused the computer to continually restart itself and never boot into windows. Doing the partition first solved the problem.

    If anyone has got this far you can hear my little rant on Microsoft. After the install, Internet Explorer would run for a minute, go out to the MSN website, and then proceed to crash. I had no access to the internet through Explorer so I couldn't even download another browser ... lol. I ended up going through the Windows update system and forcing an update to Explore 8 and then it worked ok. I immediately downloaded Google Chrome ... lol.
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    OK, this looks like one of those 'what on earth is going on' situations, which all too often turns out to be a malware infestation. As you seem to have done a reinstall, maybe you are clean now.

    I would also point out is is almost futile to reinstall to SP2 level, as that is now so out-of-date and unsupported as to create more problems than a reinstall solves. I would insist on only an SP3 reinstall CD.
  5. Vipin

    Vipin TS Rookie

    Consider in re-installing the OS via windows recovery disk.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...