Winlogon problem

By 1zoot1 ยท 10 replies
Oct 11, 2010
Post New Reply
  1. hi
    asus p5wd2 premium mb, pentium 4 630+ lga775, 3ghz 2mb cache 800mhz fsb processor, 2gb memory, nvidia geforce 8400gs graphicscard.
    windows xp sp1 updated to sp2 and sp3
    ami bios
    64-0802-000010-00101111-072806-955x-a0229000 y2kc
    work ok till........

    started with avg popping up with a virus notice with winlogon.exe and another i cant remember now.remove one to vault, couldnt remove the winlogon one.
    tried to remove it, but couldn't.. web advice suggested replace with original, tried but may have failed.

    Now windows wont start.gets to splash screen then reboots, and will ad finitum.
    can get <f8> to get safe mode screen..but all options fail..even command prompt safe.
    only option works is <kill reboot on error>
    *** stop: 0xc000021a{fatal system error} windows log on terminated unexpectedly with a status of 0xc0000005 (0x00000000, 0x00000000)
    1. tried xp install disc to get to repair screen, but after it loads the install sweet and starts to run windows, the system halts with another blue screen
    *** stop: 0x0000007b (0xf78d663c, 0xc0000034, 0x00000000,0x00000000)
    2. disconnected main boot drive, replaced with another (non- bootable)..all I have
    still the same as above.
    3. at POST, manage to get <f8> boot options, am able to load win98se start disk...from floppy. with cd support. but only as long as my usb stick drive is not connected...when connected the bios recognises it, but the windows 98se startup disk wont load and hangs mid load.tried makeing it a boot drive but it didnt work.

    so now im of the mind the bios maybe at fault, but i cant seem to be able to load the bios rom file...
    I downloaded afudos 4.36, but when i run afudos /mai i get *error:BIOS does not support afu* so anyone know what might be going on...

  2. 1zoot1

    1zoot1 TS Rookie Topic Starter

    addendum with bios

    I downloaded this bios rom file:


    when flashed with afudos /iP5WD2-ASUS-premium-0806.rom

    starts program then halts
    "error:bios does not support afu"...

  3. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Have you tried to boot in "Last Known Good Configuration" by pressing F8? If not, try that.

    This (0xC000021) is a windows login failure issue.

    Do you have Windows XP Setup CD ?
  4. 1zoot1

    1zoot1 TS Rookie Topic Starter

    I wrote:
    "can get <f8> to get safe mode screen..but all options fail..even command prompt safe."

    I wrote:
    "1. tried xp install disc to get to repair screen, but after it loads the install sweet and starts to run windows, the system halts with another blue screen
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    @ 1zoot1 and Arch -- I'm wondering if the issue might not be the harddrive itself. What say you Arch?
  6. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    I think it is worth trying to use Recovery Console. Have a look at this MS article zoot, see if you can run recovery console from your XP Setup CD to repair your OS.

    Also if you are successfully able to boot with recovery console, perhaps you can extract the login.exe file from XP set cd, and replace the one located on the HDD with it.

    I think there is no harm in checking your HDD's health as well, you can use Partition Wizard's bootable CD, to do just this (not sure you'll be able to find something like this with your HDD's manufacturer but do give it a try).
  7. 1zoot1

    1zoot1 TS Rookie Topic Starter


    thanks for the interest, the hard drive is ok...i think, I used scan disk on the windows 98se boot disks, if the mobo had drivers for win98se I'm sure I'd be able to load that os...its only because the mobo drivers are xp stuck.

    I cant get to the recovery console.

    I put in another drive and tried to install XP on that one, but the setup program fails on error 0x000007b, this is a different drive, its whats makeing me think the bios is at fault...but I've since found out so far, flashing the bios on this board can be problematic..
  8. 1zoot1

    1zoot1 TS Rookie Topic Starter

    ok ive got the recovery just went there...Im amazed....trouble is i have no idea what the admiin password is....ive been useing this os for over 5years, and i moved house since..and i never used it another reason i hate windows.....
  9. 1zoot1

    1zoot1 TS Rookie Topic Starter

    as for the bios, well i found the older version of afudos (ver 1.19(asus v2.38(08.02.26ba))) and I loaded the bios for the board from the asus site... So with crossed fingers i rebooted.. it actually did a disk check with scandisk, fixed a file problem continued to load xp, but alas, as i watched the screen pass the windows welcome screen, goes black before loading the desktop (mouse pointer appears) then the tell tale sound of either the cd or fan powering down and the reboot procedure starts all with a new flashed bios, it cant be a bad bios...back to square one, motherboard maybe..
  10. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Ok, try to boot with minimum hardware, i.e. one memory stick, one hdd, no dvd/cd etc. it may or may not work, but there is no harm in trying.
  11. 1zoot1

    1zoot1 TS Rookie Topic Starter

    WINLOGON problems resolvable? sometimes....

    ok... good news,

    i found out there are a few different "repair" ways going on here.
    1. one is running the original hard drive and pressing <F8>
    2. or booting from the xp disk and running <repair>
    3. and the other is installing xp anew (which then finds you have a previous xp, and offers a continue install or a repair option there...

    1. old drive with xp op on
    boot the normal way and let the process carry through..till it hangs...
    so I reboot and this time press <F8>, for the multiple choice screen of windows in safe mode, or just the command prompt , orfrom a previous known good point etc...all of which failed. except the one that says kill reboot on error (or something like that), taking this choice the loading now halts but with a blue screen and the message:
    "*** stop: 0xc000021a{fatal system error} windows log on terminated unexpectedly with a status of 0xc0000005 (0x00000000, 0x00000000)"

    I load the xp op install disk and run it...
    "set up will now check system and install stuff...etc but after its loaded all the "suite" stuff a choice menu appears cos it finds a previous installed version on , 1. install new, 2 repair, 3 quit.

    1. I try (1.install ), (3.quit) is not an option, (2. repair) hangs so 1.(cos im thinking its all crap anyway)...

    but it fails with the blue screen and message:
    *** stop: 0x0000007b (0xf78d663c, 0xc0000034, 0x00000000,0x00000000)
    a different one the above.

    so I'm getting no where...
    having an idea because the computer isnt dead, but can load stuff, im thinking hardware connection problems or bios problems...
    I disconnect drives, connect different ones, but no change.....

    what the hell.....

    I load an old win 98se rescue disk, knowing that the asus mb drivers are winxp drivers only so with 89se id never be able to load the correct mb drivers..., but I'm haveing problems loading the disk, sometimes it did and others it didnt, what was going on i thought,,

    until i noticed my stick drive usage, cos i was getting data and files off the internet using my wife's notebook pc, which had neither a floppy drive or disk drive and only usb ports, so i thought maybe using the usb ports on mine, as the bios supported a boot from a stick drive, though that option failed anyway.....

    but through trial and error I find out that when the usb stick drive is connected the rescue disk wont load, but disconnecting the stick drive, the rescue disk loads completely with cd support.... so there goes the usb option ...dam

    but what i do do, is download the bios program and flash loader onto a stick drive, burn it onto a cd, useing my wifes other computer...her laptop..(she ISN'T pleased, as shes using ah well needs must are needs be, after burning the cd's i copy them from my cd drive (working with win98se with cd support) onto my floppy disk drive. then run the floppy to flash the bios. so what happens in the future when floppies are no longer available, we're building up trouble for the future...i can see it now..

    so anyway searching for the correct bios and a flash program, is no easy matter i can say. as the the main protagonists such as AMI or ASUS or INTEL.. you know, the main guys, are as useful as the proverbial chocolate fire a couple of words.. absolutely useless.

    anyway, I find the bios I'm told I need, I also find out that i need to find the correct flash program (and I'm thinking ."what the hell is wrong with these people, do they do this obscure maze dance on purpose"). I eventually manage to flash this new bios, so I know now the bios is ok.

    BUT... the bios turns out to be fairly old, but after loading it, it seem perfectly fine...

    It seems its not always best to update you drivers, it depends what your doing, and anyway trying to find drivers these days is a nightmare, most sites INSIST you download their driver search program and tell you which drivers are out of date, well many of those just look at some list or other , because once i was told that my ATI graphics card drivers needed updating, except i was using an nvidia graphics card, and those drivers were a hang over from a year before when i did have an ATI card, so this prog was just checking everything not just what was being used, so treat these programs with care...

    Just like those reg scan progs that say you've got 300 errors in your registry, but your own scanner says its fine, and you got your scanner cos it found 300 errors in the first place before you had a scanner,


    In order not no confuse the loading on boot up, I stuck to loading win98se rescue disk with cd support, and then ran the xp cd, this time at the menu for install, repair, exit, i choose install, and see what happens, after a bit another menu appears asking to choose an op system, as there's only one anyway, so...

    i choose windows xp, and let it continue, but then another menu appears saying continue installing or "repair" (this is a different repair option to the last one, maybe because of the placement in the install sequence, i dont know), anyway i choose it lets see what happens.....and lo and behold it continues on its merry way and does the biz....I actually get windows loaded, and hey presto..there's my desktop, a few icons lost their progs, cos of rearranging the other drives i disconnected and reconnected along the way, the dvd, cd, the other hard drive..but thats ok....

    but not all that disastrous, cos id kept most important installed stuff on the main c drive, and everything else i install various programs such as browsers, email clients, nero, adobe etc, are all on the other drives..just a question of redirection..funnily enough, my machine seems a bit faster at times too..

    I think I had 2 problems that were interacting with each other, one was a bios problem, and the other was a windows software problem, in which i couldnt correct one without first correcting the other, cyclic errors, i seemed to have been able to get in the middle and work both ways ...

    so i can now close this thread (written on the very computer i was trying to fix, and hope others can gleen some obscure help from it


Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...