Wireless internet problem after reformatting

By monkeyrpn ยท 7 replies
Nov 10, 2007
  1. Hi all, I have a dilemma with my wireless internet.

    I have a D-link DI-524 router upstairs in my dad's office. Our Shaw cable modem is hooked up to it, and my dad's PC is hooked up to the DI-524 router via Ethernet. I have one PC downstairs in the basement connected to the internet via the D-Link DWL-122 Wireless Adapter. In addition, I have 2 MacBooks, and 2 iPhones that would access this internet network also.

    Both PCs are running Windows XP Pro.

    My problem is with the PC downstairs in the basement. About a year ago when I first got the router/adapter bundle, the connections were great. I opened up ports for my downloads, and I was getting exceptional speeds. However, problems with the connections starts to arise about 4 months ago. Downloads have slowed down... and I find that I often have to "repair" or unplug and replug the adapter to get a connection. My dad's PC was fine, and my Macbooks sometimes stalls. The downstairs PC was getting so slow and annoying, also for some strange reason, the USB adapter started to clash with my other USB devices. For example, when I plug in my camera or my external harddrive, the internet will fail, and the USB adapter will become unresponsive. So I reformatted it last week, hoping that would solve the problem.

    The problem did not go away. At first, the USB adapter will still clash with other USB devices. I updated the adapter firmware, and moved the adapter and other devices to different ports, that seemed to have solved the clashing problem.

    But the internet connection is still unstable. After reformatting, I was trying to download my firewall program and Spybot program. But the downloads constantly stops halfway, no matter which mirror I use. After multiple tries, I finally got the programs downloaded. I ran Spybot and my AntiVir programs and found no malwares or viruses. I finally was able to download Firefox, and the downloads from websites seems to work fine... that is... if I can get a webpage open~

    What I'm experiencing now is that Firefox (same with IE) will load a couple of pages fine... then I would get error messages like "page not found".... it doesn't matter which website I try to access. At the same time, my downloads with ABC will continue to trudge along. So it's not that I have lost connection... just that my browsers won't load pages properly. I've tried unintalling and reintalling Firefox. That didn't fix it.

    Things just continue to go downhill... my downloads with ABC are down to a crawl... about 0.3kb/s... that's ridiculous with a cable modem. And it used to be an average of 90kb/s with ports forwarded. My Macbooks are still downloading fine tho. I didn't do any port fowarding with the Macbooks and I'm getting avg of 15-20kb/s.

    Can anyone shed any light to my problem? I'm very frustrated. Thanks in advance.
  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

  3. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    Have you got a new Cordless Phone, or some other Wireless gadget around the time it went haywire? {Maybe the neighbours have?}

    You could try changing the broadcast channel in the Router and see if that helps.
  4. monkeyrpn

    monkeyrpn TS Rookie Topic Starter

    Yeah, I seem to have more problems after getting our 2 iPhones.

    How do I go about changing the broadcast channel?

  5. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    Log into the Router {you can find it by START/RUN type CMD , then type IPCONFIG /ALL in the DOS Box.

    It should be the DNS Address. Type that into the Address Bar of a Browser, and you should reach the Login Page of the Router. Depending on the Brand, the Default is usually admin password . Then look in the Wireless section, and change the channel. Reboot it to save settings {should be a "Save & Reboot option there}.

    The Wireless devices should pick it up as per normal {and hopefully back to speed!}
  6. monkeyrpn

    monkeyrpn TS Rookie Topic Starter

    Thanks~ I tried that and changed the channel. Firefox loads pages perfectly fine, then in about 20-30 mins after, it fails to load pages again. I left it, and it was fine again this morning. Does anyone have any idea why this is happening?

    Also, what does changing the channel actually do anyway? What does "channel" mean? Thanks a lot.
  7. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Sounds like you're getting interference; some other device nearby (eg wireless house phone) or a neighbor with a wireless connection.

    Channel: the 2.4gb band is (domestically) divided into eleven specific frequencies
    or channels. The default is typcially #6 while some routers have a default of
    #1 or #11.

    Normally we pick 1,6, or 11, but if you're having problems, try #4 or #9.
  8. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    Don't know why it'd be dropping out... You could try going into Control Panel / Networking and Right Click on the Wireless Card. Then click on the top "Configure" button, and go to the Power Management Tab. UNtick "turn off to save Power" or whatever it's called- that may help.

    Changing the Channel just changes the Frequency it broadcasts at..

    ie 2.4xxx GHz to 2.4xyz GHz

    Your Cordless phone or something was probably using the same Frequency {or one pretty close} and interfering with the signal.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...